sommeprod rechrce par rapport à une colonne

Le
AnB
Bonjour

avec une formule sommeprod je cherche à recupérer des données se trouvant
dans différentes colonnes sans avoir à nommer les colonnes du tableau

en tapant le N° de colonne qui se trouve dans une cellule (a1), je voudrais
additionner les montant de cette colonne pour tout les articles.

par ex : sommeprod(art="banane")*(colonne()¡)

merci pour votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #4960121
Bonjour
Je crains que ce système ne fonctionne pas car Sommeprod n'accepte pas les
colonnes entières. De plus, la colonne choisie devra commencer et finir à
la même ligne que celle nommée article.
Ensuite, il n'est guère plus malaisé d'écrire (b3:b100) que colonne(b) qui
n'est pas (AMHA) compréhensible par Excel.
--
Bien amicalmement,
Le vin est au repas ce que le parfum est à la femme.

Jacquouille.

"AnB"
Bonjour

avec une formule sommeprod je cherche à recupérer des données se trouvant
dans différentes colonnes sans avoir à nommer les colonnes du tableau

en tapant le N° de colonne qui se trouve dans une cellule (a1), je
voudrais additionner les montant de cette colonne pour tout les articles.

par ex : sommeprod(art="banane")*(colonne()¡)

merci pour votre aide






garnote
Le #4960091
Salut,

En attendant quelque chose de moins fou :-)

Si en A1, tu écris une lettre représentant la colonne qui t'intéresse :
=SOMMEPROD((art="banane")*(INDIRECT(A1&"1:"&A1&LIGNES(art))))

Si en A1, tu écris un nombre représentant la colonne qui t'intéresse :
=SOMMEPROD((art="banane")*(INDIRECT(CAR(A1+96)&"1:"&CAR(A1+96)&LIGNES(art))))

Serge


"AnB"
Bonjour

avec une formule sommeprod je cherche à recupérer des données se trouvant dans différentes colonnes sans avoir à nommer les
colonnes du tableau

en tapant le N° de colonne qui se trouve dans une cellule (a1), je voudrais additionner les montant de cette colonne pour tout les
articles.

par ex : sommeprod(art="banane")*(colonne()¡)

merci pour votre aide






garnote
Le #4960051
Oups!
Mes folies fonctionnent seulement si ta plage nommée « art »
débute sur la première ligne d'une colonne.

"garnote"
Salut,

En attendant quelque chose de moins fou :-)

Si en A1, tu écris une lettre représentant la colonne qui t'intéresse :
=SOMMEPROD((art="banane")*(INDIRECT(A1&"1:"&A1&LIGNES(art))))

Si en A1, tu écris un nombre représentant la colonne qui t'intéresse :
=SOMMEPROD((art="banane")*(INDIRECT(CAR(A1+96)&"1:"&CAR(A1+96)&LIGNES(art))))

Serge


"AnB"
Bonjour

avec une formule sommeprod je cherche à recupérer des données se trouvant dans différentes colonnes sans avoir à nommer les
colonnes du tableau

en tapant le N° de colonne qui se trouve dans une cellule (a1), je voudrais additionner les montant de cette colonne pour tout
les articles.

par ex : sommeprod(art="banane")*(colonne()¡)

merci pour votre aide










garnote
Le #4959971
Solution générale avant d'ëtre ridiculisé par une autre formule
contenant un nombre négligeable de caractères ;-)

Si en A1, la colonne est représentée par une ou deux lettres,
entre cette formule en B1 :
¡&LIGNE(INDEX(art;1;1))&":"&A1&LIGNE(INDEX(art;1;1))+LIGNES(art)-1
et celle-ci ailleurs :
=SOMMEPROD((art="banane")*(INDIRECT(B1)))

Si en A1, la colonne est représentée par un nombre,
entre cette formule en B1 :
=STXT(ADRESSE(1;A1;4);1;NBCAR(ADRESSE(1;A1;4))-1)&LIGNE(INDEX(art;1;1))&":"&STXT(ADRESSE(1;A1;4);1;NBCAR(ADRESSE(1;A1;4))-1)&LIGNE(INDEX(art;1;1))+LIGNES(art)-1
et celle-ci ailleurs :
=SOMMEPROD((art="banane")*(INDIRECT(B1)))

Il va sans dire que tout ça me semble un peu inutile !

Serge



"AnB"
Bonjour

avec une formule sommeprod je cherche à recupérer des données se trouvant dans différentes colonnes sans avoir à nommer les
colonnes du tableau

en tapant le N° de colonne qui se trouve dans une cellule (a1), je voudrais additionner les montant de cette colonne pour tout les
articles.

par ex : sommeprod(art="banane")*(colonne()¡)

merci pour votre aide






Jacquouille
Le #4959961
Meuh non, meuh non, Serge.
Cela fait le ménage dans les méninges....-)
--
Bien amicalmement,
Le vin est au repas ce que le parfum est à la femme.

Jacquouille.

"garnote"
Il va sans dire que tout ça me semble un peu inutile !

Serge


garnote
Le #4959921
;-)))

Grand ménage !

Serge


"Jacquouille"
Meuh non, meuh non, Serge.
Cela fait le ménage dans les méninges....-)
--
Bien amicalmement,
Le vin est au repas ce que le parfum est à la femme.

Jacquouille.

"garnote"
Il va sans dire que tout ça me semble un peu inutile !

Serge






Publicité
Poster une réponse
Anonyme