son muet avec pulseaudio

Le
Marc Siramy
--00163641670f4989280470122edd
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,

j'ai le soucis suivant :

Le son est activé partout dixit alsamixer et l'appliquette de contrôle =
de
volume de PulseAudio.
Si je relance alsa, j'entends un craquement dans mes hauts-parleurs.n'ont
pas rendu l'âme

et quand je joue un fichier son, je vois varier le niveau du signal du son
dans le "pulseAudio Volume Meter". MAIS aucun son n'est audible.

J'ai essayé tous les réglages possibles dans pulseaudio (multicast, vir=
tual
output device ),
aucune combinaison de réglages ne fonctionne.

J'ai pensé aussi à purger les paquets pulseaudio et pulseaudio-utils, m=
ais
cela supprimerait pas
mal de dépendances.
De fait, peut on forcer la purge d'un paquet sans supprimer également les
paquets qui en dépendent ?


--
Marc

--00163641670f4989280470122edd
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Bonjour,<br><br>j&#39;ai le soucis suivant :<br><br>Le son est activé par=
tout dixit alsamixer et l&#39;appliquette de contrôle de volume de PulseA=
udio.<br>Si je relance alsa, j&#39;entends un craquement dans mes hauts-par=
leurs.n&#39;ont pas rendu l&#39;âme<br>

<br>et quand je joue un fichier son, je vois varier le niveau du signal du =
son<br>
dans le &quot;pulseAudio Volume Meter&quot;. MAIS aucun son n&#39;est audib=
le.<br><br>J&#39;ai essayé tous les réglages possibles dans pulseaudio =
(multicast, virtual output device ),<br>aucune combinaison de réglages=
ne fonctionne.<br>

<br>J&#39;ai pensé aussi à purger les paquets pulseaudio et pulseaudio-=
utils, mais cela supprimerait pas<br>mal de dépendances. <br>De fait, peu=
t on forcer la purge d&#39;un paquet sans supprimer également les paquets=
qui en dépendent ?<br>

<br><br>--<br>Marc<br><br>

--00163641670f4989280470122edd--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc SIramy
Le #19875761
Marc Siramy a écrit :
Bonjour,

j'ai le soucis suivant :

Le son est activé partout dixit alsamixer et l'appliquette de contrôle
de volume de PulseAudio.
Si je relance alsa, j'entends un craquement dans mes
hauts-parleurs.n'ont pas rendu l'âme

et quand je joue un fichier son, je vois varier le niveau du signal du son
dans le "pulseAudio Volume Meter". MAIS aucun son n'est audible.

J'ai essayé tous les réglages possibles dans pulseaudio (multicast,
virtual output device ...),
aucune combinaison de réglages ne fonctionne.

J'ai pensé aussi à purger les paquets pulseaudio et pulseaudio-utils,
mais cela supprimerait pas
mal de dépendances.
De fait, peut on forcer la purge d'un paquet sans supprimer également
les paquets qui en dépendent ?



ça ne fonctionne toujours pas :
* après avoir purgé tout ce qui concernait pulseaudio
-> toujours pas de son audible avec alsa seul
* après purge de alsa, réinstallation de alsa et de pulseaudio
-> le son est devenu à nouveau audible
* puis, après reboot,
-> je n'ai à nouveau plus de son.

Je suis preneur de toute piste ...

Marc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Marc SIramy
Le #19883731
Marc Siramy a écrit :


Le son est activé partout dixit alsamixer et l'appliquette de
contrôle de volume de PulseAudio.
Si je relance alsa, j'entends un craquement dans mes
hauts-parleurs.n'ont pas rendu l'âme

et quand je joue un fichier son, je vois varier le niveau du signal
du son
dans le "pulseAudio Volume Meter". MAIS aucun son n'est audible.





La solution a été donnée sur la mailing-list anglophone (
http://linux.derkeiler.com/Mailing-Lists/Debian/2005-06/3576.html ).

J'ai testé, ça fonctionne, alors voici mon feedback :

le problème venait non pas de pulseaudio mais de kde + alsa .
c.à.d que le fait de se logguer sous kde avec certains settings
utilisateurs génère un fichier ' /var/lib/alsa/asound.state ' qui a
curieusement pour effet de stopper la sortie son !!!
Stopper le démon alsa, supprimer ce fichier puis relancer alsa permet
d'avoir à nouveau des sons audibles .. .. jusqu'au prochain login sous
kde. Pour supprimer définitivement le problème, la solution la plus
simple est de supprimer ses settings utilisateurs pour kde.

--
Marc











--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Zuthos
Le #19891831
--itqfrb9Qq3wY07cp
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Marc SIramy a écrit :
| La solution a été donnée sur la mailing-list anglophone (
| http://linux.derkeiler.com/Mailing-Lists/Debian/2005-06/3576.html ).
|
| J'ai testé, ça fonctionne, alors voici mon feedback :
|
| le problème venait non pas de pulseaudio mais de kde + alsa .
| c.à.d que le fait de se logguer sous kde avec certains settings
| utilisateurs génère un fichier ' /var/lib/alsa/asound.state ' q ui a
| curieusement pour effet de stopper la sortie son !!!
| Stopper le démon alsa, supprimer ce fichier puis relancer alsa
| permet d'avoir à nouveau des sons audibles .. .. jusqu'au prochain
| login sous kde. Pour supprimer définitivement le problème, la
| solution la plus simple est de supprimer ses settings utilisateurs
| pour kde.
|
| --
| Marc
|

Bonjour,

Mon probléme est légérement différent.
Je n'utilise pas kde, mais gnome.

Toute les applications de gnome ne donne aucun son.
Pourtant, mplayer par exemple fonctionne parfaitement.

Pulseaudio ne me donne aucune erreur.

Si quelqu'un a une idée? Une pisqte??

Merci d'avance.

Ps: Je précise avoir essayer de supprimer le fichier
' /var/lib/alsa/asound.state ' puis, relancer alsa sans que cela ne ré solve le probléme même ponctuellement.

--itqfrb9Qq3wY07cp
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkp68HYACgkQIBQYI2ra+uvYwQCfX980wIJvqusU5bArJWYwG1VU
Gg8AmQEWoB2PZ4vue5cdknP6xEhhD23A
=rs9z
-----END PGP SIGNATURE-----

--itqfrb9Qq3wY07cp--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Jean-Yves F. Barbier
Le #19893151
...
Toute les applications de gnome ne donne aucun son.
Pourtant, mplayer par exemple fonctionne parfaitement.



bon, c'est déjà ça; as-tu bien suivi le howto de chez pulseaudio (modif de
/etc/asound.conf notamment)?

Il-y-a des chances que tes voies soient mutées (ça m'arrive avec le mute de xine,
qui agit au niveau Gal et pas juste sur son canal: flemme de chger la conf :)

Commence par lancer alsamixer dans une console en root, puis vérifie si tout
est ok.

Si ça suffit, enchaîne avec un alsactl store, histoire de retrouver la même conf
lors d'un reboot éventuel.

--
The mind of the fundamentalist is like the pupil of the eye:
the more light you pour on it, the more it will contract.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme