sortie avidemux impossible a lire avec mplayer

Le
Marc Dejardin
Bonjour,
J'essaie d'utiliser avidemux2 pour supprimer les parties inintéressantes
d'un enregistrement TNT.
mencoder -endpos 2:00:00 --oac copy -ovc copy -o tmp.avi dvb://ARTE
Le fichier tmp.avi est lisible par mplayer

dans avidemux, je choisi aussi le mode copy pour la video et l'audio en
sortie, je supprime les pubs etc et j'écris le fichier tmp2.avi

Le fichier tmp2.avi n'est pas lisible par mplayer.
J'ai le message :
FATAL: Could not initialize video filters (-vf) or video output (-vo).

Je ne comprends pas ce qui cloche.
Si vous avez une idée, je suis preneur.
Le but est d'encoder en x264 le fichier expurgé.

M.D.

PS: vous le resultat de mencoder avec l'option -v

mencoder -profile x264 -v -o Vive_la_bombe.avi Vive_la_bombe_raw2.avi
MEncoder 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Genuine Intel(R) CPU T2300 @ 1.66GHz (Family: 6, Model:
14, Stepping: 8)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
init_freetype
get_path('font/font.desc') -> '/home/dejardin/.mplayer/font/font.desc'
font: can't open file: /home/dejardin/.mplayer/font/font.desc
Bitmap font /usr/share/mplayer/font/font.desc loaded successfully! (206
chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
[file] File size is 2275456940 bytes
STREAM: [file] Vive_la_bombe_raw2.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
success: format: 0 data: 0x0 - 0x87a0b7ac
AVI file format detected.
list_end=0x2218
= AVI Header =
us/frame: 40000 (fps%.000)
max bytes/sec: 0
padding: 0
MainAVIHeader.dwFlags: (272) HAS_INDEX IS_INTERLEAVED
frames total: 129630 initial: 0
streams: 2
Suggested BufferSize: 0
Size: 544 x 576
==
list_end=0x112C
==> Found video stream: 0
STREAM Header ==
Type: vids FCC:  (10000002)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 0
Rate: 25000/1000 = 25.000
Start: 0 Len: 129630
Suggested BufferSize: 116895
Quality 0
Sample size: 0
==
Found 'bih', 40 bytes of 40
= VIDEO Format
biSize 40
biWidth 544
biHeight 576
biPlanes 1
biBitCount 24
biCompression 268435458=''
biSizeImage 940032

list_end=0x2200
==> Found audio stream: 1
STREAM Header ==
Type: auds FCC: (0)
Flags: 0
Priority: 0 Language: 0
InitialFrames: 0
Rate: 24000/1 = 24000.000
Start: 0 Len: 124447680
Suggested BufferSize: 8000
Quality -1
Sample size: 1
==
Found 'wf', 16 bytes of 18
= WAVE Format =
Format Tag: 80 (0x50)
Channels: 2
Samplerate: 48000
avg byte/sec: 24000
Block align: 1
bits/sample: 16
cbSize: 0
==
list_end=0x874C52A4
Found movie at 0x2224 - 0x874C52A4
Reading INDEX block, 345680 chunks for 129630 frames (fpos"69926060).
AVI index offset: 0x2220 (movi=0x2224 idx0=0x4 idx1=0x201E)
Auto-selected AVI video ID = 0
Auto-selected AVI audio ID = 1
AVI: Searching for audio stream (id:1)
XXX initial v_pts=0.000 a_pos=0 (0.000)
AVI video size!40476935 (129630) audio size4444800 (124444800)
VIDEO: [] 544x576 24bpp 25.000 fps 3302.4 kbps (403.1 kbyte/s)
[V] filefmt:3 fourcc:0x10000002 size:544x576 fps:25.00 ftime:=0.0400
==
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: made decode tables with MMX optimization
mp3lib: using SSE optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer II, 48000 Hz 192 kbit Joint-Stereo, BPF: 576
Channels: 2, copyright: Yes, original: Yes, CRC: Yes, emphasis: 0
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 544 x 576 (preferred colorspace: Mpeg PES)
Trying filter chain: expand x264
Could not find matching colorspace - retrying with -vf scale
Opening video filter: [scale]
SwScale params: -1 x -1 (-1=no scaling)
Trying filter chain: scale expand x264
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
LAME 3.97 32bits (http://www.mp3dev.org/)
CPU features: MMX (ASM used), SSE, SSE2
Using polyphase lowpass filter, transition band: 19548 Hz - 20129 Hz

misc:

scaling: 1
ch0 (left) scaling: 0
ch1 (right) scaling: 0
filter type: 0
quantization: xr^3/4
huffman search: normal
experimental Y=0


stream format:

MPEG-1 Layer 3
2 channel - joint stereo
padding: all
variable bitrate - VBR rh (default)


psychoacoustic:

using psychoacoustic model: 1
psychoacoustic model: NSPsytune
tonality estimation limit: 8871.700195 Hz (not relevant)
using short blocks: channel coupled
subblock gain: 1
adjust masking: -4.2 dB
adjust masking short: -6.3 dB
quantization comparison: 9
^ comparison short blocks: 9
noise shaping: 1
^ amplification: 0
^ stopping: 0
ATH: using
^ type: 4
^ shape: 1 (only for type 4)
^ level adjustement: -0.48
^ adjust type: 3
^ adjust sensitivity power: 1.000000
^ adapt threshold type: 2
experimental psy tunings by Naoki Shibata
adjust masking bass=0 dB, alto=0 dB, treble=0 dB, sfb21=5.25 dB
using temporal masking effect: yes
interchannel masking ratio: 0


MP3 audio selected.
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le

Exiting
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc Dejardin
Le #1878631
Bonjour,
J'essaie d'utiliser avidemux2 pour supprimer les parties inintéressantes
d'un enregistrement TNT.
mencoder -endpos 2:00:00 --oac copy -ovc copy -o tmp.avi dvb://ARTE
Le fichier tmp.avi est lisible par mplayer

dans avidemux, je choisi aussi le mode copy pour la video et l'audio en
sortie, je supprime les pubs etc et j'écris le fichier tmp2.avi

Le fichier tmp2.avi n'est pas lisible par mplayer.
J'ai le message :
FATAL: Could not initialize video filters (-vf) or video output (-vo).



J'ai peut-être un début de réponse :
En fonction de la façon dont je coupe les morceaux de videos
indésirables, ça marche ou ça marche pas.
Il semble que si la première frame du fichier est une Frame I, mplayer
est content, par contre, si la première frame est une frame B ou P,
mplayer ne veut pas lire le fichier.

Si c'est ça la raison, je trouve que le message d'erreur n'est pas très
explicite... Et je ne comprends pas pourquoi le programme ne saute pas
les premières frame jusqu'à trouver une frame I.

M.D.

bkgl
Le #1877898
Marc Dejardin wrote:
Bonjour,
Pareil,

J'essaie d'utiliser avidemux2 pour supprimer les parties inintéressantes
d'un enregistrement TNT.
mencoder -endpos 2:00:00 --oac copy -ovc copy -o tmp.avi dvb://ARTE
Le fichier tmp.avi est lisible par mplayer

dans avidemux, je choisi aussi le mode copy pour la video et l'audio en
sortie, je supprime les pubs etc et j'écris le fichier tmp2.avi
C'est ce que je fais pour enregistrer la TNT et couper la pub, et je

n'ai pas ce problème. Par contre j'ai une vieille version d'avidemux
(2.0.x) que je n'ai jamais eu le courage de mettre à jour.
As-tu essayé de faire un Rebuild frames (I & B) dans avidemux avant
d'enregistrer ?
Ou alors mencoder fichier.avi -idx -oac copy -ovc copy -o nouveau.avi
pour peut-être réparer les fichiers ?

Publicité
Poster une réponse
Anonyme