Sortie optique Mcbook pro qui ne fonctionne pas?

Le
philming
Salut !
J'ai un MacBook Pro penryn premier du nom, sur lequel je branche un
cable optique (jack-toslink) relié à un ampli home cinema (Yamaha 365).
Et ca ne passe pas. Je ne comprends pas car si je branche une autre
source sur la meme prise de l'ampli, pas de souci, mais le MbP non.
Lorsque je débranche le toslink de l'ampli, je voi bien la petite
lumière rouge qui s'allume, donc il doit bien y avoir quelque chose qui
passe, mais lampli n'accroche pas au signal. Y a t il un reglage a faire
quelque part? Aucun son ne transite, ni ceux du systeme, ni via VLC
etc
Merci pour votre aide !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles ROBERT
Le #20656551
phil a écrit :
Salut !
...je voi bien la petite
lumière rouge qui s'allume, donc il doit bien y avoir quelque chose qui
passe,



Je n'ai pas de Mac ayant ce système... Par contre j'en ai beaucoup
d'autres...

La lumière rouge ne signifie pas la présence d'un signal, mais du câble
effectivement branché.

Certains appareils se connectant systématiquement de cette façon quant
le câble optique est connecté, ce qui m'en limite l'emploi...
gilles
Le #20689461
phil
Salut !
J'ai un MacBook Pro penryn premier du nom, sur lequel je branche un
cable optique (jack-toslink) relié à un ampli home cinema (Yamaha 365).
Et ca ne passe pas. Je ne comprends pas car si je branche une autre
source sur la meme prise de l'ampli, pas de souci, mais le MbP non.
Lorsque je débranche le toslink de l'ampli, je voi bien la petite
lumière rouge qui s'allume, donc il doit bien y avoir quelque chose qui
passe, mais lampli n'accroche pas au signal. Y a t il un reglage a faire
quelque part? Aucun son ne transite, ni ceux du systeme, ni via VLC
etc...
Merci pour votre aide !




tu peux peut-être aller voir du côté de l'utilitaire "Configuration
audio et midi" : où tu devrais pouvoir régler le niveau de sortie, et la
fréquence et définition (16 bits 44,1 Khz ou plus)
Gerald
Le #20689611
phil
J'ai un MacBook Pro penryn premier du nom, sur lequel je branche un
cable optique (jack-toslink) relié à un ampli home cinema (Yamaha 365).
Et ca ne passe pas.



"ça ne passe" que dans certains contextes bien précis, mais sois sûr que
"ça va passer", si tu respectes bien ce qui suit. J'ai moi-même mis du
temps à bien comprendre les tenants et les aboutissants et j'ai plaisir
à partager l'info.

En gros il faut bien définir source et destination. Pour la destination,
il faut bien entendu sélectionner sur l'ampli la position qui correspond
à l'entrée numérique. Sur le mien (Yamaha RX-V463) il y a deux entrées
numériques optiques qui ne sont pas sélectionnées par défaut et il faut
modifier l'affectation d'entrée d'une des configurations. J'en ai choisi
une qui n'avait pas d'effets préprogrammés (son droit "straight") et qui
ne me servait pas, DTV/CBL (voir le manuel pour choisir la source, qui
sera "CD" si tu as utilisé l'entrée optique dite "CD").

Pour la source il faut savoir quel logiciel tu utilises et quelle
configuration de sortie tu souhaites pour lui. On part de l'idée que tu
veux la sortie optique pour disposer de son surround 5.1 donc :

- Pour Lecteur DVD, c'est subtil. Ça se passe dans le menu Lecteur DVD /
préférences / Audio / -> menu local : "sortie audio" MAIS le choix n'est
possible que si le lecteur est à l'arrêt (position STOP, pas PAUSE !
sinon ça reste grisé). Tu as alors le choix entre "Sortie son système"
et "Sortie numérique - Sortie intégrée". Dès que tu la choisis et que tu
remets ton DVD en lecture, tu vois la configuration des haut-parleurs,
sur l'ampli, passer en 5.1 et le son être diffusé en 5.1 (pour autant
que ton DVD ait une piste son à ce format !).

- Pour VLC, ça peut se faire "à la volée" en cours de lecture, dans le
menu Audio/Périphériques audio/ : choisir "Sortie intégr (sortie
encodée)" pour avoir aussi le 5.1.

- Pour les applis musicales gérant le multicanal comme Logic Studio, ça
se trouve naturellement dans les affectations de sortie. Il faut passer
par les groupes pour affecter une même voie à plusieurs canaux de
sortie, mais un grand piano sur 5 canaux dans Mainstage avec une réverb
appropriée, c'est somptueux !

- Pour le reste, et en particulier le son de iTunes, je viens de
découvrir la nouvelle ergonomie de l'utilitaire "Configuration audio et
MIDI" où tout semble automatique : il suffit de brancher la fibre
optique pour que dans "Sortie intégrée", la source bascule
automatiquement sur "Sortie numérique". Si tu es susceptible d'avoir des
sources meilleures que du CD audio, tu peux choisir 48 kHz et 24 bits,
ça ne mange pas de pain (après, faut avoir les écoutes qui suivent).
C'est magique : dès que tu retires la fibre optique ça bascule sur
"Haut-parleurs internes", et dès que tu branches un mini-jack
analogique, ça bascule sur "Écouteurs". Très efficace ! Je viens
d'allumer une interface USB (Fast Track Ultra) et elle apparaît sagement
toute seule avec ses huit canaux. C'est magique quand on se rappelle
comment ça pouvait planter autrefois quand on faisait ça à la volée !

X-post modéré car ça peut intéresser le système et FU2 là où c'était
pour ne pas perturber. hth,

--
Gérald
philming
Le #20720191
Gerald
- Pour VLC, ça peut se faire "à la volée" en cours de lecture, dans le
menu Audio/Périphériques audio/ : choisir "Sortie intégr (sortie
encodée)" pour avoir aussi le 5.1.



Merci pour vos réponses !

VLC c'est ma source principale. J'ai testé avec plusieurs cables. Sur
certains rien ne passe du tout, sur d'autres ca passe, mais j'ai assez
souvent des décrochages...
Faut dire que ce sont des cables pas chers de chez Amazon... Est-ce que
ca peut avopir une incidence?

y a t il une incidence sur l'ordre d'allumage des éléments (MbP branché
en HDMI sur l'ampli, relié a la TV en HDMI aussi, Sortie optique sur
l'ampli. En general, j'allume l'ampli, puis la TV, puis je réveille le
MbP...
Je n'utilise pas l'audio a travers l'HDMI car l'ampli ne gere pas ce
signal malheureusement.

Ensuite la prise mbp > ampi vient se connecter sur l'entrée toslink DTV,
et dans le menu de config de l'ampli, j'ai bien entendu affecté l'entrée
en question à la bonne source, donc tout est en ordre a ce niveau.
En fait je me demande si c'est pas la sortie optique du mac qui a un
coup dans l'aile...
Gerald
Le #20722291
phil
VLC c'est ma source principale. J'ai testé avec plusieurs cables. Sur
certains rien ne passe du tout, sur d'autres ca passe, mais j'ai assez
souvent des décrochages...



« Ici ça marche ! » © ™ etc. ce qui, bien sûr, ne t'avance à rien hélas.
Deux pistes quand même : essayer avec divers DVDs d'une part et essayer
quand même avec "Lecteur DVD" comme je te l'ai indiqué. Une modification
du comportement excluerait le problème matériel.

Pour info, les restitutions audio les plus somptueuses à mon goût (pour
le 5.1) sont d'une part le concert anniversaire des 60 ans de Tina
Turner et d'autre part le Don Giovanni de Losey (pour ratisser large :-)

Faut dire que ce sont des cables pas chers de chez Amazon... Est-ce que
ca peut avopir une incidence?



Je ne sais pas : j'ai acheté les miens sur l'AppleStore. Mon ampli est
cousin proche du tien... et mon ordi aussi. À suivre ?

--
Gérald
Éric Lévénez
Le #20723081
phil a écrit :

En fait je me demande si c'est pas la sortie optique du mac qui a un
coup dans l'aile...



Ce n'est peut-être pas ton problème, mais regarde ça :



--
Éric Lévénez -- Unix is not only an OS, it's a way of life.
Gerald
Le #20723771
Éric Lévénez
Ce n'est peut-être pas ton problème, mais regarde ça :

http://www.commentcamarche.net/forum/affich-5435541-probleme-de-son-sur-ma
cbook#p5528159>



Attention : en fait son problème est *l'inverse* de celui qui est décrit
dans le lien !

- le problème de ces gens est en effet d'une absence de son analogique
du fait de la persistance en position "enfoncé" du capteur de présence
du connecteur numérique.

- le problème du PO est, *en utilisation numérique optique*, d'absence
de détection du signal ou d'interruptions ("décrochages") sur l'ampli.
Il n'a rien dit sur le son analogique qu'on peut donc supposer non
concerné.

Avant d'aller tripatouiller "à la barbare" (avec cure-dents ou
cotons-tiges décapités) un connecteur qui marche peut-être très bien, je
pense utile d'exclure un certain nombre de causes.

Au premier chef les câbles puisqu'il dit qu'il en a essayé plusieurs et
qu'avec certains ça marche et avec d'autres pas :-) Le doute nous saisit
tous !

Ensuite qu'il procède avec un peu de méthode pour cerner ce qui marche
ou pas. Je lui ai suggéré différentes options qu'il n'a pas commentées.
Il serait intéressant de savoir si ça marche mieux ou pas avec Lecteur
DVD, avec certains DVDs (certains sont en Dolby Digital, d'autres en
DTS, certains proposent le choix etc. il peut s'agir d'une absence de
convertisseur ad hoc sur l'ampli), et surtout si, dans Configuration
audio et MIDI, le branchement/débranchement du jack optique puis d'un
jack analogique provoque bien les bascules automatiques que j'ai
décrites (qui signalera le bon fonctionnement des interrupteurs internes
du mini-jack).

Restera alors à faire deux essais-clé : utiliser le câble préconisé par
Apple (qui peut avoir ses raisons...) et voir su le problème est
identique ou pas avec un autre ampli. À suivre...

-- Gérald
philming
Le #20729141
Gerald
Ensuite qu'il procède avec un peu de méthode pour cerner ce qui marche
ou pas. Je lui ai suggéré différentes options qu'il n'a pas commentées.
Il serait intéressant de savoir si ça marche mieux ou pas avec Lecteur
DVD, avec certains DVDs (certains sont en Dolby Digital, d'autres en
DTS, certains proposent le choix etc. il peut s'agir d'une absence de
convertisseur ad hoc sur l'ampli), et surtout si, dans Configuration
audio et MIDI, le branchement/débranchement du jack optique puis d'un
jack analogique provoque bien les bascules automatiques que j'ai
décrites (qui signalera le bon fonctionnement des interrupteurs internes
du mini-jack).



Je ferais ce soir si j'ai le temps le test aec differentes sources. (DVD
etc)
Je n'ai aucun souci avec l'audio analogique (casque)
Les bascules auto se font correctement. J'ai testé de basculer en 96khz,
et je suis resté bloqué aussi sur "straight" sur l'ampli. Je suis donc
resté en 48. La detection du nombre de cabnaux se fait toute seule aussi
avec un passage direct de 2ca-24bits a "sortie encodée (je crois, je
n'ai pas le cable sous la main)" en passant sur une piste DTS ou DD.


Restera alors à faire deux essais-clé : utiliser le câble préconisé par
Apple (qui peut avoir ses raisons...) et voir su le problème est
identique ou pas avec un autre ampli. À suivre...



Ce qui me surprend, c'est qu'autrefois, (je n'ai pas testé depuis
longtemps mais faudrait que j'essaye a nouveau) je n'avais pas du tout
ce souci avec un ampli Denon. Entre temps, j'ai pas mal utilisé le MbP
avec un casque pour écouter de la musique au boulot. C'est ce qui me
fait penser à un souci au niveau de la prise jack de l'ordi, a cause des
branchements - debranchements, occasionels "tirage" sur le cable etc...

Autre chose : j'ai une PS3 branchée sur l'ampli en optique aussi, et je
n'ai pas du tout ce souci avec, même si je la branche sur la même prise,
ela exclu donc un problème éventuellement lié à l'ampli je penses...
Gerald
Le #20732261
phil
Ce qui me surprend, c'est qu'autrefois, (je n'ai pas testé depuis
longtemps mais faudrait que j'essaye a nouveau) je n'avais pas du tout
ce souci avec un ampli Denon. Entre temps, j'ai pas mal utilisé le MbP
avec un casque pour écouter de la musique au boulot. C'est ce qui me
fait penser à un souci au niveau de la prise jack de l'ordi, a cause des
branchements - debranchements, occasionels "tirage" sur le cable etc...



je ne dis pas que ça ne puisse pas être possible, mais si le test
branchement/débranchement optique puis analogique puis rien provoque les
bonnes bascules dans configuration audio et MIDI, on peut déjà exclure
le problème des switchs/interrupteurs précédemment évoqué. Un nouveau
test sur un autre ampli (dans un magasin hifi éventuellement ?) avec
câble ancien et câble du magasin peut-être permettrait de mettre en
cause directement le MacBook ou le câble.

Autre chose : j'ai une PS3 branchée sur l'ampli en optique aussi, et je
n'ai pas du tout ce souci avec, même si je la branche sur la même prise,
ela exclu donc un problème éventuellement lié à l'ampli je penses...



Peut-être pas à l'ampli mais qui sait à l'encodage de l'ampli qui ne
serait pas bien compatible avec celui du Mac ? Dans tous les cas tu
procèdes avec méthode et c'est bien. As-tu appelé le SAV Apple et qu'en
dit-il ? Quand, par hasard, on n'est pas seul à avoir un problème donné
les choses sont souvent bien plus sympas :-)

--
Gérald
philming
Le #20771601
Gerald

Peut-être pas à l'ampli mais qui sait à l'encodage de l'ampli qui ne
serait pas bien compatible avec celui du Mac ? Dans tous les cas tu
procèdes avec méthode et c'est bien. As-tu appelé le SAV Apple et qu'en
dit-il ? Quand, par hasard, on n'est pas seul à avoir un problème donné
les choses sont souvent bien plus sympas :-)



Bon, suite des tests hier soir. Ca commencait bien depuis quelques jours
pour une raison que j'ignore, le signal passait assez bien. Et hier
soir, a nouveau des décrochages. Je débranche et rebranche des deux
cotés alternativement (coté mac et coté ampli) et ca ne s'arrange pas.
JE change de cable, plus rien. Je reviens au premier cable, plus rien
non plus. Quel que soit le cable, la config audio et midi me détecte
bien un passage sur sortie optique.
Je prend mon cable et vaisbrancher le MbP sur un autre ampli que j'ai
(Denon). La ca passe sans problème.
Je me dis, c'ets peut-$etre la prise toslink de l'ampli qui déconne : je
repart vers le yamaha, et je tente une branchement sur la 2eme prise
optique : rien.
Je branche la PS3 sur l'une ou l'autre prise optique, en modifiant la
config de l'ampli pour que la bonne entrée optique soit associée a la
bonne source : Signal DD reconnu immédiatement, sur les deux prises
directement.
Je n'y comprends plus rien :-/
Le cable a prendre le cas échéant sur l'Apple store, c'ets le toslink
tout bete avec un adaptateur prévu pour l'Apple TV?
Publicité
Poster une réponse
Anonyme