SOS : fonction recherchev

Le
dal.luc
Bonjour,

Qui peut me dire ou est l'erreur ?
Soit le tableau suivant dans les cellules A1:D2
0,000155377 0,000142832 0,000145168 0,000143711
0,000177449 0,000172489 0,000163985 0,000155997
Dans la cellule A4, on a 0,000142832
Dans la cellule A5, on la formule =RECHERCHEV($A$4;$A$1:$D$2;1;) et on
a faux, ce qui est normal
Dans la cellule A6, on la formule =RECHERCHEV($A$4;$A$1:$D$2;2;) et on
a faux, ce qui est anormal : on devrait avoir la valeur introduite à
mon avis.

Par ailleurs, je voudrais récupérer le numéro de colonne (donc B, ou
2) dans laquelle se trouve cette valeur.

Qui peut éclairer ma lanterne ?

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #16770841
Bonjour,

utilise la fonction Equiv

Cordialement.


--
lSteph

dal.luc a écrit :
Bonjour,

Qui peut me dire ou est l'erreur ?
Soit le tableau suivant dans les cellules A1:D2
0,000155377 0,000142832 0,000145168 0,000143711
0,000177449 0,000172489 0,000163985 0,000155997
Dans la cellule A4, on a 0,000142832
Dans la cellule A5, on la formule =RECHERCHEV($A$4;$A$1:$D$2;1;) et on
a faux, ce qui est normal
Dans la cellule A6, on la formule =RECHERCHEV($A$4;$A$1:$D$2;2;) et on
a faux, ce qui est anormal : on devrait avoir la valeur introduite à
mon avis.

Par ailleurs, je voudrais récupérer le numéro de colonne (donc B, ou
2) dans laquelle se trouve cette valeur.

Qui peut éclairer ma lanterne ?

Merci d'avance



Corto
Le #16770831
Bonjour dal.luc,
La fontion Recherchev recherche la valeur dans la première colonne de
données, il est donc tout a fait normal que tes fonctions renvoient une
erreur car la valeur cherchée ne s'y trouve pas, il suffit de remplacer
par RECHERCHEH qui cherche dans la première ligne et ça marche :
en A5 =RECHERCHEH($A$4;$A$1:$D$2;1;FAUX) renvoie 0,00014283
en A6 =RECHERCHEH($A$4;$A$1:$D$2;2;FAUX) renvoie 0,00017249

Pour récupérer la colonne il faut utiliser la fonction
=EQUIV($A$4;$A$1:$D$1;0) qui renvoie 2

Corto


dal.luc a écrit :
Bonjour,

Qui peut me dire ou est l'erreur ?
Soit le tableau suivant dans les cellules A1:D2
0,000155377 0,000142832 0,000145168 0,000143711
0,000177449 0,000172489 0,000163985 0,000155997
Dans la cellule A4, on a 0,000142832
Dans la cellule A5, on la formule =RECHERCHEV($A$4;$A$1:$D$2;1;) et o n
a faux, ce qui est normal
Dans la cellule A6, on la formule =RECHERCHEV($A$4;$A$1:$D$2;2;) et o n
a faux, ce qui est anormal : on devrait avoir la valeur introduite à
mon avis.

Par ailleurs, je voudrais récupérer le numéro de colonne (donc B, ou
2) dans laquelle se trouve cette valeur.

Qui peut éclairer ma lanterne ?

Merci d'avance




LSteph
Le #16771091
Bonjour...,

...oui! mais
je crois que JL cherche colonne par colonne donc bien, verticalement.

...quoiqu'il en soit
et sauf à chercher à se situer dans un ensemble de valeur, avant ou
après il est délicat de chercher dans des décimales dont la valeur peut
excèder l'affichage en outre ceci interdirait d'omettre ainsi le
dernier paramêtre de la fonction RECHERCHE...H...ou..V.

Reste que pour nombre de cas il est plus avantageux de combiner INDEX
et EQUIV on peut ainsi chercher dans toute direction.

En l'occurence EQUIV permet de ramener ce fameux numéro de colonne ou de
ligne selon la matrice.

--
lSteph



Corto a écrit :
Bonjour dal.luc,
La fontion Recherchev recherche la valeur dans la première colonne de
données, il est donc tout a fait normal que tes fonctions renvoient une
erreur car la valeur cherchée ne s'y trouve pas, il suffit de remplacer
par RECHERCHEH qui cherche dans la première ligne et ça marche :
en A5 =RECHERCHEH($A$4;$A$1:$D$2;1;FAUX) renvoie 0,00014283
en A6 =RECHERCHEH($A$4;$A$1:$D$2;2;FAUX) renvoie 0,00017249

Pour récupérer la colonne il faut utiliser la fonction
=EQUIV($A$4;$A$1:$D$1;0) qui renvoie 2

Corto


dal.luc a écrit :
Bonjour,

Qui peut me dire ou est l'erreur ?
Soit le tableau suivant dans les cellules A1:D2
0,000155377 0,000142832 0,000145168 0,000143711
0,000177449 0,000172489 0,000163985 0,000155997
Dans la cellule A4, on a 0,000142832
Dans la cellule A5, on la formule =RECHERCHEV($A$4;$A$1:$D$2;1;) et on
a faux, ce qui est normal
Dans la cellule A6, on la formule =RECHERCHEV($A$4;$A$1:$D$2;2;) et on
a faux, ce qui est anormal : on devrait avoir la valeur introduite à
mon avis.

Par ailleurs, je voudrais récupérer le numéro de colonne (donc B, ou
2) dans laquelle se trouve cette valeur.

Qui peut éclairer ma lanterne ?

Merci d'avance






dal.luc
Le #16790161
On 10 sep, 09:25, LSteph
Bonjour...,

...oui! mais
je crois que JL cherche colonne par colonne donc bien, verticalement.

...quoiqu'il en soit
et sauf à chercher à se situer dans un ensemble de valeur, avant ou
après il est délicat de chercher dans des décimales dont la valeur peut
excèder l'affichage en outre ceci  interdirait d'omettre ainsi le
dernier paramêtre de la fonction RECHERCHE...H...ou..V.

Reste que pour nombre de cas  il est plus avantageux  de combiner IND EX
et EQUIV on  peut ainsi chercher dans toute direction.

En l'occurence EQUIV permet de ramener ce fameux numéro de colonne ou d e
ligne selon la matrice.

--
lSteph

Corto a écrit :



> Bonjour dal.luc,
> La fontion Recherchev recherche la valeur dans la première colonne de
> données, il est donc tout a fait normal que tes fonctions renvoient u ne
> erreur car la valeur cherchée ne s'y trouve pas, il suffit de remplac er
> par RECHERCHEH qui cherche dans la première ligne et ça marche :
> en A5 =RECHERCHEH($A$4;$A$1:$D$2;1;FAUX) renvoie 0,00014283
> en A6 =RECHERCHEH($A$4;$A$1:$D$2;2;FAUX) renvoie 0,00017249

> Pour récupérer la colonne il faut utiliser la fonction
> =EQUIV($A$4;$A$1:$D$1;0) qui renvoie 2

> Corto

> dal.luc a écrit :
>> Bonjour,

>> Qui peut me dire ou est l'erreur ?
>> Soit le tableau suivant dans les cellules A1:D2
>> 0,000155377    0,000142832    0,000145168    0,000143711
>> 0,000177449    0,000172489    0,000163985    0,000155997
>> Dans la cellule A4, on a 0,000142832
>> Dans la cellule A5, on la formule =RECHERCHEV($A$4;$A$1:$D$2;1;) et on
>> a faux, ce qui est normal
>> Dans la cellule A6, on la formule =RECHERCHEV($A$4;$A$1:$D$2;2;) et on
>> a faux, ce qui est anormal : on devrait avoir la valeur introduite à
>> mon avis.

>> Par ailleurs, je voudrais récupérer le numéro de colonne (donc B , ou
>> 2) dans laquelle se trouve cette valeur.

>> Qui peut éclairer ma lanterne ?

>> Merci d'avance- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



merci à tous
Publicité
Poster une réponse
Anonyme