Souci de dépendances nécessitant la suppression de paquets sur testing

Le
fra-duf-no-spam
Salut.

J'ai un petit souci avec les mises à jour de ma testing.

Depuis quelques temps, je ne sais plus quand ni pourquoi, je ne peux pas
mettre à jour les paquets suivants:

Conserver les paquets suivants dans leur version actuelle :
1) libgssapi-krb5-2 [1.8.1+dfsg-5 (now)] =

2) libk5crypto3 [1.8.1+dfsg-5 (now)] =

3) libkrb5-3 [1.8.1+dfsg-5 (now)] =

4) libkrb5support0 [1.8.1+dfsg-5 (now)] =


parce que si j'accepte, il va me supprimer certains autres paquets. La
première des solutions est:

Les paquets suivants ont des dépendances non satisfaites :
libkrb5-3: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~beta1-5=
lenny4 est installé.
libkrb5support0: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~b=
eta1-5lenny4 est installé.
libk5crypto3: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~beta=
1-5lenny4 est installé.
libgssapi-krb5-2: Casse: libkrb53 mais 1.6.dfsg.4~beta1-5lenny4 est insta=
llé.
ouverts : 19 ; fermés : 442 ; reportés :=
15 ; en conflit : 31 .Les actions suivantes permettront =
de résoudre ces dépendances :

Supprimer les paquets suivants :
1) gnome-cups-manager
2) libbind9-50
3) libcamel1.2-11
4) libdns55 =

5) libgnomecupsui1.0-1c2a
6) libisccfg50
7) libkrb53 =


Mais j'ai pas envie de supprimer ces 7 paquets. Je ne sais pas pourquoi,
d'ailleurs, car il est peut-être nécessaire de les supprimer

J'aimerais un avis éclairé, car en plus je ne sais pas trop oÃ=
¹ et quoi
chercher.

--
L'atomisme était la doctrine, par excellence, des choesttes.
-+- Gaston Bachelard -+-

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/874odrm6pk.fsf@fermat.tourde.home
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Antoine
Le #22572911
salut, c'est le bug #596678
~> libkrb5-3: Ne peut être co-installée avec libkrb53, et ainsi bloque
les màj depuis lenny
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugY6678

et perso en attendant la résolution :
Package: krb5-multidev libgssapi-krb5-2 libgssrpc4 libk5crypto3
libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4 libkrb5-3 libkrb5-dev
libkrb5support0
Pin: release a=now
Pin-Priority: 993

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #22573881
'lut,

J'ai un petit souci avec les mises à jour de ma testing.

Depuis quelques temps, je ne sais plus quand ni pourquoi, je ne peux pas
mettre à jour les paquets suivants:

Conserver les paquets suivants dans leur version actuelle :
1) libgssapi-krb5-2 [1.8.1+dfsg-5 (now)]
2) libk5crypto3 [1.8.1+dfsg-5 (now)]
3) libkrb5-3 [1.8.1+dfsg-5 (now)]
4) libkrb5support0 [1.8.1+dfsg-5 (now)]


ah oui, j'ai eu aussi ce soucis le 16 aout et comme la correction n'est
pas venue d'elle même (problème entre libkrb5-3 et libkrb53), voici ce
que j'ai fait (tiré de /var/log/aptitude):

[RETIRÉ] libkrb53

et ensuite

[MIS A JOUR] libgssapi-krb5-2 1.8.1+dfsg-5 -> 1.8.3+dfsg~beta1-1
[MIS A JOUR] libkrb5-3 1.8.1+dfsg-5 -> 1.8.3+dfsg~beta1-1
[MIS A JOUR] libkrb5support0 1.8.1+dfsg-5 -> 1.8.3+dfsg~beta1-1


a+

f.


parce que si j'accepte, il va me supprimer certains autres paquets. La
première des solutions est:

Les paquets suivants ont des dépendances non satisfaites :
libkrb5-3: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~beta1-5lenny4 est installé.
libkrb5support0: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~beta1-5lenny4 est installé.
libk5crypto3: Casse: libkrb53 (< 1.6.dfsg.4~beta1-9) mais 1.6.dfsg.4~beta1-5lenny4 est installé.
libgssapi-krb5-2: Casse: libkrb53 mais 1.6.dfsg.4~beta1-5lenny4 est installé.
ouverts : 19 ; fermés : 442 ; reportés : 15 ; en conflit : 31 .Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
1) gnome-cups-manager
2) libbind9-50
3) libcamel1.2-11
4) libdns55
5) libgnomecupsui1.0-1c2a
6) libisccfg50
7) libkrb53

Mais j'ai pas envie de supprimer ces 7 paquets. Je ne sais pas pourquoi,
d'ailleurs, car il est peut-être nécessaire de les supprimer...

J'aimerais un avis éclairé, car en plus je ne sais pas trop où et quoi
chercher.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/4c911d53$0$5355$
Antoine
Le #22573941
Le 15/09/2010 21:24, fabrice régnier a écrit :
'lut,

J'ai un petit souci avec les mises à jour de ma testing.

Depuis quelques temps, je ne sais plus quand ni pourquoi, je ne peux pas
mettre à jour les paquets suivants:

Conserver les paquets suivants dans leur version actuelle :
1) libgssapi-krb5-2 [1.8.1+dfsg-5 (now)]
2) libk5crypto3 [1.8.1+dfsg-5 (now)]
3) libkrb5-3 [1.8.1+dfsg-5 (now)]
4) libkrb5support0 [1.8.1+dfsg-5 (now)]


ah oui, j'ai eu aussi ce soucis le 16 aout et comme la correction
n'est pas venue d'elle même (problème entre libkrb5-3 et libkrb53),
voici ce que j'ai fait (tiré de /var/log/aptitude):

[RETIRÉ] libkrb53


sauf quand tu veux garder libapache2-mod-php5 et php5-xxx de dotdeb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #22574661
sauf quand tu veux garder libapache2-mod-php5 et php5-xxx de dotdeb


en effet, je n'ai pas précisé que je n'ai pas php d'installé.

f.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/4c91c651$0$10807$
fra-duf-no-spam
Le #22574811
Le 14868ième jour après Epoch,
fabrice régnier écrivait:

sauf quand tu veux garder libapache2-mod-php5 et php5-xxx de dotdeb


en effet, je n'ai pas précisé que je n'ai pas php d'installà ©.



Merci à vous deux. J'avais pourtant cherché dans BTS, mais j'avai s pas
trouvé ce bug :( ... Honte à moi.

Pour ce qui est de la solution, je vais plutôt faire en sorte de rà ¢ler
un peu à chaque dist-upgrade, sinon je vais oublier que j'ai mis le
pinning et il va rester ad vitam aeternam ...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Antoine
Le #22574881
Le 16/09/2010 10:37, François TOURDE a écrit :
sinon je vais oublier que j'ai mis le
pinning et il va rester ad vitam aeternam


perso, j'ai souscrit au bug ("subscribe to this bug"), pour suivre le
fil de résolution du bug (et humblement participer si appel à tests)
afin de ne pas oublier de désactiver le pinning quand il sera résolu/fermé
a+

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Antoine
Le #22617801
Le 16/09/2010 10:49, Antoine a écrit :
Le 16/09/2010 10:37, François TOURDE a écrit :
sinon je vais oublier que j'ai mis le pinning et il va rester ad
vitam aeternam


perso, j'ai souscrit au bug ("subscribe to this bug") afin de ne pas
oublier de désactiver le pinning quand il sera résolu/fermé


salut, à toutes fins utiles, reçu aujourd'hui :
"Bug#596678: marked as done (libkrb5-3: Not co-installable with
libkrb53, thus breaking upgrades from Lenny)"
pinning désactivé...màj ok
à +

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fra-duf-no-spam
Le #22629051
Le 14878ième jour après Epoch,
Antoine écrivait:

"Bug#596678: marked as done (libkrb5-3: Not co-installable with
libkrb53, thus breaking upgrades from Lenny)"
pinning désactivé...màj ok



Merci de l'info. Je vais attendre le passage en testing, et faire la MÃ  J
à ce moment là.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme