Souci réseau sous Xen 4.0

Le
fra-duf-no-spam
Salut la liste.

J'utilise Xen (depuis un bon moment déjà), et j'ai un petit souci=
avec
une de mes machines virtuelles. C'est la seule sur la machine physique Ã=
 
ne pas répondre au ping, et n'avoir pas d'accès au réseau.

Je détaille:

Serveur physique Debian stable:
Linux srv04 2.6.32-5-xen-amd64 #1 SMP Fri May 10 11:48:05 UTC 2013 x86_64

DomU qui marche:
Linux wiki 2.6.32-5-amd64 #1 SMP Fri May 10 08:43:19 UTC 2013 x86_64

DomU qui marche pas:
Linux rh42g1 2.6.32-5-xen-amd64 #1 SMP Fri May 10 11:48:05 UTC 2013 x86_6=
4 GNU/Linux

C'est pas le même kernel, mais je sais pas pourquoi exactement.

Les paquets arrivent bien au Dom0 (tcpdump me le dit), les tables arp du
Dom0 et des Dom0 semblent correctes, les routes aussi:

Dom0:
root@srv04:~# ip route
88.191.222.127 dev vif109.0 scope link src 88.191.108.41
88.191.223.138 dev vif8.0 scope link src 88.191.108.41
88.191.229.230 dev vif108.0 scope link src 88.191.108.41
88.191.226.108 dev vif110.0 scope link src 88.191.108.41
88.191.108.0/24 dev eth0 proto kernel scope link src 88.191.108.41
88.191.110.0/24 dev eth1 proto kernel scope link src 88.191.110.41
default via 88.191.110.1 dev eth1
default via 88.191.108.1 dev eth0

DomU qui marche:
88.191.229.0/24 dev eth0 proto kernel scope link src 88.191.229.230
default dev eth0 scope link

DomU qui marche pas:
88.191.223.0/24 dev eth0 proto kernel scope link src 88.191.223.138
default dev eth0 scope link

Le firewall (sur le Dom0) est une boucle qui génère les même=
s règles
pour tous les DomU

Toutes les idées (même saugrenues) sont acceptées.

Merci d'avance.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/87hagltkoz.fsf@tourde.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Huhardeaux
Le #25504592
Le 26/06/2013 09:06, François TOURDE a écrit :
Salut la liste.



Salut


J'utilise Xen (depuis un bon moment déjà), et j'ai un petit souci avec
une de mes machines virtuelles. C'est la seule sur la machine physique à
ne pas répondre au ping, et n'avoir pas d'accès au réseau.


[...]
Les paquets arrivent bien au Dom0 (tcpdump me le dit), les tables arp du
Dom0 et des Dom0 semblent correctes, les routes aussi:



[...]

(Je précise que je ne connais pas Xen)

S'ils arrivent au Dom0 c'est qu'ils sont peut être bloqués au retour.
Que donne un ping de Dom0 vers la DomU qui ne fonctionne pas avec
tcpdump écoutant sur l'interface dans la DomU ?

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fra-duf-no-spam
Le #25504742
Le 15882ième jour après Epoch,
Daniel Huhardeaux écrivait:

Le 26/06/2013 09:06, François TOURDE a écrit :
Salut la liste.



Salut


J'utilise Xen (depuis un bon moment déjà), et j'ai un petit so uci avec
une de mes machines virtuelles. C'est la seule sur la machine physique à
ne pas répondre au ping, et n'avoir pas d'accès au réseau.


[...]
Les paquets arrivent bien au Dom0 (tcpdump me le dit), les tables arp du
Dom0 et des Dom0 semblent correctes, les routes aussi:



[...]

(Je précise que je ne connais pas Xen)

S'ils arrivent au Dom0 c'est qu'ils sont peut être bloqués au
retour. Que donne un ping de Dom0 vers la DomU qui ne fonctionne pas
avec tcpdump écoutant sur l'interface dans la DomU ?



Le ping de Dom0 vers DomU (et la réciproque) marchent bien. Donc je
suppose au départ que c'est le Dom0 qui ne route pas les paquets vers
l'extérieur.

Je n'ai pas pu "simplement" installer tcpdump sur le DomU, mais je vais
devoir le faire pour cibler un peu mieux les problèmes.

Merci de ta réponse.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
webmaster
Le #25505012
J'ai utilisé ce tuto :

http://blog.yoda-bzh.net/index.php?post/2011/02/26/Configuration-de-Xen-s ur-une-machine-dedibox


philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fra-duf-no-spam
Le #25509302
Le 15882ième jour après Epoch,
écrivait:

J'ai utilisé ce tuto :

http://blog.yoda-bzh.net/index.php?post/2011/02/26/Configuration-de-Xen-s ur-une-machine-dedibox



Merci, mais j'avais déjà installé tout un tas de machines vi rtuelles, et
ça marchait.

Après examen, il s'avère que les "echo request" reçus par et h0 sur le
Dom0 sont bien transférés au DomU, qui réponds correctement par un "echo
reply", mais ces paquets sont routés sur eth1.

Le Dom0 ayant plusieurs interfaces NIC, et le source routing étant
pourtant bien activé sur toutes les interfaces (y compris vifnnn.0), il
m'a suffit de désactiver eth1 (dont je ne me sers pas pour le moment) et
la VM est devenue correctement opérationnelle.

Merci en tout cas pour les réponses.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme