Soucis avec le WebBrowser

Le
Boblemar
Bonjour,

J'utilise le composant WebBrowser pour visualiser des fichiers locaux
sans trop me prendre la tête en théorie
Car il arrive, mais ce n'est pas systématique que je ne puisse afficher
qu'un unique document.
Lorsque j'appelle la méthode Navigate la première fois, mon document
s'affiche. La seconde fois, non ! pourtant, j'obtiens bien un évenement
DocumentCompleted et l'url du document est bien le second, mais à
l'écran, il s'agit du premier.
La propriété AllowNavigation est à True

Quelqu'un aurait-il une idée ?

Merci !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles TOURREAU
Le #12170271
Le Tue, 09 Oct 2007 17:58:39 +0200, Boblemar a écrit:

Bonjour,

J'utilise le composant WebBrowser pour visualiser des fichiers locaux
sans trop me prendre la tête... en théorie...
Car il arrive, mais ce n'est pas systématique que je ne puisse afficher
qu'un unique document.
Lorsque j'appelle la méthode Navigate la première fois, mon document
s'affiche. La seconde fois, non ! pourtant, j'obtiens bien un évenement
DocumentCompleted et l'url du document est bien le second, mais à
l'écran, il s'agit du premier.
La propriété AllowNavigation est à True...

Quelqu'un aurait-il une idée ?

Merci !



Pouvez-vous nous poster votre code ?

Cordialement

--
Gilles TOURREAU


S.A.R.L. P.O.S
Le spécialiste en motoculture depuis + de 30 ans !
http://www.pos.fr
Boblemar
Le #12170131
Bonjour,

Pour que vous compreniez le problème, il aurait été nécessaire de vous
transmettre plusieurs projets.
Finalement, j'ai compris ce qui se passait.
En fait, le webbrowser était utilisé au sein d'un composant graphique
permettant d'afficher des fichiers. Pour éviter toute modification des
fichiers source (dans le cas de fichiers ms office) et pour éviter tout
temps de latence (cas de répertoires réseau) une fois le document
ouvert, les fichiers sont copiés dans un répertoire local temporaire
local, puis ouverts.
J'ai eu la louable idée d'essayer de faire régulièrement du ménage dans
ce répertoire.

Le problème est que j'essayais de supprimer le fichier que j'étais en
train d'afficher (affichage asynchrone dans le webbrowser). En général,
cela ne posait pas de problèmes : lors de la suppression du fichier en
cours d'affichage, une exception était levée car le fichier était "locké
par un autre processus". Parfois, il y avait des soucis. J'imagine que
le lock n'est pas effectif durant tout le chargement ou que le fait de
lever une exception le perturbait.

Le problème semble avoir été résolu en affinant la méthode de nettoyage
: je n'essaie plus de supprimer le fichier qui est affiché ou en cours
d'affichage... ce qui est plutôt logique !

J'aurais pu y penser avant... mais je ne cherchais pas au bon endroit...

Boblemar

Gilles TOURREAU a écrit :
Le Tue, 09 Oct 2007 17:58:39 +0200, Boblemar

Bonjour,

J'utilise le composant WebBrowser pour visualiser des fichiers locaux
sans trop me prendre la tête... en théorie...
Car il arrive, mais ce n'est pas systématique que je ne puisse
afficher qu'un unique document.
Lorsque j'appelle la méthode Navigate la première fois, mon document
s'affiche. La seconde fois, non ! pourtant, j'obtiens bien un
évenement DocumentCompleted et l'url du document est bien le second,
mais à l'écran, il s'agit du premier.
La propriété AllowNavigation est à True...

Quelqu'un aurait-il une idée ?

Merci !



Pouvez-vous nous poster votre code ?

Cordialement



Publicité
Poster une réponse
Anonyme