SOUS.TOTAL et SOMMEPROD

Le
linou615974
Bonjour à tous !

J'ai trouvé un article dans le forum qui a une problématique proche de la
mienne sauf que.(ça aurait été trop beau!!) ça ne marche pas.
Je m'explique :
J'ai un onglet reprenant les colonnes suivantes :

semaine saison références qtés vendues
200735 1 100xxx 10
200735 2 120xxx 15 et ainsi de suite

Ce que je souhaite, c'est avoir le nombre de références sur la semaine
200735 pour la saison 1. Donc une combinaison des formules SOMMEPROD et
SOUS.TOTAL(3) d'après l'article du forum que j'ai lu.

Ma formule est donc :
=SOMMEPROD((SOUS.TOTAL(3;références)*(semaine="200705")*(saison=1)))

Sauf que ça me renvoie 1 au lieu de 2600 par exemple

Si quelqu'un a une idée de la syntaxe à utiliser ou autre chose à
proposer.. un grand merci d'avance pour toutes les idées proposées !!!!


Linou
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JFrancois QC
Le #4748181
Bonjour,
voici un exemple qui pourrait t'aider
http://cjoint.com/?jmtifG1PKf


Bonjour à tous !

J'ai trouvé un article dans le forum qui a une problématique proche de la
mienne sauf que....(ça aurait été trop beau!!) ça ne marche pas.
Je m'explique :
J'ai un onglet reprenant les colonnes suivantes :

semaine saison références qtés vendues
200735 1 100xxx 10
200735 2 120xxx 15 et ainsi de suite

Ce que je souhaite, c'est avoir le nombre de références sur la semaine
200735 pour la saison 1. Donc une combinaison des formules SOMMEPROD et
SOUS.TOTAL(3) d'après l'article du forum que j'ai lu.

Ma formule est donc :
=SOMMEPROD((SOUS.TOTAL(3;références)*(semaine="200705")*(saison=1)))

Sauf que ça me renvoie 1 au lieu de 2600 par exemple......

Si quelqu'un a une idée de la syntaxe à utiliser ou autre chose à
proposer..... un grand merci d'avance pour toutes les idées proposées !!!!

---
Linou


linou615974
Le #4748051
Merci JFrancois QC mais je ne comprends pas pourquoi tu utilise la fonction
DECALER.... dans mon cas, je ne pense pas quelle soit utile. En la testant
sur mon fichier, j'ai rien en retour (toujours le 1). Mais merci d'avoir
répondu !

--
Linou



Bonjour,
voici un exemple qui pourrait t'aider
http://cjoint.com/?jmtifG1PKf


Bonjour à tous !

J'ai trouvé un article dans le forum qui a une problématique proche de la
mienne sauf que....(ça aurait été trop beau!!) ça ne marche pas.
Je m'explique :
J'ai un onglet reprenant les colonnes suivantes :

semaine saison références qtés vendues
200735 1 100xxx 10
200735 2 120xxx 15 et ainsi de suite

Ce que je souhaite, c'est avoir le nombre de références sur la semaine
200735 pour la saison 1. Donc une combinaison des formules SOMMEPROD et
SOUS.TOTAL(3) d'après l'article du forum que j'ai lu.

Ma formule est donc :
=SOMMEPROD((SOUS.TOTAL(3;références)*(semaine="200705")*(saison=1)))

Sauf que ça me renvoie 1 au lieu de 2600 par exemple......

Si quelqu'un a une idée de la syntaxe à utiliser ou autre chose à
proposer..... un grand merci d'avance pour toutes les idées proposées !!!!

---
Linou




linou615974
Le #4748031
en fait, c'est bon, ta syntaxe est la bonne, je trouve bien mon nombre de
références !!
encore merci !!
je la note pour ceux qui aurait le même problème :

SOMMEPROD((SOUS.TOTAL(3;DECALER(références;LIGNE(réferences)-MIN(LIGNE(références));;1)))*(saison=1)*(semaine 0735))

voilà !
--
Linou



Merci JFrancois QC mais je ne comprends pas pourquoi tu utilise la fonction
DECALER.... dans mon cas, je ne pense pas quelle soit utile. En la testant
sur mon fichier, j'ai rien en retour (toujours le 1). Mais merci d'avoir
répondu !

--
Linou



Bonjour,
voici un exemple qui pourrait t'aider
http://cjoint.com/?jmtifG1PKf


Bonjour à tous !

J'ai trouvé un article dans le forum qui a une problématique proche de la
mienne sauf que....(ça aurait été trop beau!!) ça ne marche pas.
Je m'explique :
J'ai un onglet reprenant les colonnes suivantes :

semaine saison références qtés vendues
200735 1 100xxx 10
200735 2 120xxx 15 et ainsi de suite

Ce que je souhaite, c'est avoir le nombre de références sur la semaine
200735 pour la saison 1. Donc une combinaison des formules SOMMEPROD et
SOUS.TOTAL(3) d'après l'article du forum que j'ai lu.

Ma formule est donc :
=SOMMEPROD((SOUS.TOTAL(3;références)*(semaine="200705")*(saison=1)))

Sauf que ça me renvoie 1 au lieu de 2600 par exemple......

Si quelqu'un a une idée de la syntaxe à utiliser ou autre chose à
proposer..... un grand merci d'avance pour toutes les idées proposées !!!!

---
Linou






c.baudoin
Le #4695391
La Fx sommeprod peut calculer le nombre de valeur : au lieu de [
sous.total(3;références)) ] mettre [ *1 ]

pour faire une somme : sommeprod((critère1)*(critère2)*(plage_à_sommer))

pour compter le nbre de valeurs : sommeprod((critère1)*(critère2)*1)

=+SOMMEPROD(($A$2:$A$3 0735)*($B$2:$B$3=1)*1)

Dans l'exemple le résultat est bien : 1 valeur correspondante aux critères.

http://cjoint.com/?joq7CgXemG

"linou615974" message de news:
Merci JFrancois QC mais je ne comprends pas pourquoi tu utilise la
fonction

DECALER.... dans mon cas, je ne pense pas quelle soit utile. En la testant
sur mon fichier, j'ai rien en retour (toujours le 1). Mais merci d'avoir
répondu !

--
Linou



Bonjour,
voici un exemple qui pourrait t'aider
http://cjoint.com/?jmtifG1PKf


Bonjour à tous !

J'ai trouvé un article dans le forum qui a une problématique proche de
la



mienne sauf que....(ça aurait été trop beau!!) ça ne marche pas.
Je m'explique :
J'ai un onglet reprenant les colonnes suivantes :

semaine saison références qtés vendues
200735 1 100xxx 10
200735 2 120xxx 15 et ainsi de suite

Ce que je souhaite, c'est avoir le nombre de références sur la semaine
200735 pour la saison 1. Donc une combinaison des formules SOMMEPROD
et



SOUS.TOTAL(3) d'après l'article du forum que j'ai lu.

Ma formule est donc :
=SOMMEPROD((SOUS.TOTAL(3;références)*(semaine="200705")*(saison=1)))

Sauf que ça me renvoie 1 au lieu de 2600 par exemple......

Si quelqu'un a une idée de la syntaxe à utiliser ou autre chose à
proposer..... un grand merci d'avance pour toutes les idées proposées
!!!!




---
Linou






Publicité
Poster une réponse
Anonyme