SQLserver

Le
tjfromparis
bonjour,


J'ai un soucis avec une connection SQLserver : la connection passe
bien mais les requetes non ???

-=
--
SI HDécritConnexion("SQLserver", "sa", "dba", "JACQUA-SPEIGLOCAL",
"test", "SQLNCLI", hOLectureEcriture, "", hCurseurServeur +
hCurseurOpenKeyset) = Faux ALORS
Erreur("HS")
SINON
Info("OK")
FIN

sql est une chaîne
sql = " select * from TABLETEST "
MaRequête est une Source de Données

SI PAS HExécuteRequêteSQL(MaRequête,sql) ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN

HLitPremier(MaRequête)
TANTQUE PAS HEnDehors()
Trace(MaRequête.col1)
HLitSuivant()
FIN
-=
--

J'ai le message "erreur d'init de la requete"
"erreur dans le code de la requete"
"Fichier TABLETEST inconnu"

La connection est etablie : j'ai verifié sur la base
La table existe bien
Je suis sur le bon schema.

Une idée , une suggestion ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre BOUSQUET
Le #14547011
TABLETEST existe dans la BDD test ?

a présenté l'énoncé suivant :
TABLETEST



--
Pierre BOUSQUET

" Ne me dites pas que ce problème est difficile.
S'il n'était pas difficile, ce ne serait pas un problème. "
tjfromparis
Le #14547001
On 4 fév, 13:20, Pierre BOUSQUET
TABLETEST existe dans la BDD test ?

a présenté l'énoncé suivant :

> TABLETEST

--
Pierre BOUSQUET

" Ne me dites pas que ce problème est difficile.
S'il n'était pas difficile, ce ne serait pas un problème. "



oui
ca marche avec SQL4WD
Pierre BOUSQUET
Le #14546961
parametre HrequeteSanscorretion dans HExécuteRequêteSQL

a écrit :
On 4 fév, 13:20, Pierre BOUSQUET
TABLETEST existe dans la BDD test ?

a présenté l'énoncé suivant :

TABLETEST



--
Pierre BOUSQUET

" Ne me dites pas que ce problème est difficile.
S'il n'était pas difficile, ce ne serait pas un problème. "



oui
ca marche avec SQL4WD



--
Pierre BOUSQUET

" Ne me dites pas que ce problème est difficile.
S'il n'était pas difficile, ce ne serait pas un problème. "
tjfromparis
Le #14546941
On 4 fév, 13:54, Pierre BOUSQUET
parametre HrequeteSanscorretion dans HExécuteRequêteSQL

a écrit :

> On 4 fév, 13:20, Pierre BOUSQUET >> TABLETEST existe dans la BDD test ?

>> a présenté l'énoncé suivant :

>>> TABLETEST




yes c'etait ca, merci bien.

je vais creuser un peu ces paramètres


>> --
>> Pierre BOUSQUET

>> " Ne me dites pas que ce problème est difficile.
>> S'il n'était pas difficile, ce ne serait pas un problème. "

> oui
> ca marche avec SQL4WD

--
Pierre BOUSQUET

" Ne me dites pas que ce problème est difficile.
S'il n'était pas difficile, ce ne serait pas un problème. "


Béru
Le #14546931
Il se trouve que a formulé :
------------------------------------------------------------------------------------------------------------------
SI HDécritConnexion("SQLserver", "sa", "dba", "JACQUA-SPEIGLOCAL",
"test", "SQLNCLI", hOLectureEcriture, "", hCurseurServeur +
hCurseurOpenKeyset) = Faux ALORS
Erreur("HS")
SINON
Info("OK")
FIN



Il faut que tu ajoutes des infos etendues et que tu mettes :

"Initial Catalog=<nom de la base>"

Tiens nous au courant

Bons dev

Béru
adrien
Le #14546921
Bonjour,

Utiliser l'autre syntaxe de
<Résultat> = HExécuteRequêteSQL(<Nom de la requête> [, <Connexion> ][,
<Mode> ], <Texte de la Requête en SQL>)

Donc au lieu du :
SI PAS HExécuteRequêteSQL(MaRequête,sql) ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN


On aura
SI PAS
HExécuteRequêteSQL(MaRequête,SQLserver,hRequêteSansCorrection ,sql)
ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN


Cordialement,
Adrien
Dominique Lecocq
Le #14546911
Bonjour,
juste une remarque : même pour à des fin de test, IL NE FAUT PAS UTILISER
"SA", c'est trop dangereux, crée un user, avec des droit sur tes objets ca
prend 3 minutes.

Bon courage

Dominique "QNX" Lecocq


bonjour,


J'ai un soucis avec une connection SQLserver : la connection passe
bien mais les requetes non ???

------------------------------------------------------------------------------------------------------------------
SI HDécritConnexion("SQLserver", "sa", "dba", "JACQUA-SPEIGLOCAL",
"test", "SQLNCLI", hOLectureEcriture, "", hCurseurServeur +
hCurseurOpenKeyset) = Faux ALORS
Erreur("HS")
SINON
Info("OK")
FIN

sql est une chaîne
sql = " select * from TABLETEST "
MaRequête est une Source de Données

SI PAS HExécuteRequêteSQL(MaRequête,sql) ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN

HLitPremier(MaRequête)
TANTQUE PAS HEnDehors()
Trace(MaRequête.col1)
HLitSuivant()
FIN
------------------------------------------------------------------------------------------------------------------

J'ai le message "erreur d'init de la requete"
"erreur dans le code de la requete"
"Fichier TABLETEST inconnu"

La connection est etablie : j'ai verifié sur la base
La table existe bien
Je suis sur le bon schema.

Une idée , une suggestion ?
tjfromparis
Le #14546891
yep bien sur (pour "sa")

mais c'est une base de test sur mon poste de dev



On 4 fév, 15:45, "Dominique Lecocq"
Bonjour,
juste une remarque : même pour à des fin de test, IL NE FAUT PAS UTILI SER
"SA", c'est trop dangereux, crée un user, avec des droit sur tes objets ca
prend 3 minutes.

Bon courage

Dominique "QNX" Lecocq


bonjour,

J'ai un soucis avec une connection SQLserver : la connection passe
bien mais les requetes non ???

-------------------------------------------------------------------------- ----------------------------------------
SI HDécritConnexion("SQLserver", "sa", "dba", "JACQUA-SPEIGLOCAL",
"test", "SQLNCLI", hOLectureEcriture, "", hCurseurServeur +
hCurseurOpenKeyset) = Faux ALORS
Erreur("HS")
SINON
Info("OK")
FIN

sql est une chaîne
sql = " select * from TABLETEST "
MaRequête est une Source de Données

SI PAS HExécuteRequêteSQL(MaRequête,sql) ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN

HLitPremier(MaRequête)
TANTQUE PAS HEnDehors()
Trace(MaRequête.col1)
HLitSuivant()
FIN
-------------------------------------------------------------------------- ----------------------------------------

J'ai le message "erreur d'init de la requete"
"erreur dans le code de la requete"
"Fichier TABLETEST inconnu"

La connection est etablie : j'ai verifié sur la base
La table existe bien
Je suis sur le bon schema.

Une idée , une suggestion ?


tj
Le #14546851
ca roule impec.
J'ai maintenant un autre probleme : recuperer le nombre de colonnes retourné
par la requete.

avec SQLmanager c'est facile
Avec un ordre SQLexec : on fait ca avec sqlinfogene et sql.nbcol

mais lorsque l'on cré sa connection avec un hdecritconnexion on utilise quoi
?

pour appeler la fonction SQLinfogene il faut lui passer le nom de la
requete, mais en utilsant le HExécuteRequêteSQL la requete n'a pas de nom vu
qu'elle est envoyée dans une source de données ?!

et executer le sqlinfogene sans passer de nom de requete (qui devrait
ramener moins d'info mais au moins celle qu'il me faut) windev me dit qu'il
n'y a pas de connection courante...




"Dominique Lecocq" message de groupe de discussion : 47a72505$0$895$
Bonjour,
juste une remarque : même pour à des fin de test, IL NE FAUT PAS UTILISER
"SA", c'est trop dangereux, crée un user, avec des droit sur tes objets ca
prend 3 minutes.

Bon courage

Dominique "QNX" Lecocq


bonjour,


J'ai un soucis avec une connection SQLserver : la connection passe
bien mais les requetes non ???

------------------------------------------------------------------------------------------------------------------
SI HDécritConnexion("SQLserver", "sa", "dba", "JACQUA-SPEIGLOCAL",
"test", "SQLNCLI", hOLectureEcriture, "", hCurseurServeur +
hCurseurOpenKeyset) = Faux ALORS
Erreur("HS")
SINON
Info("OK")
FIN

sql est une chaîne
sql = " select * from TABLETEST "
MaRequête est une Source de Données

SI PAS HExécuteRequêteSQL(MaRequête,sql) ALORS
Erreur("Erreur d'initialisation de la requête"+RC+HErreurInfo())
RETOUR
FIN

HLitPremier(MaRequête)
TANTQUE PAS HEnDehors()
Trace(MaRequête.col1)
HLitSuivant()
FIN
------------------------------------------------------------------------------------------------------------------

J'ai le message "erreur d'init de la requete"
"erreur dans le code de la requete"
"Fichier TABLETEST inconnu"

La connection est etablie : j'ai verifié sur la base
La table existe bien
Je suis sur le bon schema.

Une idée , une suggestion ?



adrien
Le #14546841
Bonjour,

Normalement la fonction hnbEnr(MaRequête) ferait l'affaire,

Cordialement,
Adrien
Publicité
Poster une réponse
Anonyme