Squeeze et PHP5.2

Le
Grégoire COUTANT
Bonjour à tous,
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui je le
sais n'est plus maintenu.

J'ai commencé à installer tous les paquets annexes dont j'ai besoin
(apache2, bind etc) par contre je bute sur cette version.
Quand j'essaie d'installer php5.2 en utilisant le dépôt de la version
oldstable, j'ai un nombre de conflit assez hallucinant qui sont tout
bonnement incompatible (bind9 etc.)
Quel est la meilleure solution ? Certains d'entres vous ont-ils déjà
installé cette configuration ?

Merci

Greg

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/5017A22B.4070004@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Luc Novalès
Le #24670481
This is a cryptographically signed message in MIME format.

--------------ms060009080605070909010707
Content-Type: multipart/alternative;
boundary="------------010307010608050101000500"

This is a multi-part message in MIME format.
--------------010307010608050101000500
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

Bonjour,

Le 31/07/2012 11:15, Grégoire COUTANT a écrit :
Bonjour à tous,
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui je
le sais n'est plus maintenu.



La bonne méthode serait peut être d'utiliser le service snapshot debi an.
La version PHP 5.2.12 est rentrée dans la squeeze le 11 janvier 2010

En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list
deb http://snapshot.debian.org/archive/debian/20100112T220332Z/ squeeze m ain

tous les paquets disponibles à cette date, donc cohérents avec cette
version php5 deviendront accessibles et la bonne ligne apt-get ou
aptitude (pour forcer l'utilisation de ces vieux paquets) devrait
permettre l'installation sans problèmes (hormis ceux de sécurité ;) .

Luc.

--

_ o
/ \____
_/ O °

Faites un cadeau aux générations futures,
abandonnez votre voiture !


--------------010307010608050101000500
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Bonjour,<br>
<br>
Le 31/07/2012 11:15, Gr&eacute;goire COUTANT a &eacute;crit&nbsp;:
&agrave; tous,
<br>
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui
je le sais n'est plus maintenu.
<br>
</blockquote>
<br>
La bonne m&eacute;thode serait peut &ecirc;tre d'utiliser le service snapshot
debian. <a
href="http://packages.debian.org/changelogs/pool/main/p/php5/php5_5.3.3 -7+squeeze13/changelog">La
version PHP 5.2.12 est rentr&eacute;e dans la squeeze le 11 janvier 2010</a><br>
<br>
En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list<br>
deb squeeze main<br>
<br>
tous les paquets disponibles &agrave; cette date, donc coh&eacute;ren ts avec cette
version php5 deviendront accessibles et la bonne ligne apt-get ou
aptitude (pour forcer l'utilisation de ces vieux paquets) devrait
permettre l'installation sans probl&egrave;mes (hormis ceux de s&eacu te;curit&eacute; ;)
.<br>
<br>
Luc.<br>
<br>
<pre class="moz-signature" cols="72">--

_ o
/ \____
_/ O &deg;

Faites un cadeau aux g&eacute;n&eacute;rations futures,
abandonnez votre voiture !
</pre>
</body>
</html>

--------------010307010608050101000500--

--------------ms060009080605070909010707
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature
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 --------------ms060009080605070909010707--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Caillibaud
Le #24670561
Le 31/07/12 à 11:15, Grégoire COUTANT GC> Bonjour à tous,
GC> J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui je le
GC> sais n'est plus maintenu.
GC>
GC> J'ai commencé à installer tous les paquets annexes dont j'ai besoin
GC> (apache2, bind etc...) par contre je bute sur cette version.
GC> Quand j'essaie d'installer php5.2 en utilisant le dépôt de la version
GC> oldstable, j'ai un nombre de conflit assez hallucinant qui sont tout
GC> bonnement incompatible (bind9 etc....)

Assez logique si tu veux installer du paquet lenny dans une squeeze.

GC> Quel est la meilleure solution ? Certains d'entres vous ont-ils dé jà
GC> installé cette configuration ?

C'est amha franchement à déconseiller, j'espère que c'est pa s ouvert au public !

J'avais eu besoin de faire ça sur une ip locale pour préparer une migration.

C'est vrai que j'avais un peu galéré et noté ce que j'avais fait
http://ll.lairdutemps.org/linux/adminsys/php_5.2_on_squeeze

Pour un cas comme ça, (je suppose que tu peux pas modifier l'appli pou r passer à 5.3 ?), si
c'est public tu as intérêt à pas mal sécuriser en amont.

1) Une VM lenny minimale sur une ip privée, avec un frontal web qui ne redirigera que ce qu'il
faut vers elle après un max de contrôles si tu peux.

2) Récupérer les paquets source php 5.2 de lenny et les recompile r sur une squeeze (prend
juste le cgi et pas le mod_apache, tu auras moins de dépendances à   satisfaire). Mais ne pas
mettre trop de truc sur cette squeeze car elle est une faille ambulante (si tu as une appli qui
supporte pas 5.3, c'est probablement un truc abandonné plein de trous)

3) Jongler avec du pinning comme dans le tuto, mais
- changer lenny par oldstable
- ça c'est foireux :
aptitude -t lenny --disable-columns -F "%p" search ^php5|tr 'n' ' '
à remplacer par
aptitude --disable-columns -F "%p" search ^php5~Aoldstable|tr 'n' ' '

--
Daniel

Un classique c'est ce que tout le monde veut avoir lu
et que personne ne veut lire
Mark Twain

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Luc Novalès
Le #24671301
This is a cryptographically signed message in MIME format.

--------------ms080601040501060109080607
Content-Type: multipart/alternative;
boundary="------------080507080308050503040401"

This is a multi-part message in MIME format.
--------------080507080308050503040401
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

Le 31/07/2012 11:58, Luc Novalès a écrit :
Bonjour,

Le 31/07/2012 11:15, Grégoire COUTANT a écrit :
Bonjour à tous,
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui je
le sais n'est plus maintenu.



La bonne méthode serait peut être d'utiliser le service snapshot
debian. La version PHP 5.2.12 est rentrée dans la squeeze le 11
janvier 2010

En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list
deb http://snapshot.debian.org/archive/debian/20100112T220332Z/
squeeze main

tous les paquets disponibles à cette date, donc cohérents avec cett e
version php5 deviendront accessibles et la bonne ligne apt-get ou
aptitude (pour forcer l'utilisation de ces vieux paquets) devrait
permettre l'installation sans problèmes (hormis ceux de sécurité ;) .



|aptitude -o Acquire::Check-Valid-Untilúlse update

pour éviter l'erreur disant que le dépot ne va pas être pris en com pte
car trop ancien.

A+
Luc.|

--

_ o
/ \____
_/ O °

Faites un cadeau aux générations futures,
abandonnez votre voiture !


--------------080507080308050503040401
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Le 31/07/2012 11:58, Luc Noval&egrave;s a &eacute;crit&nbsp;:
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
Bonjour,<br>
<br>
Le 31/07/2012 11:15, Gr&eacute;goire COUTANT a &eacute;crit&nbsp;:

&agrave; tous, <br>
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP
qui je le sais n'est plus maintenu. <br>
</blockquote>
<br>
La bonne m&eacute;thode serait peut &ecirc;tre d'utiliser le servic e snapshot
debian. <a moz-do-not-send="true"
href="http://packages.debian.org/changelogs/pool/main/p/php5/php5_5.3.3 -7+squeeze13/changelog">La

version PHP 5.2.12 est rentr&eacute;e dans la squeeze le 11 janvi er
2010</a><br>
<br>
En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list<br>
deb <a moz-do-not-send="true" class="moz-txt-link-freetext"
href="http://snapshot.debian.org/archive/debian/20100112T220332 Z/">http://snapshot.debian.org/archive/debian/20100112T220332Z/</a>
squeeze main<br>
<br>
tous les paquets disponibles &agrave; cette date, donc coh&eacute;r ents avec
cette version php5 deviendront accessibles et la bonne ligne
apt-get ou aptitude (pour forcer l'utilisation de ces vieux
paquets) devrait permettre l'installation sans probl&egrave;mes (ho rmis
ceux de s&eacute;curit&eacute; ;) .<br>
</blockquote>
<br>
<code>aptitude -o Acquire::Check-Valid-Untilúlse update <br>
<br>
pour &eacute;viter l'erreur disant que le d&eacute;pot ne va pas &e circ;tre pris en
compte car trop ancien.<br>
<br>
A+<br>
Luc.</code><br>
<br>
<pre class="moz-signature" cols="72">--

_ o
/ \____
_/ O &deg;

Faites un cadeau aux g&eacute;n&eacute;rations futures,
abandonnez votre voiture !
</pre>
</body>
</html>

--------------080507080308050503040401--

--------------ms080601040501060109080607
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature
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 --------------ms080601040501060109080607--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégoire COUTANT
Le #24671331
Merci pour vos réponses Luc et Daniel.
Je suis en train de tester une solution avec compilation de PHP, je vous
ferai le retour si ça fonctionne.

Greg

Le 31/07/2012 15:53, Luc Novalès a écrit :
Le 31/07/2012 11:58, Luc Novalès a écrit :
Bonjour,

Le 31/07/2012 11:15, Grégoire COUTANT a écrit :
Bonjour à tous,
J'ai besoin d'installer sur une squeeze la version 5.2 de PHP qui je
le sais n'est plus maintenu.



La bonne méthode serait peut être d'utiliser le service snapshot
debian. La version PHP 5.2.12 est rentrée dans la squeeze le 11
janvier 2010

En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list
deb http://snapshot.debian.org/archive/debian/20100112T220332Z/
squeeze main

tous les paquets disponibles à cette date, donc cohérents avec cette
version php5 deviendront accessibles et la bonne ligne apt-get ou
aptitude (pour forcer l'utilisation de ces vieux paquets) devrait
permettre l'installation sans problèmes (hormis ceux de sécurité ;) .



|aptitude -o Acquire::Check-Valid-Untilúlse update

pour éviter l'erreur disant que le dépot ne va pas être pris en compte
car trop ancien.

A+
Luc.|

--

_ o
/ \____
_/ O °

Faites un cadeau aux générations futures,
abandonnez votre voiture !




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Grégoire COUTANT
Le #24673311
Bonjour,
Au final, j'ai fais différemment et ça fonctionne.
Installation d'apache, bind et autres via aptitude.
Installation PHP + modules (APC, curl etc...) en compilant les sources
dans /opt puis ajout du chemin des binaires dans le PATH.

Plus que Qmail et ça sera bon.

Merci à tous

Grégoire


Le 31/07/2012 11:58, Luc Novalès a écrit :
La bonne méthode serait peut être d'utiliser le service snapshot debian.
La version PHP 5.2.12 est rentrée dans la squeeze le 11 janvier 2010

En ajoutant la ligne suivante dans un nouveau fichier
/etc/apt/sources.list.d/php5.list
deb http://snapshot.debian.org/archive/debian/20100112T220332Z/ squeeze main

tous les paquets disponibles à cette date, donc cohérents avec cette
version php5 deviendront accessibles et la bonne ligne apt-get ou
aptitude (pour forcer l'utilisation de ces vieux paquets) devrait
permettre l'installation sans problèmes (hormis ceux de sécurité ;) .

Luc.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme