SSE2 requirement !

Le
Pascal LACROIX
Bonjour,

Voilà une contrainte agaçante un programme pourtant sympa de part ses
fonctionnalités qui exige un CPU qui admet les instructions SSE2.
- Il s'agit de la version 2.4 de Lightzone, qui est un produit
commercial avec une version gratuite pour linux.

Cette exigence me surprend, mais c'est comme ça !

Je ne souhaite pas pour cela me séparer de ma machine actuelle, "AMD
Athlon(TM) XP 2200+" pour cela, si l'un d'entre vous a expérimente une
solution pour contourner ce problème d'exigence SSE2 je suis preneur.
Je pense à une solution qui passerait par un émulateur ?

En vous remerciant d'avance

bien cordialement.


--
God is dead.' -Nietzsche | 'Nietzsche is dead.' -God
88' _`88'_ `88888 | Pascal LACROIX

http://kikoucalou.chez-alice.fr

La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yann GHYS
Le #9539331
Bonjour,

Je ne connais pas les instructions SSE2.J'ai un portable Asus A6vm et
j'ai installé Lightzone dessus. Tout fonctionne sans aucun problème.
J'utilise la version 2.1.1. Est-ce différent ?

Pascal LACROIX a écrit :
Bonjour,

Voilà une contrainte agaçante un programme pourtant sympa de part ses
fonctionnalités qui exige un CPU qui admet les instructions SSE2.
- Il s'agit de la version 2.4 de Lightzone, qui est un produit
commercial avec une version gratuite pour linux.

Cette exigence me surprend, mais c'est comme ça !

Je ne souhaite pas pour cela me séparer de ma machine actuelle, "AMD
Athlon(TM) XP 2200+" pour cela, si l'un d'entre vous a expérimente une
solution pour contourner ce problème d'exigence SSE2 je suis preneur.
Je pense à une solution qui passerait par un émulateur ?

En vous remerciant d'avance

bien cordialement.







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal LACROIX
Le #9539311
On Mon, 07 May 2007 17:45:52 +0200
Yann GHYS
Bonjour,

Je ne connais pas les instructions SSE2.J'ai un portable Asus A6vm et
j'ai installé Lightzone dessus. Tout fonctionne sans aucun problème.
J'utilise la version 2.1.1. Est-ce différent ?




Bonjour Yann

J'utilisais moi aussi la version 2.1. sans aucun problème.
Pour la version 2.4 il faut un CPU qui supporte les instructions SSE2.
Je crois que c'est une question de forme ou méthode de calculs ???

Une fenêtre s'ouvre les réclame et on ne va pas plus en avant...
Donc sauf à changer mon PC ce qui n'est pas envisagé, je suis coincé.

Par contre il y aurait peut être une solution de secours en passant par
une émulation ?
C'est une idée, je ne sais pas si c'est possible et j'avoue que mes
connaissances pour y arriver seul avec un émulateurs sont faibles.
Si quelqu'un sait ou a écrit un tuto la dessus, je suis preneur et ce
serait sympa pour mes recherches photos.

--
God is dead.' -Nietzsche | 'Nietzsche is dead.' -God
88' _`88'_ `88888 | Pascal LACROIX

http://kikoucalou.chez-alice.fr

La vie est pleine d'une infinité d'absurdités, qui, impudemment, n'ont
même pas besoin de paraître vraisemblables; car elles sont vraies.
Vincent Lefevre
Le #9538731
On 2007-05-07 18:04:13 +0200, Pascal LACROIX wrote:
J'utilisais moi aussi la version 2.1. sans aucun problème.
Pour la version 2.4 il faut un CPU qui supporte les instructions SSE2.
Je crois que c'est une question de forme ou méthode de calculs ???



Je ne sais pas du tout ce qu'il fait, mais sache que gcc est buggé
sur x86 si le FPU traditionnel est utilisé pour le type double (bug
323 de gcc). Et il peut y avoir d'autres problèmes. Cf

http://www.vinc17.org/research/extended.fr.html

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
cedric cellier
Le #9538661
-[ Wed, May 09, 2007 at 12:00:23AM +0200, Vincent Lefevre ]----
On 2007-05-07 18:04:13 +0200, Pascal LACROIX wrote:
> J'utilisais moi aussi la version 2.1. sans aucun problème.
> Pour la version 2.4 il faut un CPU qui supporte les instructions SSE2.
> Je crois que c'est une question de forme ou méthode de calculs ???

Je ne sais pas du tout ce qu'il fait, mais sache que gcc est buggé
sur x86 si le FPU traditionnel est utilisé pour le type double (bug
323 de gcc). Et il peut y avoir d'autres problèmes. Cf

http://www.vinc17.org/research/extended.fr.html



Tu pense qu'ils auraient choisi d'utiliser le SSE2 à la place du FPU pour
ne pas risquer de rencontrer un bug qui, si je comprend bien, est
spécifique à Linux ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Lefevre
Le #9538371
On 2007-05-09 10:58:13 +0200, cedric cellier wrote:
Tu pense qu'ils auraient choisi d'utiliser le SSE2 à la place du FPU
pour ne pas risquer de rencontrer un bug qui, si je comprend bien,
est spécifique à Linux ?



Peut-être pas. Pour la version 2.4, SSE2 est requis même sous
Windows[*], qui n'a pas le problème que je mentionne (car c'est de
la double précision par défaut, et pas de la précision étendue).

[*] http://www.lightcrafts.com/products/lightzone/download/

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme