ssh connection reset by peer

Le
Michel
Bonjour,

Sur un réseau local tout ce qu'il y a d'ordinaire, j'ai un phénomène
étrange: lorsque je me connecte à une machine du réseau par:
ssh toto@192.168.1.xxx, pas de problème.
En revanche, si je m'y connecte par son nom de machine ( disons titi ):
ssh toto@titi, j'ai systématiquement ce message:
ssh_exchange_identification: read: Connection reset by peer
et sur titi, une ligne est ajoutée à /etc/hosts.deny avec mon IP.

Pour pouvoir m'y connecter à nouveau ( par son IP ), je dois effacer
cette ligne.

Pourtant, dans le /etc/hosts de titi, j'ai:
127.0.0.1 localhost
127.0.0.1 titi
192.168.1.xxx titi

Je passe probablement à côté d'un truc évident, mais là, je sèche!

Il y a-t-il quelqu'un pour combler cette lacune?

Bon WE à tous

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michel
Le #26390187
Le 20/02/2016 14:01, Michel a écrit :
Bonjour,

Sur un réseau local tout ce qu'il y a d'ordinaire, j'ai un phénomène
étrange: lorsque je me connecte à une machine du réseau par:
ssh , pas de problème.
En revanche, si je m'y connecte par son nom de machine ( disons titi ):
ssh , j'ai systématiquement ce message:
ssh_exchange_identification: read: Connection reset by peer
et sur titi, une ligne est ajoutée à /etc/hosts.deny avec mon IP.

Pour pouvoir m'y connecter à nouveau ( par son IP ), je dois effacer
cette ligne.

Pourtant, dans le /etc/hosts de titi, j'ai:
127.0.0.1 localhost
127.0.0.1 titi
192.168.1.xxx titi

Je passe probablement à côté d'un truc évident, mais là, je sèche!

Il y a-t-il quelqu'un pour combler cette lacune?

Bon WE à tous

Michel



Ah, je corrige: lorsque je m'y connecte par son IP, je ne peux le faire
qu'une seule fois. Ensuite, j'ai le même phénomène, et une ligne est
ajoutée à /etc/hosts.deny de titi avec mon IP:
sshd: 192.168.1.yyy

Ce qui est bizarre, c'est que je n'ai ce problème que depuis une seule
machine, les autres se connectent à titi sans problème, que ce soit avec
son IP ou son nom.

Michel
Alain
Le #26390196
On 20/02/2016 14:01, Michel wrote:
Bonjour,
Sur un réseau local tout ce qu'il y a d'ordinaire, j'ai un phénomène
étrange: lorsque je me connecte à une machine du réseau par:
ssh , pas de problème.
En revanche, si je m'y connecte par son nom de machine ( disons titi ):
ssh ,



Bjour,

pour que ça marche il faut l'IP de titi ...
faut que titi soit dans le DNS et que le client ajoute le domaine par défaut
ou bien une ligne titi dans /etc/hosts

j'ai systématiquement ce message:
ssh_exchange_identification: read: Connection reset by peer
et sur titi, une ligne est ajoutée à /etc/hosts.deny avec mon IP.



la demande de connexion arrive sur la bonne machine
mais elle déplait à un dispositif de sécurité sur titi

je crois que hosts.deny ne s'auto modifie pas tout seul par défaut
vous avez une appli genre tcp wrappers ou fail2ban ?
regardez les configs et en premier celle de sshd (AllowUsers)

a+
Michel
Le #26390202
Le 20/02/2016 15:18, Alain a écrit :
On 20/02/2016 14:01, Michel wrote:
Bonjour,
Sur un réseau local tout ce qu'il y a d'ordinaire, j'ai un phénomène
étrange: lorsque je me connecte à une machine du réseau par:
ssh , pas de problème.
En revanche, si je m'y connecte par son nom de machine ( disons titi ):
ssh ,



Bjour,

pour que ça marche il faut l'IP de titi ...
faut que titi soit dans le DNS et que le client ajoute le domaine par défaut
ou bien une ligne titi dans /etc/hosts

j'ai systématiquement ce message:
ssh_exchange_identification: read: Connection reset by peer
et sur titi, une ligne est ajoutée à /etc/hosts.deny avec mon IP.



la demande de connexion arrive sur la bonne machine
mais elle déplait à un dispositif de sécurité sur titi

je crois que hosts.deny ne s'auto modifie pas tout seul par défaut
vous avez une appli genre tcp wrappers ou fail2ban ?
regardez les configs et en premier celle de sshd (AllowUsers)

a+



Bonjour,

l'IP de titi est connue ( les /etc/hosts des machines sont bien
renseignés ), mais ce qui me chiffonne, c'est que sur 5 machines, c'est
la seule pour qui la connexion est refusée.

À chaque connexion, l'IP est ajoutée à /etc/hosts.deny comme ceci:
sshd: 192.168.0.xxx
et la connexion suivante est rejetée.

Il n'y a pas d'applications genre tcp wrappers ou fail2ban tournant sur
cette machine, c'est juste un PC bureautique et internet sans plus,
tournant avec une wheezy basique.
yamo'
Le #26390207
Salut,

Michel a écrit le 20/02/2016 15:54 :

Il n'y a pas d'applications genre tcp wrappers ou fail2ban tournant sur
cette machine, c'est juste un PC bureautique et internet sans plus,
tournant avec une wheezy basique.




Les machines sont à jour?

J'afficherais un tail -F /var/log/auth.log /var/log/syslog sur le
serveur et je tenterais des connexions pour voir ce qu'il se passe.


--
Stéphane
Michel
Le #26390208
Le 20/02/2016 16:18, yamo' a écrit :
Salut,

Michel a écrit le 20/02/2016 15:54 :

Il n'y a pas d'applications genre tcp wrappers ou fail2ban tournant sur
cette machine, c'est juste un PC bureautique et internet sans plus,
tournant avec une wheezy basique.




Les machines sont à jour?

J'afficherais un tail -F /var/log/auth.log /var/log/syslog sur le
serveur et je tenterais des connexions pour voir ce qu'il se passe.




Merci à vous deux...

J'ai en effet trouvé dans les logs un fichier denyhosts qui indiquait
bien qu'il refusait la connexion de cette machine. Mais alors, pourquoi
j'avais bien pu installer ça? Et ça doit faire un sacré bout de temps...
Cette machine a bien 8 / 10 ans, et il n'y a eu que des dist-upgrades,
pas de réinstallation...

J'ai purgé denyhosts et tout est rentré dans l'ordre.

Désolé pour le bruit.

Cordialement
Michel
yamo'
Le #26390321
Salut,

Michel a écrit le 20/02/2016 16:41 :
J'ai en effet trouvé dans les logs un fichier denyhosts qui indiquait
bien qu'il refusait la connexion de cette machine. Mais alors, pourquoi
j'avais bien pu installer ça? Et ça doit faire un sacré bout de temps...
Cette machine a bien 8 / 10 ans, et il n'y a eu que des dist-upgrades,
pas de réinstallation...

J'ai purgé denyhosts et tout est rentré dans l'ordre.




Surtout que sur debian, il vaut mieux utiliser fail2ban plutôt que
denyhosts qui n'est plus maintenu dans stable et testing :



--
Stéphane
Publicité
Poster une réponse
Anonyme