syntaxe Condition

Le
Pascal
bonjour ,
petit exemple vaut mieux qu'un long discours
Cellule B : une formule je met =SI(A3=0;0;Si.
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met zéro
?

merci d'avance
Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #16532541
Bonsoir,

Essaie
=SI(ET(ESTNUM(A3);A3=0);0;.........)

--
Salutations
JJ


"Pascal" ,com> a écrit dans le message de news:
%23TZUo8I$
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met
zéro ?

merci d'avance
Pascal





lSteph
Le #16532651
Bonsoir,

On pourrait interpréter encore sur ce thème une cellule vaut une
cellule et non pas zéro
(pour sinon t'as rien dit donc je suppose ci après le "sinon")

On peut aussi cocher autre interpretation des formules ce qui fera
varier ce qui suit
selon le cas: voici non coché après tu peux t'amuser.

Faut bien sûr avoir coché Outils options Affichage valeurs zéro

une cellule peut contenir zéro ou renvoyer la valeur zéro via une
formule

si on applique ceci =SI(A1=0;0;"sinon")

elle peut ne rien contenir dans ce cas l'évaluation du contenu de la
cellule est zéro

ou bien elle peut contenir "" ou ="" (ce qui signifie rien
textuellement mais est déjà qqchose)
donc elle renverra "sinon"

ou bien contenir 0 et la formule renverra 0

contenir un texte elle renverra "sinon"

Comme je disais si tu mets autre interpretation elle renvoie zéro


A partir de là il suffit de savoir ce qu'on veut.

@+

--
lSteph


On 12 août, 16:23, "Pascal" ,com> wrote:
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a 3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met zéro
?

merci d'avance
Pascal


isabelle
Le #16532761
bonjour Pascal,

=SI(ESTVIDE(A1);"cellule est vide";SI(A1=0;"est égal à zéro";"ni l'un ni l'autre"))

isabelle

Pascal a écrit :
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met zéro
?

merci d'avance
Pascal





Sam
Le #16532921
Bonjour,
je me suis amusé à faire ceci :
=SI(A3&"$"="0$";0;1)
ça fonctionne.

Nota tu peux remplacer $ par tout ce que tu veux : F, euros, Yen ;-)

Cordialement
Michel dit "Sam"


"Pascal" ,com> a écrit dans le message de news:
%23TZUo8I$
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met
zéro ?

merci d'avance
Pascal





Pascal
Le #16532891
merci à vous tous,
pour info cette cellule contient soit 0 soit 2 soit 3 et des actions sont
déclenchée selon la valeur lue
je retiens donc la solution d'Isabelle

cordialement
Pascal


"isabelle" a écrit dans le message de groupe de discussion :
#i7k7cJ$
bonjour Pascal,

=SI(ESTVIDE(A1);"cellule est vide";SI(A1=0;"est égal à zéro";"ni l'un ni
l'autre"))

isabelle

Pascal a écrit :
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si
a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met
zéro ?

merci d'avance
Pascal





lSteph
Le #16532851
..voilà qui illustre bien la controverse d'interpretation liée à ta
question et l'interprétation du vaut zéro
si j'applique la formule de Jacky et que a3 est vide je n'obtiens pas
zéro
alors que si je fais la somme de a3 j'obtiens bien zéro
si j'utilise la formule zaza ça dit bien que la cellule est vide

Alors vaut-elle zéro?

;-)

On 12 août, 18:19, isabelle wrote:
bonjour Pascal,

=SI(ESTVIDE(A1);"cellule est vide";SI(A1=0;"est égal à zéro";"n i l'un ni l'autre"))

isabelle

Pascal a écrit :

> bonjour ,
> petit exemple vaut mieux qu'un long discours...
> Cellule B : une formule je met =SI(A3=0;0;Si..........
> Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
> ma condition est toujours remplie !
> Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je me t zéro
> ?

> merci d'avance
> Pascal


Misange
Le #16533051
ce que je ne comprends pas dans ce que tu dis c'est le si a3<1 !!
que tu aies un pb pour faire la différence entre vide et 0, ça se
comprends, voir les deux réponses déjà donnée. MAis je comprends mal
comment en entrant 0.2 dans A3, ta formule peut renvoyer 0...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Pascal a écrit :
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met zéro
?

merci d'avance
Pascal





lSteph
Le #16533001
;-)

... d'ailleurs Pascal finit par préférer la solution d'Isabelle qui
resterait
très bonne pour palier à d'autres alternatives alors que dans le cas
qu'il vient de préciser
les différentes formules proposées (à part le $) iraient aussi bien.

Dans la mesure où la controverse du vaut zéro est dissipée, cela n'a
plus autant d'intérêt,
ni pour Paul ni pour Mickey

--
lSteph
(... et je n'en suis donc pas surpris)

On 12 août, 18:46, Misange
ce que je ne comprends pas dans ce que tu dis c'est le si a3<1 !!
que tu aies un pb pour faire la différence entre vide et 0, ça se
comprends, voir les deux réponses déjà donnée. MAis je comprends mal
comment en entrant 0.2 dans A3, ta formule peut renvoyer 0...

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !http://xlwiki. free.fr/wikihttp://www.excelabo.net

Pascal a écrit :

> bonjour ,
> petit exemple vaut mieux qu'un long discours...
> Cellule B : une formule je met =SI(A3=0;0;Si..........
> Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si a3<1
> ma condition est toujours remplie !
> Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je me t zéro
> ?

> merci d'avance
> Pascal


Sam
Le #16533811
ah ben voilà,
pour une fois que j'avais la plus courte, personne n'en veut !

et on peut réduire à =SI(A3&""="0";0;1)

Cordialement
Michel dit "Sam"

"Sam" 48a1bb0c$0$911$


Bonjour,
je me suis amusé à faire ceci :
=SI(A3&"$"="0$";0;1)
ça fonctionne.

Nota tu peux remplacer $ par tout ce que tu veux : F, euros, Yen ;-)

Cordialement
Michel dit "Sam"


"Pascal" ,com> a écrit dans le message de news:
%23TZUo8I$
bonjour ,
petit exemple vaut mieux qu'un long discours...
Cellule B : une formule je met =SI(A3=0;0;Si..........
Cellule A : si j'entre la valeur 0(zéro) ou rien (cellule vide) OU Si
a3<1
ma condition est toujours remplie !
Quel est la syntaxe exacte pour dire Si ma cellule A VAUT zéro je met
zéro ?

merci d'avance
Pascal









Molle et piquée
Le #16534101
Michel dit "Sam"

ah ben voilà,
pour une fois que j'avais la plus courte, personne n'en veut !
et on peut réduire à =SI(A3&""="0";0;1)



;o)))
= --(A3<>0)

Paul & Mickey
--
@+
;o)))
Publicité
Poster une réponse
Anonyme