Syntaxe CpteDom

Le
jcp66
Bonjour
J'ai un controle qui est :
=CpteDom("[PhotoSite_Code]";"T_PhotoSite")
Il compte le nombre d'enregistrements de la table T_PhotoSite

Je voudrais maintenant afficher le nombre d'enregistrements pour lesquels
PhotoSite_Code est égal au controle Site_CodeLong du formulaire.

Cela fait un moment que je "bataille" avec les différenbtes syntaxes sans y
arriver. Alors si quelqu'un peut m'ader ce sera avec plaisir.

Merci
jcp
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #6348871
Salut,

"jcp66"
| J'ai un controle qui est :
| =CpteDom("[PhotoSite_Code]";"T_PhotoSite")
| Il compte le nombre d'enregistrements de la table T_PhotoSite


Pas vraiment...

Ici, tu comptes le nombre d'enregistrements dans lesquels le champ
[PhotoSite_Code] est non null !

Pour compter les enregistrements, quelque soit le contenu du champ
[PhotoSite_Code] il faut écrire :

Üount("*";"T_PhotoSite")


| Je voudrais maintenant afficher le nombre d'enregistrements pour lesquels
| PhotoSite_Code est égal au controle Site_CodeLong du formulaire.


Üount("*";"T_PhotoSite";"PhotoSite_Code=" & Me.Site_CodeLong )

pour autant que PhotoSite_Code est de type numérique...

Si de type "texte" :

Üount("*";"T_PhotoSite";"PhotoSite_Code='" & Me.Site_CodeLong & "'")

=>>> à la loupe, la fin est : =' " & Me.Site_CodeLong & " ' ")

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
jcp66
Le #6348851
J'ai un petit probleme.
Mon champ est bien texte alors j'ai mis :
=CpteDom("*";"T_PhotoSite";"PhotoSite_Code=' " & Me.Site_CodeLong & "'")
Et j'ai la réponse :
#Nom ?

Par contre si je mets
=CpteDom("*";"T_PhotoSite";"PhotoSite_Code='81004VENE'")
(81004VENE étant la valeur du champ PhotoSite_Code pour certains enreg)
La cela marche. La réponse est 5
OK

J'ai essayé différentes syntaxes sans y parvenir

Désolé

jcp
3stone
Le #6348831
re,

"jcp66"
| J'ai un petit probleme.
| Mon champ est bien texte alors j'ai mis :
| =CpteDom("*";"T_PhotoSite";"PhotoSite_Code=' " & Me.Site_CodeLong & "'")
| Et j'ai la réponse :
| #Nom ?
|
| Par contre si je mets
| =CpteDom("*";"T_PhotoSite";"PhotoSite_Code='81004VENE'")
| (81004VENE étant la valeur du champ PhotoSite_Code pour certains enreg)
| La cela marche. La réponse est 5
| OK


J'avais dit :

Si de type "texte" :

Üount("*";"T_PhotoSite";"PhotoSite_Code='" & Me.Site_CodeLong & "'")

=>>> à la loupe, la fin est : =' " & Me.Site_CodeLong & " ' ")

Il ne faut pas d'espace entre les quillemets simples et doubles !!
Ni devant Me.Site_CodeLong, ni derrière !

Et ceci, à condition que sur le formulaire ce soit bien "Site_CodeLong"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
jcp66
Le #6348821
Merci 3stone

"3stone" %23tVBbT$
re,

"jcp66"
| J'ai un petit probleme.
| Mon champ est bien texte alors j'ai mis :
| =CpteDom("*";"T_PhotoSite";"PhotoSite_Code=' " & Me.Site_CodeLong & "'")
| Et j'ai la réponse :
| #Nom ?
|
| Par contre si je mets
| =CpteDom("*";"T_PhotoSite";"PhotoSite_Code='81004VENE'")
| (81004VENE étant la valeur du champ PhotoSite_Code pour certains enreg)
| La cela marche. La réponse est 5
| OK


J'avais dit :

Si de type "texte" :

Üount("*";"T_PhotoSite";"PhotoSite_Code='" & Me.Site_CodeLong & "'")

=>>> à la loupe, la fin est : =' " & Me.Site_CodeLong & " ' ")

Il ne faut pas d'espace entre les quillemets simples et doubles !!
Ni devant Me.Site_CodeLong, ni derrière !

Et ceci, à condition que sur le formulaire ce soit bien "Site_CodeLong"

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)





Publicité
Poster une réponse
Anonyme