syntaxe de NBVAL

Le
Pascal
bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #6750721
Bonjour

Créer des noms de champ dynamiques avec

Þcaler($a$2;;;nbval(a:a)-1)

et mettre les noms de champ dans la formule

http://boisgontierjacques.free.fr/pages_site/ChampDynamique.htm

JB
http://boisgontierjacques.free.fr

On 1 juin, 11:55, "Pascal" ,com> wrote:
bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal


Jacky
Le #6750911
Bonjour,
Le mieux serait de nommer les plages dynamiquement
insertion/nom/définir
LesMoisÞCALER(Feuil1!$A$2;;;NBVAL(Feuil1!$A:$A)-1)
LesMontantsÞCALER(Feuil1!$C$2;;;NBVAL(Feuil1!$A:$A)-1)
Pour reprendre l'exemple de JB que tu as apparemment retenu
http://cjoint.com/?gbmzPsUIuW
--
Salutations
JJ


"Pascal" ,com> a écrit dans le message de news:
%
bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal



Daniel.C
Le #6750901
Bonjour.
=SOMMEPROD((MOIS(INDIRECT("$A$2:$A$"&NBVAL(A:A)))=...
Il est plus simple de définir une plage nommée dynamique :
Insertion / Nom / Définir, "ColonneA" et fait référence à :
ÞCALER($A$2;;;NBVAL($A:$A)-1)
"-1" si la cellule A1 contient une valeur.
Utilise ensuite :
=SOMMEPROD((MOIS(ColonneA)=...
et de même pour la colonne C.
Cordialement.
Daniel
"Pascal" ,com> a écrit dans le message de news:
%
bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal



Misange
Le #6750881
pour compléter la réponse de mes petits camarades (que je salue !)
si tu définis tes noms de façon dynamique, fais bien attention à ce
qu'il y ait exactement le même nombre d'éléments dans tes deux colonnes....
Pour cela, utilise
Þcaler($A$2;;;nbval($A:$A)-1)
et
Þcaler($C$2;;;nbval($A:$A)-1) et surtout pas $C:$C (ce que Jaccky
avait bien écrit d'ailleurs :-))

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal




Pascal
Le #6754181
merci à vous tous je ne connaissais pas du tout cette fonction
le seul "Hic" à cela c'est qu'il ne peut y avoir de blanc!
Pascal


"Misange"
pour compléter la réponse de mes petits camarades (que je salue !)
si tu définis tes noms de façon dynamique, fais bien attention à ce qu'il
y ait exactement le même nombre d'éléments dans tes deux colonnes....
Pour cela, utilise
Þcaler($A$2;;;nbval($A:$A)-1)
et
Þcaler($C$2;;;nbval($A:$A)-1) et surtout pas $C:$C (ce que Jaccky avait
bien écrit d'ailleurs :-))

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

bonjour,
dans la formule suivante, je suis limité de A2:A100
=SOMMEPROD((MOIS($A$2:$A$100)=MOIS(F2))*$C$2:$C$100)

pour l'adapter de A2 au nombre de cellule réellement occupé j'essaie
d'intégrer nbval
=SOMMEPROD((MOIS($A$2:$A nbval(A:A))=MOIS(F2))*$C$2:$C$100)
quel est la syntaxe exacte ?
merci d'avance
Pascal




Publicité
Poster une réponse
Anonyme