tableau croisés dynamique(help)

Le
Mike
Bonjour à tous

Help !!!!!

Je dois dans un tcd,calculer combien de convives ont mangé un certain
menule problème est que pour chaque menu dans la base de
données,chaque champ menu est relié à 5 articles, donc en posant mes
champs, elle calcule 5 patients par menu, et comme dans le fichier
cjoint ci dessous, elle devrait trouvé 3 patients pour le menu A, et 7
patients pour le menu harmony, faut-t'il poser un champs calculé(nbval)
ou groupé 2 champs, j'avoue, perdu

Un grand merci de vos idées

http://cjoint.com/?gsvaseMaqq

Mike
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DesseJ
Le #4913881
Bonjour Mike,

Si j'ai bien compris, en reprenant une idée d'AV, un exemple ici
http://cjoint.com/?gtiTrDrWI5

Cordialement,
SteF
Michel
Le #4913851
Bonjour

Efectivement j'ai insérer une colonne dans ma base, puis poser la
formule, avec un nouveau champs "test", puis rajouter dans mon tcd et
ca marche !!!! un grand merci !!!, peut-u me détailler la formule que
je comoprenne le détail de cette dernière...comment elle voit la
rupture du nom ?

=SI(SOMMEPROD((D$2:D2Ò)*(L$2:L2=L2))=1;1;0)

un grand merci de ta réponse

Mike



DesseJ a formulé la demande :
Bonjour Mike,

Si j'ai bien compris, en reprenant une idée d'AV, un exemple ici
http://cjoint.com/?gtiTrDrWI5

Cordialement,
SteF


--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net

DesseJ
Le #4911461
Bonjour Mike,

Je vais essayer d'être clair ;o)))

Sur ta deuxième ligne de ton tableau, le SOMMEPROD((B$2:B2²)*(A
$2:A2¢) compte le nombre de fois qu'apparaît la combinaison Menu-Nom
dans les plages A2:A2 et B2:B2.
Dans la troisième, la plage de recherche devient A2:A3 et B2:B3. Dans
ce cas, le SommeProd renvoie 2 pour 2 apparitions du couple "A
Dupont".
Comme l'on veut compter un couple une seule fois, on intègre le
SommeProd dans un Si : quand le couple apparaît la première fois, on
affecte 1 au résultat, sinon 0.

Cordialement
Stef
Publicité
Poster une réponse
Anonyme