Tiger 10.4.10 et PostFix

Le
mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Bonjour,

Cela fait quelques jours que j'essaie de faire fonctionner PostFix. J'ai
bien respecté les instructions données sur XRing, j'ai même essayé sur
deux machines, toutes deux sous 10.4.10 et ça ne veut pas marcher.

La config : je suis connecté derrière un routeur et une Freebox. J'ai
demandé à Free de laisser ouvert le port 25.

Suis-je vraiment incompétent ? Vous ne tarderez pas à me renseigner sur
ce sujet, gageons-le ! :)

--
<http://mloiseau.free.fr/blog>
Ça c'est du blog destroy avec rien dans la tête, oui !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patpro ~ patrick proniewski
Le #2684251
In article (Jean-Yves Bernier) wrote:

Erwan David
Il me semble que par défaut le postfix d'Apple n'écoute que sur la
loopback.


Par défaut, il écoute pas.
MAILSERVER=-NO-
dans /etc/hostconfig

L'utilitaire Postfix Enabler l'active, mais c'est plus sportif en shell:
http://www.macosxhints.com/article.php?story 031025022626398


la question portait sur 10.4, ça n'a rien a voir avec la 10.3 :


patpro

--
http://www.patpro.net/


nospam
Le #2637331
Jean-Yves Bernier
inet_interfaces = all (ou inet_interfaces = a.b.c.d pour le parano)
et ça roule.


Toujours en mode parano !

"only paranoïd survive"

Jacques
--
« Mac OS X Server à votre Service » est épuisé.
Vous pouvez désormais l'acquérir en PDF

patpro ~ patrick proniewski
Le #2636641
In article (Jacques Foucry) wrote:

Jean-Yves Bernier
inet_interfaces = all (ou inet_interfaces = a.b.c.d pour le parano)
et ça roule.


Toujours en mode parano !

"only paranoïd survive"


ouais, sauf que là ça sert à rien, ce qui compte c'est de définir pour
qui on va accepter de relayer (tant la source que la destination).

D'autant qu'ici, le but était d'être accessible sur internet, si j'ai
bien compris la demande initiale. Donc bon...

patpro

--
http://www.patpro.net/


patpro ~ patrick proniewski
Le #2684191
In article Erwan David
patpro ~ patrick proniewski
In article (Jacques Foucry) wrote:

Jean-Yves Bernier
inet_interfaces = all (ou inet_interfaces = a.b.c.d pour le parano)
et ça roule.


Toujours en mode parano !

"only paranoïd survive"


ouais, sauf que là ça sert à rien, ce qui compte c'est de définir pour
qui on va accepter de relayer (tant la source que la destination).


Oui, mais...

D'autant qu'ici, le but était d'être accessible sur internet, si j'ai
bien compris la demande initiale. Donc bon...



Justement sans modifier ce inet_interfaces on n'est pas joignable sur
internet, parceque postfix n'écoute que sur la loopback et pas sur
l'interface d'où arrivent les messages...


bien sûr. mon commentaire était pour le mode parano, pas pour la
modification de 'loopback' en 'all'

patpro

--
http://www.patpro.net/




mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #2684141
Erwan David
Que donne un postconf inet_interfaces ?


"inet_interfaces = all"
--
Ça c'est du blog destroy avec rien dans la tête, oui !

mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #2684151
Jean-Yves Bernier
postfix stop
postfix start


Alors, il semble qu'il ne s'était pas lancé au démarrage de la machine.
Je le lance, le terminal m'informe de ce que :

postfix/postfix-script: starting the Postfix mail system

mais ça ne fonctionne pas pour autant.
--
Ça c'est du blog destroy avec rien dans la tête, oui !

patpro ~ patrick proniewski
Le #2684091
In article
,
(Loiseau Michel)
wrote:

postfix/postfix-script: starting the Postfix mail system

mais ça ne fonctionne pas pour autant.


J'espère que tu connais une bonne voyante. Personne d'autre ne pourra
t'aider si tu donnes si peu de détails.

patpro

--
http://www.patpro.net/

mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #2679621
Jean-Yves Bernier
Loiseau Michel
mais ça ne fonctionne pas pour autant.


Que disent localement

$ telnet 127.0.0.1 25


telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host

et

$ telnet ip-de-la-machine 25


telnet: connect to address 100.0.0.1: Connection refused
telnet: Unable to connect to remote host

On en déduit quoi ? Il y a quelque chose de cassé ?
--
Ça c'est du blog destroy avec rien dans la tête, oui !


Nina Popravka
Le #2679611
On Sun, 23 Sep 2007 16:43:15 +0200,
(Loiseau Michel)
wrote:

telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host


Et si tu faisais "sudo service smtp start" avant ?
Nan, parce que je viens d'essayer et c'est dit dans le lien cité par
patpro je crois, et si on le démarre pas, effectivement ça ne
fonctionne pas :-)
--
Nina

mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #2679601
Nina Popravka
Et si tu faisais "sudo service smtp start" avant ?
Nan, parce que je viens d'essayer et c'est dit dans le lien cité par
patpro je crois, et si on le démarre pas, effectivement ça ne
fonctionne pas :-)


Je viens de faire. Ça me dit :

postfix/postfix-script: starting the Postfix mail system

Donc, ça semble marcher. Mais avant, plus tôt dans la journée, j'avais
fait un :

sudo posfix start

Et ça avait fait quelque chose aussi. :)

Ceci dit, après avoir fait un sudo service smtp start , j'ai les même
réponses aux commandes suggérées par Patpro. Bizarre, non ?
--
Ça c'est du blog destroy avec rien dans la tête, oui !

Publicité
Poster une réponse
Anonyme