Tiger, Apache2 et php5

Le
mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Bonjour,

Sur mon bon vieux G4 qui tourne sous Tiger, j'ai installé il y a déjà
fort longtemps un Apache 2 qui fonctionne parfaitement bien.

Par contre, là, pour faire des tests, j'aurais besoin d'installer et
d'activer php5 et je ne vois pas bien comment faire.

J'ai téléchargé la version de php5 disponible auprès de entropy.ch et
j'ai pratiqué à l'installation. Tout s'est bien déroulé mais je ne vois
pas ce qu'il me faut modifier, sans doute dans le httpd.conf, pour que
le php5 soit pris en compte.

Vous sauriez où je pourrais trouver de l'info claire et simple ?
Vous sauriez m'expliquer ce que je dois faire ?

Merci !

--
<http://mloiseau.free.fr/blog/>
<http://azerat.free.fr>
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jose.campos
Le #19552511
Loiseau Michel
Vous sauriez m'expliquer ce que je dois faire ?



Le plus simple (àmha) MAMP :
--
Jo
"Don't suffer from insanity, enjoy every minute of it."
mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #19552491
José Campos
Le plus simple (àmha) MAMP :


Oui mais non. :)
--
bgrandin
Le #19576861
Loiseau Michel
J'ai téléchargé la version de php5 disponible auprès de entropy.ch et
j'ai pratiqué à l'installation. Tout s'est bien déroulé mais je ne vois
pas ce qu'il me faut modifier, sans doute dans le httpd.conf, pour que
le php5 soit pris en compte.



Il doit falloir désactiver avec un "#" les lignes :

LoadModule php4_module libexec/httpd/libphp4.so

et

AddModule mod_php4.c

dans le httpd.conf et ajouter les lignes qui vont bien.

Il faut également compléter la directive quelque chose dans le genre
Si tu ne veux pas faire de bêtise, il est peut-être possible d'activer
les 2 (php4 et php5) en ajoutant une directive mod_php5 et en précisant
que les fichiers .php5 sont prise en charge par le module qui va bien
(OVH fait un truc dans le genre).

Je suppose que la solution MAMP proposée ne te convient pas, car il ne
s'agit pas simplement de faire du test, mais de se servir du Mac comme
serveur.


--
http://www.bdzone.com Le portail BD
mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #19580351
Benoît Grandin
Je suppose que la solution MAMP proposée ne te convient pas, car il ne
s'agit pas simplement de faire du test, mais de se servir du Mac comme
serveur.



Oui. Enfin pas du serveur "pro" hein. Plutôt pour m'amuser à le faire.
Ce qui est bizarre, c'est que l'installation de php5 a bien fonctionné
mais que je ne parviens pas à faire pointer le fichier httpd.conf de
Apache2 vers le fichier .so de php5. C'est peut-être bien de ce côté
qu'il faudrait que je regarde mais je ne sais pas trop où.
--
Publicité
Poster une réponse
Anonyme