Touche fn du clavier sans fil Apple

Le
Bastien Dejean
Bonjour,

J'ai installé /Arch Linux/ sur un iMac10,1 et mon clavier (QWERTY US
0239) a fonctionné dès la procédure l'installation, cependant, j'ai
rapidement déchanté :

– lorsque le prompt de connexion apparaît, le clavier n'est pas
connecté : il faut presser une touche (idem concernant la souris) ;
– la touche fn n'a aucun effet (F1 et fn + F1 renvoient le même
/keycode/ dans /xev/ et /showkey/).

Il semblerait qu'il existe un pilote adapté (hid_apple) puisque l'ID de
mon clavier apparaît en clair dans le source de celui-ci…

Pourriez-vous éclairer ma lanterne ?
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #22533111
Le 02/09/2010 10:44, Bastien Dejean a écrit :
Bonjour,

J'ai installé /Arch Linux/ sur un iMac10,1 et mon clavier (QWERTY US 0239) a fonctionné dès la procédure l'installation, cependant,
j'ai rapidement déchanté :

– lorsque le prompt de connexion apparaît, le clavier n'est pas connecté : il faut presser une touche (idem concernant la souris) ;
– la touche fn n'a aucun effet (F1 et fn + F1 renvoient le même /keycode/ dans /xev/ et /showkey/).

Il semblerait qu'il existe un pilote adapté (hid_apple) puisque l'ID de mon clavier apparaît en clair dans le source de celui-ci…

Pourriez-vous éclairer ma lanterne ?



Déjà, t'as tenté avec un clavier (USB) de PC ?

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Sergio
Le #22533131
Le 02/09/2010 11:01, Sergio a écrit :
Le 02/09/2010 10:44, Bastien Dejean a écrit :
Bonjour,

J'ai installé /Arch Linux/ sur un iMac10,1 et mon clavier (QWERTY US 0239) a fonctionné dès la procédure l'installation, cependant,
j'ai rapidement déchanté :

– lorsque le prompt de connexion apparaît, le clavier n'est pas connecté : il faut presser une touche (idem concernant la souris) ;
– la touche fn n'a aucun effet (F1 et fn + F1 renvoient le même /keycode/ dans /xev/ et /showkey/).

Il semblerait qu'il existe un pilote adapté (hid_apple) puisque l'ID de mon clavier apparaît en clair dans le source de celui-ci…

Pourriez-vous éclairer ma lanterne ?



Déjà, t'as tenté avec un clavier (USB) de PC ?



Je viens d'essayer la manip inverse (brancher un clavier Apple [azerty] sur mon PC SOUS Ubuntu). Pas de problèmes avec les touches
fonctions... Même les touches de contrôle du son fonctionnent ! Seules quelques touches du clavier alphabétiques sont différentes
(car je n'ai pas changé de table clavier...).

lsusb me donne :
Bus 001 Device 007: ID 05ac:0205 Apple, Inc. Extended Keyboard [Mitsumi]
Bus 001 Device 006: ID 05ac:1002 Apple, Inc. Extended Keyboard Hub [Mitsumi]

PS: Ce message a été tapé avec le clavier apple...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Bastien Dejean
Le #22533191
Sergio a écrit :

Je viens d'essayer la manip inverse (brancher un clavier Apple [azerty]
sur mon PC SOUS Ubuntu). Pas de problèmes avec les touches fonctions...
Même les touches de contrôle du son fonctionnent ! Seules quelques
touches du clavier alphabétiques sont différentes (car je n'ai pas
changé de table clavier...).

lsusb me donne :
Bus 001 Device 007: ID 05ac:0205 Apple, Inc. Extended Keyboard [Mitsumi]
Bus 001 Device 006: ID 05ac:1002 Apple, Inc. Extended Keyboard Hub
[Mitsumi]



Je vous remercie, mais l'on ne peut rien en conclure, puisque votre
clavier et votre distribution (quelle version du noyau ?) diffèrent.
Benoit Izac
Le #22534881
Bonjour,

le 02/09/2010 à 10:44, Bastien Dejean a écrit dans le message

J'ai installé /Arch Linux/ sur un iMac10,1 et mon clavier (QWERTY US
0239) a fonctionné dès la procédure l'installation, cependant, j'ai
rapidement déchanté :

– lorsque le prompt de connexion apparaît, le clavier n'est pas
connecté : il faut presser une touche (idem concernant la souris) ;
– la touche fn n'a aucun effet (F1 et fn + F1 renvoient le même
/keycode/ dans /xev/ et /showkey/).

Il semblerait qu'il existe un pilote adapté (hid_apple) puisque l'ID
de mon clavier apparaît en clair dans le source de celui-ci…

Pourriez-vous éclairer ma lanterne ?



Rien dans les logs (dmesg, /var/log/everything.log) ?
Est-ce que le module hid-apple est chargé au démarrage (lsmod) ?
Dans le cas contraire, tu peux rajouter dans /etc/rc.conf :
MODULES=(hid-apple)

Sinon,
% modinfo hid-apple
[...]
vermagic: 2.6.35-ARCH SMP preempt mod_unload
parm: fnmode:Mode of fn key on Apple keyboards (0 = disabled, [1] = fkeyslast, 2 = fkeysfirst) (uint)
parm: iso_layout:Enable/Disable hardcoded ISO-layout of the keyboard. (0 = disabled, [1] = enabled) (uint)

Comme tu peux le voir, ce module possède deux paramètres optionnels (les
valeurs par défaut sont indiqués par [x]). Je ne sais pas trop ce que
représentent fkeyslast/fkeysfirst, tu peux essayer en rajoutant dans
/etc/modprobe.d/modprobe.conf :
options hid-apple fnmode=2

Si un modprobe -r hid-apple && modprobe hid-apple ne fonctionne pas, il
te faudra rebooter pour que les changements soit pris en compte.

--
Benoit Izac
Bastien Dejean
Le #22537031
Benoit Izac a écrit :

Est-ce que le module hid-apple est chargé au démarrage (lsmod) ?



Oui.

% modinfo hid-apple
[...]
Je ne sais pas trop ce que
représentent fkeyslast/fkeysfirst, tu peux essayer en rajoutant dans
/etc/modprobe.d/modprobe.conf :
options hid-apple fnmode=2



J'ai déjà ajouté cette ligne, cela n'a aucun effet.
Il semblerait que le problème vienne du pilote bluetooth générique :

http://tinyurl.com/33wjjzo
http://tinyurl.com/28jusvw
Sergio
Le #22537121
Le 03/09/2010 12:46, Bastien Dejean a écrit :

> % modinfo hid-apple
> [...]
> Je ne sais pas trop ce que
> représentent fkeyslast/fkeysfirst, tu peux essayer en rajoutant dans
> /etc/modprobe.d/modprobe.conf :
> options hid-apple fnmode=2

J'ai déjà ajouté cette ligne, cela n'a aucun effet.
Il semblerait que le problème vienne du pilote bluetooth générique :



Déjà, t'aurais pu, dès le début, dire que ton clavier était en BlueTooth !

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Bastien Dejean
Le #22537231
Sergio a écrit :

Déjà, t'aurais pu, dès le début, dire que ton clavier était en BlueTooth !



Au temps pour moi.
Publicité
Poster une réponse
Anonyme