transformer commande en vba

Le
stephprod
bonjour

comment transformer cette commande excel en vba?


=SI(DO="X";adr_X;SI(DO="Y";adresse_Y;SI(DO="A";adr_A;SI(DO="Ag";agence_ag;SI(DO="C";RECHERCHEV(I78;Feuil1!A1:D25;2);SI(DO="R";RECHERCHEV(I78;Feuil1!A50:D95;2);""))))))

l'enregistreur de macro ne marche pas.

merci

cordialement

stefane
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #5225841
Salut,

Cela te conviendrait-il ?
=IF(DO=""X"",adr_X,IF(DO=""Y"",adresse_Y,IF(DO=""A"",adr_A,IF(DO=" "Ag"",agence_ag,IF(DO=""C"",VLOOKUP(R[50]C[5],Feuil1!
R[-27]C[-3]:R[-3]C,2),IF(DO=""R"",VLOOKUP(R[50]C[5],Feuil1!
R[22]C[-3]:R[67]C,2),""""))))))

Cordialement,

F.

On 18 mar, 12:18, "stephprod"
bonjour

comment transformer cette commande excel en vba?

=SI(DO="X";adr_X;SI(DO="Y";adresse_Y;SI(DO="A";adr_A;SI(DO="Ag"; agence_ag;S­I(DO="C";RECHERCHEV(I78;Feuil1!A1:D25;2);SI(DO="R";RECHERC HEV(I78;Feuil1!A5­0:D95;2);""))))))

l'enregistreur de macro ne marche pas....

merci

cordialement

stefane


Publicité
Poster une réponse
Anonyme