tri croissant plaques immatriculation

Le
VASNIER
bonjour à toutes et à toutes,

voici mon problème (je suis excel 2003) je voudrais trier dans l'ordre
croissant une liste de numéro d'immatriculation :

1478VV83
456AB75
4782GG83
5894VV13
675VP83
125ABC12
456GG75

j'ai utilisé la formule =GAUCHE(A16;NBCAR(A16)-4) pour extraire les chiffres
de la cellule, mais le problème est le suivant lorsqu'il y a trois chiffres
et trois lettres cela donne le résultat suivant :

1478
456
4782
5894
675
125A
456

auriez-vous une solution ?

merci à vous et bonne journéé

--
Pascale
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #6760151
Bonjour.
Pour décomposer tes numéros, en supposant les numéros en A :
en B : =SI(CODE(STXT(A1;4;1))<64;GAUCHE(A1;4);GAUCHE(A1;3))
en C : =STXT(A1;NBCAR(B1)+1;NBCAR(A1)-NBCAR(B1)-2)
en D : =DROITE(A1;2)
Cordialement.
Daniel
"VASNIER"
bonjour à toutes et à toutes,

voici mon problème (je suis excel 2003) je voudrais trier dans l'ordre
croissant une liste de numéro d'immatriculation :

1478VV83
456AB75
4782GG83
5894VV13
675VP83
125ABC12
456GG75

j'ai utilisé la formule =GAUCHE(A16;NBCAR(A16)-4) pour extraire les
chiffres
de la cellule, mais le problème est le suivant lorsqu'il y a trois
chiffres
et trois lettres cela donne le résultat suivant :

1478
456
4782
5894
675
125A
456

auriez-vous une solution ?

merci à vous et bonne journéé

--
Pascale


VASNIER
Le #6760711
merci beaucoup cela fonctionne génial
--
Pascale



Bonjour.
Pour décomposer tes numéros, en supposant les numéros en A :
en B : =SI(CODE(STXT(A1;4;1))<64;GAUCHE(A1;4);GAUCHE(A1;3))
en C : =STXT(A1;NBCAR(B1)+1;NBCAR(A1)-NBCAR(B1)-2)
en D : =DROITE(A1;2)
Cordialement.
Daniel
"VASNIER"
bonjour à toutes et à toutes,

voici mon problème (je suis excel 2003) je voudrais trier dans l'ordre
croissant une liste de numéro d'immatriculation :

1478VV83
456AB75
4782GG83
5894VV13
675VP83
125ABC12
456GG75

j'ai utilisé la formule =GAUCHE(A16;NBCAR(A16)-4) pour extraire les
chiffres
de la cellule, mais le problème est le suivant lorsqu'il y a trois
chiffres
et trois lettres cela donne le résultat suivant :

1478
456
4782
5894
675
125A
456

auriez-vous une solution ?

merci à vous et bonne journéé

--
Pascale







Publicité
Poster une réponse
Anonyme