Trousseau HS ?

Le
Herve
Bonjour,

Pour l'un des utilisateurs sur ma machine (en 10.4.11), à chaque
lancement de Mail qui suit l'ouverture de session, j'ai une fenêtre
qui s'affiche disant "Veuillez saisir le mot de passe de votre
trousseau. Mail souhaite utiliser le trousseau "session"."
Je rentre le mot de passe du compte, Mail fait sa relève, tout va
bien. Mais au prochain lancement rebelote. Alors que pour l'autre
utilisateur pas de problème, Mail fait son boulot tout seul.
Je suis allé voir le Trousseau de cet utilisateur à problème : il y
avait deux trousseaux "session", un vide, et l'autre avec les mots de
passe. J'ai supprimé le trousseau vide, en choisissant de ne supprimer
que les références aux fichiers par précaution.
Je redémarre, maintenant Mail ne me demande plus le mot de passe du
trousseau, mais le mot de passe de chaque compte de messagerie. Et
même si je lui demande de "conserver les mots de passe dans Trousseau
d'accès", il me les redemande à chaque lancement.
Nouveau coup d'oeil au contenu de Trousseau d'accès : il n'y a
maintenant qu'un seul trousseau "session", mais il est vide,
verrouillé, et indéverrouillable (menu grisé). De plus, il y a deux
trousseaux "Système", identiques.
Comment remettre ça d'aplomb ?
Merci d'avance,
Hervé
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michael.le_barbier
Le #3090631
Herve
Bonjour,

Pour l'un des utilisateurs sur ma machine (en 10.4.11), à chaque
lancement de Mail qui suit l'ouverture de session, j'ai une fenêtre
qui s'affiche disant "Veuillez saisir le mot de passe de votre
trousseau. Mail souhaite utiliser le trousseau "session"."
Je rentre le mot de passe du compte, Mail fait sa relève, tout va
bien. Mais au prochain lancement rebelote. Alors que pour l'autre
utilisateur pas de problème, Mail fait son boulot tout seul.
Je suis allé voir le Trousseau de cet utilisateur à problème : il y
avait deux trousseaux "session", un vide, et l'autre avec les mots de
passe. J'ai supprimé le trousseau vide, en choisissant de ne supprimer
que les références aux fichiers par précaution.
Je redémarre, maintenant Mail ne me demande plus le mot de passe du
trousseau, mais le mot de passe de chaque compte de messagerie. Et
même si je lui demande de "conserver les mots de passe dans Trousseau
d'accès", il me les redemande à chaque lancement.
Nouveau coup d'oeil au contenu de Trousseau d'accès : il n'y a
maintenant qu'un seul trousseau "session", mais il est vide,
verrouillé, et indéverrouillable (menu grisé). De plus, il y a deux
trousseaux "Système", identiques.
Comment remettre ça d'aplomb ?


J'ai le même problème des deux trousseaux ``système'', et de façon
générale les procédures de manipulation du trousseau sont un peu
déboussolantes! Je n'ai malheureusement pas de solution pour ce problèm e.
--
Michaël

jperrocheau
Le #3090561
Herve
Pour l'un des utilisateurs sur ma machine (en 10.4.11), à chaque lancement
de Mail qui suit l'ouverture de session, j'ai une fenêtre qui s'affiche
disant "Veuillez saisir le mot de passe de votre trousseau. Mail souhaite
utiliser le trousseau "session"."


Le trousseau de login était verrouillé au moment où il a été invoqué.

Je rentre le mot de passe du compte, Mail fait sa relève, tout va bien.
Mais au prochain lancement rebelote.


Quelles sont les préférences de ce trousseau de login ?

Peut-être aussi faire une revue des préférences générales...

Alors que pour l'autre utilisateur pas de problème, Mail fait son boulot
tout seul.


OK.

Je suis allé voir le Trousseau de cet utilisateur à problème : il y avait
deux trousseaux "session", un vide, et l'autre avec les mots de passe.


Manipulations des préférences de manière incohérente ?

J'ai supprimé le trousseau vide, en choisissant de ne supprimer que les
références aux fichiers par précaution.


??

Je redémarre, maintenant Mail ne me demande plus le mot de passe du
trousseau, mais le mot de passe de chaque compte de messagerie.


Celui que tu n'as pas supprimé était peut-être toujours le trousseau
"associé" mais il est peut-être endommagé ?


Et même si je lui demande de "conserver les mots de passe dans Trousseau
d'accès", il me les redemande à chaque lancement.


Essayer un check avec "Keychain First Aid" "S.O.S Trousseau"

Nouveau coup d'oeil au contenu de Trousseau d'accès : il n'y a maintenant
qu'un seul trousseau "session", mais il est vide, verrouillé, et
indéverrouillable (menu grisé).


Vérifier les privilèges du fichier "~/Library/Keychains/login.keychain"

-rw-r--r-- 1 moi moi 179K Jan 25 23:09 login.keychain

De plus, il y a deux trousseaux "Système", identiques.


???

C'est à dire ?

Comment remettre ça d'aplomb ?


Si "Keychain First Aid" ne peut remettre d'aplomb, vérifier ce qu'il y a
dans "/Library/Keychains"


--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:

Herve
Le #3090551
On 27 jan, 18:20, (Jacques Perrocheau)
wrote:
Quelles sont les préférences de ce trousseau de login ?


Qu'appelles tu "trousseau _de login_" ?
Si tu parles des préfs de l'appli Trousseau d'accès chez user2, elles
sont réglées ainsi :
- onglet Général : rien n'est coché,
- onglet SOS : tout est coché,
- onglet Certificats : les deux premiers menus déroulants sont sur
désactivé(e)

Je suis allé voir le Trousseau de cet utilisateur à problème : il y avait
deux trousseaux "session", un vide, et l'autre avec les mots de passe.


Manipulations des préférences de manière incohérente ?


Ou mauvaise installation (j'ai récemment fait une clean install suivie
d'une migration des bibliothèques à la main). J'ai peut-être loupé l a
manip pour l'un des utilisateurs.

J'ai supprimé le trousseau vide, en choisissant de ne supprimer que le s
références aux fichiers par précaution.


??


Quand j'ai voulu supprimer l'un des deux trousseaux "session", j'ai eu
un message me demandant en gros si je voulais supprimer seulement la
référence aux fichiers (je ne sais plus lesquels), ou la référence +
les fichiers.

Essayer un check avec "Keychain First Aid" "S.O.S Trousseau"


OK, je vais voir de ce côté.
Sinon quid d'une réinitialisation du trousseau telle que permise dans
les préférences, onglet Général ?

Vérifier les privilèges du fichier "~/Library/Keychains/login.keychain "

-rw-r--r--    1 moi  moi    179K Jan 25 23:09 login.keychain


Correctes.

De plus, il y a deux trousseaux "Système", identiques.


???


Dans la case "Trousseaux" de la fenêtre de Trousseau d'accès, j'ai
deux trousseaux dénommés Système. Que je sélectionne l'un ou l'autre ,
le contenu est identique (Apple Airport et Dashboard Advisory).

Si "Keychain First Aid" ne peut remettre d'aplomb, vérifier ce qu'il y a
dans "/Library/Keychains"


Ça :
-rw-r--r-- 1 root admin 25916 Jan 6 08:57 /Library/Keychains/
System.keychain

Hervé


Herve
Le #3090531
On 27 jan, 18:38, Herve
Essayer un check avec "Keychain First Aid" "S.O.S Trousseau"


OK, je vais voir de ce côté.


Bon j'ai testé, il m'a trouvé deux problèmes dont un explique que ça
ne marchait pas : il cherchait un trousseau login sur la deuxième
partition de mon disque, qui était mon ancienne partition de démarrage
(effacée depuis) avant clean install d'un nouveau système sur la
partition de démarrage actuelle.
Après l'opération de réparation, je n'ai plus de trousseau login,
normal ?
Par contre j'ai toujours mes deux trousseaux Système. Quand je mets la
souris dessus, la bulle d'aide qui s'affiche me dit qu'ils
correspondent tous les deux à /Library/Keychains/System.keychain.

Hervé


Herve
Le #3090521
On 27 jan, 18:57, Herve
Après l'opération de réparation, je n'ai plus de trousseau login,
normal ?


Non ça ne doit pas être normal, car Mail me réclame les mdp des
comptes de messagerie à chaque lancement, même si je coche la case
"Conserver ce mdp dans mon trousseau".

Je précise que j'ai effectué la réparation en utilisant "S.O.S.
Trousseau" dans le menu principal de Trousseau d'accès. C'est la même
chose qu'un logiciel appelé Keychain First Aid trouvé sur
VersionTracker ?

Hervé

jperrocheau
Le #3004891
Herve
Qu'appelles tu "trousseau _de login_" ?


trousseau de session, celui qui se trouve ici:
"~/Library/Keychains/login.keychain"

Si tu parles des préfs de l'appli Trousseau d'accès chez user2, elles
sont réglées ainsi :
- onglet Général : rien n'est coché,


Afficher l'état dans la barre des menus n'est pas inutile...

- onglet SOS : tout est coché,


OK

- onglet Certificats : les deux premiers menus déroulants sont sur
désactivé(e)


Pas d'incidence sur le pb.


Manipulations des préférences de manière incohérente ?


Ou mauvaise installation (j'ai récemment fait une clean install suivie
d'une migration des bibliothèques à la main). J'ai peut-être loupé la
manip pour l'un des utilisateurs.


Sans doute... Il faut faire attention dans ce genre de manip que le
Trousseau ne continue pas à gérer l'ancien trousseau de login s'il se
trouve encore sur un volume monté.

J'ai supprimé le trousseau vide, en choisissant de ne supprimer que les
références aux fichiers par précaution.


??


Quand j'ai voulu supprimer l'un des deux trousseaux "session", j'ai eu
un message me demandant en gros si je voulais supprimer seulement la
référence aux fichiers (je ne sais plus lesquels), ou la référence +
les fichiers.


OK. Mais tu as du simplement désactiver le "bon" trousseau de login qui
n'était plus dans l'endroit "idoine", puisque tu récupères un trousseau
de login vide et grisé (désactivé).


Essayer un check avec "Keychain First Aid" "S.O.S Trousseau"


OK, je vais voir de ce côté.
Sinon quid d'une réinitialisation du trousseau telle que permise dans
les préférences, onglet Général ?


Oui, bien sur en dernier ressort.

De plus, il y a deux trousseaux "Système", identiques.


???


Dans la case "Trousseaux" de la fenêtre de Trousseau d'accès, j'ai
deux trousseaux dénommés Système. Que je sélectionne l'un ou l'autre,
le contenu est identique (Apple Airport et Dashboard Advisory).

Si "Keychain First Aid" ne peut remettre d'aplomb, vérifier ce qu'il y a
dans "/Library/Keychains"


Ça :
-rw-r--r-- 1 root admin 25916 Jan 6 08:57 /Library/Keychains/
System.keychain


Visiblement, c'est l'effet de ton clonage avec oublie d'aller regarder
dans le menu "Edition" -> "Liste des trousseaux" pour mettre cela au
propre.

--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:



jperrocheau
Le #3004901
Herve
Bon j'ai testé, il m'a trouvé deux problèmes dont un explique que ça
ne marchait pas : il cherchait un trousseau login sur la deuxième
partition de mon disque, qui était mon ancienne partition de démarrage
(effacée depuis) avant clean install d'un nouveau système sur la
partition de démarrage actuelle.
Après l'opération de réparation, je n'ai plus de trousseau login,
normal ?


Normal.

Par contre j'ai toujours mes deux trousseaux Système. Quand je mets la
souris dessus, la bulle d'aide qui s'affiche me dit qu'ils
correspondent tous les deux à /Library/Keychains/System.keychain.


Voir le menu "Edition" -> "Liste des trousseaux" pour mettre cela au
propre.

--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:

jperrocheau
Le #3004881
Herve
Non ça ne doit pas être normal, car Mail me réclame les mdp des
comptes de messagerie à chaque lancement, même si je coche la case
"Conserver ce mdp dans mon trousseau".


Il faut peut-être alors recréer le trousseau de login avec le bouton
idoine dans le premier onglet des préférences générales.

Je précise que j'ai effectué la réparation en utilisant "S.O.S.
Trousseau" dans le menu principal de Trousseau d'accès. C'est la même
chose qu'un logiciel appelé Keychain First Aid trouvé sur
VersionTracker ?


C'est l'ancienne version pour Mac OS X 10.2 quand le Trousseau n'avait
pas cet utilitaire incorporé


--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:

Herve
Le #3004501
On 28 jan, 01:15, (Jacques Perrocheau)
wrote:
Par contre j'ai toujours mes deux trousseaux Système.


Voir le menu "Edition" -> "Liste des trousseaux" pour mettre cela au
propre.


Liste des trousseaux n'en voit qu'un, alors qu'il y en a deux dans la
partie supérieure gauche de la fenêtre principale.

Hervé


jperrocheau
Le #3002041
Herve
Voir le menu "Edition" -> "Liste des trousseaux" pour mettre cela au
propre.


Liste des trousseaux n'en voit qu'un, alors qu'il y en a deux dans la
partie supérieure gauche de la fenêtre principale.


???

Je sèche, je n'ai jamais vu cela.

--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:


Publicité
Poster une réponse
Anonyme