Ubuntu sur EEEPC : bien, sauf eth qui ne se réveille pas

Le
Vincent Verdon
Bonjour à tous,

d'abord un petit témoignage : je viens d'acquérir un EEEPC 1005HA-H.
Evidemment, je n'ai pas tardé à installer Linux dessus. J'aurais bien
mis une Debian, mais après quelques lectures j'ai compris que ma machine
était trop neuve : noyau un peu ancien qui ne prend pas en compte
certain matériel de l'EEEPC (éthernet surtout).
J'ai donc opté pour la prochaine Ubuntu (Karmic) qui contient le noyau
correct. Pour une pré-version, cela fonctionne rudement bien !!! Tout
est reconnu, en dehors de quelques touches particulières de mon clavier
(celle qui permet de couper l'écran par exemple).
Je suis impressionné de la réactivité de cette petite machine (j'utilise
habituellement un AMD Athlon64 "vieux" de 4 ans) : elle est aussi rapide
que mon Athlon pour les applications courantes.
L'autonomie est vraiment bonne également.

J'ai juste un soucis concernant le passage en mode veille du processeur
: quand j'appuie sur la touche de veille du proc, la machine tombe bien
en létargie comme prévu. Je la réveille sans pb, SAUF l'éthernet qui lui
ne se réveille pas ! Cela reste un peu gênant.
Je vérifie par lsmod que le module est toujours chargé, c'est bien le
cas. Je tente de redémarrer à la main l'eth par un ifup eth0. On me
répond que eth0 n'existe pas.

Peut-être dois-je montrer patient et attendre une version stable de mon
Ubuntu qui résoudra le pb ?

Si quelqu'un a une idée, je suis preneur.

Amicalement, Vincent Verdon
Vidéos High-Tech et Jeu Vidéo
Téléchargements
  • Ubuntu Sudio est une distribution Linux orientée multimédia.
  • Ubuntu est une distribution Linux libre et gratuite basée sur Debian.
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Cumbalero
Le #19980691
Vincent Verdon a écrit :

Je vérifie par lsmod que le module est toujours chargé, c'est bien le
cas. Je tente de redémarrer à la main l'eth par un ifup eth0. On me
répond que eth0 n'existe pas.



Que donne un ifconfig -a?

Il y a de grandes chances pour que ce ne soit pas à eth0 que l'adresse
IP soit attribuée mais à une interface type bond0.

Sinon un dhclient ne corrige pas le problème?

A+
JF
Doug713705
Le #19980681
Le Mon, 24 Aug 2009 15:20:12 +0200, Vincent Verdon a gâché de la bande
passante pour nous écrire :

je viens d'acquérir un EEEPC 1005HA-H.



Un petit lspci serait apprécié ;-) et permettrait d'identifier avec
précision les composants de ton matériel.

merci.

--
@+
Doug - Linux user #307925 - Slamd64 roulaize ;-)
[ Plus ou moins avec une chance de peut-être ]
Vincent Verdon
Le #19981831
Bonjour,

Cumbalero a écrit :
Vincent Verdon a écrit :

Je vérifie par lsmod que le module est toujours chargé, c'est bien le
cas. Je tente de redémarrer à la main l'eth par un ifup eth0. On me
répond que eth0 n'existe pas.



Que donne un ifconfig -a?

Il y a de grandes chances pour que ce ne soit pas à eth0 que l'adresse
IP soit attribuée mais à une interface type bond0.



Non non, ifconfig montre bien l'existence de l'interface eth0 avant mise
en veille, puis plus de eth0 après (seule lo subsiste)


Sinon un dhclient ne corrige pas le problème?



Je suis en dhcp. La question n'est pas là, c'est l'existence de
l'ethernet qui est en cause !


A+
JF


Merci de ta réponse.
Amicalement, Vincent Verdon
Vincent Verdon
Le #19981821
Bonjour,

Doug713705 a écrit :
Le Mon, 24 Aug 2009 15:20:12 +0200, Vincent Verdon a gâché de la bande
passante pour nous écrire :

je viens d'acquérir un EEEPC 1005HA-H.



Un petit lspci serait apprécié ;-) et permettrait d'identifier avec
précision les composants de ton matériel.



Il s'agit d'un controleur éthernet Atheros AR8132 qui utilise le module
atl1c.


merci.




Merci de ton aide,
amicalement, Vincent Verdon
Nicolas George
Le #19981921
Vincent Verdon wrote in message
Il s'agit d'un controleur éthernet Atheros AR8132 qui utilise le module
atl1c.



Apparaît-il encore dans la sortie de lspci après retour de veille ?
Sergio
Le #19982091
Vincent Verdon a écrit :

Sinon un dhclient ne corrige pas le problème?

Je suis en dhcp. La question n'est pas là, c'est l'existence de
l'ethernet qui est en cause !



Simplement la mise en veille d'Ubuntu qui est m***que à souhait : Chez moi (Jaunty), la sortie de mise en veille coupe l'ethernet.
Il faut, soit cliquer sur l'icône réseau et relancer le bouzin, soit faire un dhclient. Mais bon, pas ton cas.

Néanmoins retiens cet adage :
*LA MISE EN VEILLE SOUS LINUX EST UNE COCHONNERIE SANS NOM*

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Vincent Verdon
Le #19983051
Bonsoir,

Nicolas George a écrit :
Vincent Verdon wrote in message
Il s'agit d'un controleur éthernet Atheros AR8132 qui utilise le module
atl1c.



Apparaît-il encore dans la sortie de lspci après retour de veille ?


et oui, et le module est toujours chargé !

Amicalement, Vincent Verdon
Doug713705
Le #19983431
Le Mon, 24 Aug 2009 18:44:20 +0200, Sergio a gâché de la bande passante
pour nous écrire :

Néanmoins retiens cet adage :
*LA MISE EN VEILLE SOUS LINUX EST UNE COCHONNERIE SANS NOM*



Pas du tout, ça fonctionne parfaitement, notamment sur mon eeePC 1000H.


--
@+
Doug - Linux user #307925 - Slamd64 roulaize ;-)
[ Plus ou moins avec une chance de peut-être ]
Doug713705
Le #19983551
Le Mon, 24 Aug 2009 17:53:51 +0200, Vincent Verdon a gâché de la bande
passante pour nous écrire :

Un petit lspci serait apprécié ;-) et permettrait d'identifier avec
précision les composants de ton matériel.



Il s'agit d'un controleur éthernet Atheros AR8132 qui utilise le module
atl1c.



J'aurais néanmoins apprécié un lspci histoire de comparer avec mon
propre eeePC 1000H (tout court)

un cat /proc/cpuinfo aussi ;-)

Merci d'avance.
--
@+
Doug - Linux user #307925 - Slamd64 roulaize ;-)
[ Plus ou moins avec une chance de peut-être ]
Nicolas George
Le #19983681
Vincent Verdon wrote in message
et oui, et le module est toujours chargé !



Dans ce cas, essaie de décharger le module puis de le recharger. Voire de
décharger le module avant la mise en veille pour le recharger après le
réveil.
Publicité
Poster une réponse
Anonyme