Upgrade Etch/Lenny

Le
Bernard
Messieurs bonsoir,
Suite à l'utilisation de la commande apt-get -u dist-upgrade, je me retro=
uve
avec la liste des erreurs suivantes :
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mi=
s à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utili=
sés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets Fait
Lecture de l'état des paquets Fait
Récupération des rapports de bogue Fait
Analyse des informations Trouvé/Corrigé 65%dpkg : mauvaise syntaxe=
de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la ver=
sion n'est pas
un nombre
Analyse des informations Trouvé/Corrigé Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->=

1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't sh=
ow
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarde=
d>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug=

printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé=
 :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <do=
ne>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable=

release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.=
5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé=
 :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating=

list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.=
25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pendin=
g>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstr=
eam
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pendin=
g>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pen=
ding>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pen=
ding>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pendi=
ng>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.1=
0-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)=

<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alteratio=
ns
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12=
)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 b=
ogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),=

cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),=

texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-des=
sus ?
[Y/n/?/]
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mi=
s à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utili=
sés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets Fait
Lecture de l'état des paquets Fait
Récupération des rapports de bogue Fait
Analyse des informations Trouvé/Corrigé 65%dpkg : mauvaise syntaxe=
de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la ver=
sion n'est pas
un nombre
Analyse des informations Trouvé/Corrigé Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->=

1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't sh=
ow
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarde=
d>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug=

printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé=
 :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <do=
ne>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable=

release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.=
5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé=
 :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating=

list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.=
25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pendin=
g>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstr=
eam
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pendin=
g>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pen=
ding>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pen=
ding>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pendi=
ng>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.1=
0-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)=

<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alteratio=
ns
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12=
)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 b=
ogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),=

cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),=

texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-des=
sus ?
[Y/n/?/]

Mon sources.list sans fichier preferences :
# lenny
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free
# security
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

Si je lance la mise à jour, il m'affiche tout un tas de warning concernan=
t
perl apparemment, et je me retrouve avec une distro cassée !
J'ai essayé le fichier sources.list et le fichier préférences
Lenny>Etch>Sid>Experimental du forum :
http://forum.debian-fr.org/viewtopic.php?f=8&t=5659 mais sans succés.
J'avoue être trés découragé sur ce coup.
C'est ou que ça colle pas ?
Souhaitant être en version testing/Lenny comment je fais ?
Merci de vos réponses suremment pertinentes.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
antoine
Le #18337021
Le jeudi 8 janvier 2009 19:15, Bernard a écrit :
Messieurs bonsoir,
Suite à l'utilisation de la commande apt-get -u dist-upgrade, je me ret rouve
avec la liste des erreurs suivantes :
J'avoue être trés découragé sur ce coup.
C'est ou que ça colle pas ?
Souhaitant être en version testing/Lenny comment je fais ?
Merci de vos réponses suremment pertinentes.


----------------

Désolé, je ne peux t'aider mais je compatis.

Je remarque que les Upgrade ne fonctionnent pas toujours
et pire, ils cassent la version avant upgrade !

Je voulais le faire et j'ai bien fait, étant encore sous Etch.

J'ai eu le même déboire lorsque j'ai voulu upgrader de Sarge
vers Etch.
Du coup, j'ai dû tout réinstaller directement avec un DVD etch.
(mais quel boulot pour tout configurer : son, vidéo, compte emails ... et c ... !!)

As tu fait une sauvegarde de ta précédente version ?

J'aimerai connaître le moyen pour faire un upgrade sans trop de déboire s.

antoine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
jipe
Le #18337741
Bernard a écrit :
Messieurs bonsoir,
Suite à l'utilisation de la commande apt-get -u dist-upgrade, je me retrouve
avec la liste des erreurs suivantes :
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... 65%dpkg : mauvaise syntaxe de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la version n'est pas
un nombre
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->
1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't show
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarded>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug
printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <done>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable
release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating
list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pending>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstream
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pending>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pending>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pending>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pending>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.10-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)
<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alterations
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 bogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),
cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),
texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...]
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... 65%dpkg : mauvaise syntaxe de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la version n'est pas
un nombre
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->
1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't show
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarded>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug
printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <done>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable
release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating
list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pending>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstream
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pending>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pending>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pending>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pending>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.10-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)
<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alterations
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 bogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),
cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),
texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...]

Mon sources.list sans fichier preferences :
# lenny
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free
# security
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

Si je lance la mise à jour, il m'affiche tout un tas de warning concernant
perl apparemment, et je me retrouve avec une distro cassée !
J'ai essayé le fichier sources.list et le fichier préférences
Lenny>Etch>Sid>Experimental du forum :
http://forum.debian-fr.org/viewtopic.php?f=8&tV59 mais sans succés.
J'avoue être trés découragé sur ce coup.
C'est ou que ça colle pas ?
Souhaitant être en version testing/Lenny comment je fais ?
Merci de vos réponses suremment pertinentes.




bonsoir, moi je suis passé de etch à lenny en mettant "lenny" à la place
de "testing" dans le sources.list
et en multipliant les "aptitude update suivi de "aptitude safe-upgrade".
(aptitude gère mieux les dépendances que apt), et de la patience :-)
et bien lire les infos données, certaine fois je m'en suis sorti avec
des "dpkg reconfigure"
maintenant tout est ok depuis 2 mois.
courage

--
jipe
Linux 2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686
Description: Ubuntu 8.04.1 Codename: hardy
http://pascaudjipe.free.fr/dotclear/index.php?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #18338511
> Mon sources.list sans fichier preferences :
# lenny
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free
# security
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-fr ee

Si je lance la mise à jour, il m'affiche tout un tas de warning conce rnant
perl apparemment, et je me retrouve avec une distro cassée !
J'ai essayé le fichier sources.list et le fichier préférences
Lenny>Etch>Sid>Experimental du forum :
http://forum.debian-fr.org/viewtopic.php?f=8&tV59 mais sans succé s.
J'avoue être trés découragé sur ce coup.
C'est ou que ça colle pas ?
Souhaitant être en version testing/Lenny comment je fais ?
Merci de vos réponses suremment pertinentes.




Avant de faire l'upgrade être sûr d'avoir un etch correct avec toutes
les mises à jour
faites. J'ai l'impression qu'il y a encore des références à sarge ! !!

Donc remplacer les "testing" par "etch" dans sources.list et faire un
aptitude update;
aptitude dist-upgrade.

Vérifier que tous les paquets sont bien mis à jour (qu'il n'ya pas de
paquets bloqués ...)

Ensuite remplacer "etch" par "lenny" dans sources.list et faire :
aptitude update
aptitude install aptitude
aptitude dist-upgrade

J'ai déjà fait 3 ou 4 upgrades sans trop de problèmes avec cette mé thode.
L'essentiel des soucis que j'ai rencontré gravitent autour du xorg.conf


--
Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
antoine
Le #18338711
> J'ai déjà fait 3 ou 4 upgrades sans trop de problèmes avec cette m éthode.
L'essentiel des soucis que j'ai rencontré gravitent autour du xorg.conf


-------------

Merci de ces bons conseils et précisions.

Quel soucis as tu eu avec "xorg.conf" ? :
Il n'y avait plus de mode graphique ?
Comment les as tu résolus ?

car je compte faire un upgrade et avant je m'informe,
je suis vacciné d'échecs ... :-)

antoine

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Stephane Bortzmeyer
Le #18338871
On Thu, Jan 08, 2009 at 07:56:23PM +0100,
a message of 39 lines which said:

Je remarque que les Upgrade ne fonctionnent pas toujours et pire,
ils cassent la version avant upgrade !



Jamais eu de problème similaire mais, de toute façon, lenny n'est pas
sortie encore. C'est une version de test. Donc, mettez à jour si vous
voulez mais soyez prévenu !

J'aimerai connaître le moyen pour faire un upgrade sans trop de
déboires.



0) SAUVEGARDES SAUVEGARDES SAUVEGARDES AI-JE DIT QU'IL FALLAIT FAIRE
DES SAUVEGARDES ?
1) Éditer /etc/apt/sources.list
2) aptitude update
3) aptitude install aptitude (car la mise à jour doit se faire avec un
aptitude récent)
4) aptitude dist-upgrade (en quatrième surtout pas en premier)

Et j'en ai mis des machines à jour comme ça.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #18339891
Bonsoir,
Pourquoi cette ligne :

aptitude install aptitude ?


Pour utiliser la version lenny de aptitude à la ligne suivante ...
(dist-upgrade)

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guy Roussin
Le #18340071
a écrit :
J'ai déjà fait 3 ou 4 upgrades sans trop de problèmes avec cette méthode.
L'essentiel des soucis que j'ai rencontré gravitent autour du xorg.c onf



-------------

Merci de ces bons conseils et précisions.

Quel soucis as tu eu avec "xorg.conf" ? :



Un probleme avec la souris, j'ai remis les paramètres de la version etc h
du xorg.conf
de la section InputDevice correspondante.
Un probleme avec openchrome qui est maintenant pris en charge par lenny e t
que je m'évertuais à recompiler alors qu'il suffisait d'indiquer driv er
"openchrome"
Donc pas de graphique et petit passage en console ...

La mise à jour peut te prendre 1 heure dans le meilleur des cas.
Je constate que la présence de logiciels "proprio" (drivers, ...) ou
compilés à la main rendent plus difficile la mise à jour.

Et puis pas d'inquiétude ... on est là ;-)

Depuis le temps que je fais des install et des mises à jours avec debia n
je n'ai jamais eu besoin de réinstaller (sauf lors de pannes disques) :
merci la liste :-)

Guy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Cornichon
Le #18340241
Bernard a écrit :
Messieurs bonsoir,
Suite à l'utilisation de la commande apt-get -u dist-upgrade, je me retrouve
avec la liste des erreurs suivantes :
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... 65%dpkg : mauvaise syntaxe de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la version n'est pas
un nombre
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->
1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't show
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarded>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug
printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <done>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable
release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating
list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pending>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstream
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pending>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pending>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pending>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pending>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.10-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)
<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alterations
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 bogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),
cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),
texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...]
1030 mis à jour, 306 nouvellement installés, 15 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/1073Mo dans les archives.
Après dépaquetage, 743Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Lecture des champs des paquets... Fait
Lecture de l'état des paquets... Fait
Récupération des rapports de bogue... Fait
Analyse des informations Trouvé/Corrigé... 65%dpkg : mauvaise syntaxe de la
version « 2007-10-01T00:00:00Z » : l'époque (epoch) dans la version n'est pas
un nombre
Analyse des informations Trouvé/Corrigé... Fait
Bogues de gravité grave sur openoffice.org-writer (2.0.4.dfsg.2-7etch6 ->
1:2.4.1-15) <forwarded>
#507865 - openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't show
text (2.x implements standard wrong)
Bogues de gravité grave sur nautilus (2.14.3-11+b1 -> 2.20.0-7) <forwarded>
#510564 - nautilus: smb file deletion gvfs
Bogues de gravité grave sur procps (1:3.2.7-3 -> 1:3.2.7-9) <done>
#511082 - procps: sysctl "Display all values" function contain bogus debug
printf() (Corrigé : procps/1:3.2.7-9.1)
Bogues de gravité grave sur texlive-common (-> 2007.dfsg.1-4) <done>
#429753 - texlive-commong post-install action fails, blocking tex/latex
install (Corrigé : 2007-10-01T00:00:00Z)
Bogues de gravité grave sur python2.5 (-> 2.5.2-14) <done>
#509697 - python2.5 misses dependency on binutils (Corrigé : 2.5.2-15)
Réuni avec : 509821
Bogues de gravité grave sur libpam-modules (0.79-5 -> 1.0.1-4) <done>
#502140 - cannot unlock screen during etch -> lenny transition (Corrigé :
pam/1.0.1-5)
Bogues de gravité grave sur initramfs-tools (0.85i -> 0.92n) <done>
#511085 - 60 seconds timeout for ipconfig is not enough (Corrigé :
initramfs-tools/0.92o)
Bogues de gravité serious sur epiphany-browser (2.14.3-8 -> 2.22.3-8) <done>
#510764 - epiphany-webkit: Epiphany should not provide webkit in a stable
release (Corrigé : epiphany-browser/2.22.3-9)
Bogues de gravité serious sur hal (0.5.8.1-9etch1 -> 0.5.11-6) <done>
#510639 - hal.conf.in needs augmenting for new D-Bus (Corrigé : hal/0.5.11-7)
Bogues de gravité serious sur ghostscript (-> 8.62.dfsg.1-3.1) <done>
#503712 - etch->lenny upgrade left the system in broken state (Corrigé :
ghostscript/8.62.dfsg.1-3.2 ghostscript/8.63.dfsg.1-1
ghostscript/8.62.dfsg.1-3.2lenny0)
Bogues de gravité serious sur policycoreutils (1.32-3 -> 2.0.49-6) <done>
#506727 - policycoreutils: fail with error: list index out of range
(Corrigé : policycoreutils/2.0.49-8)
Bogues de gravité serious sur libsemanage1 (1.8-1 -> 2.0.25-2) <done>
#510134 - genhomedircon.c: login.defs:MAX_UID have no effect on generating
list of valid users, but MIN_UID does have. (Corrigé : libsemanage/2.0.25-3)
Bogues de gravité critical sur libaudiofile0 (0.2.6-6 -> 0.2.6-7) <pending>
#510205 - buffer overflow in libaudiofile
Bogues de gravité critical sur iceweasel (2.0.0.18-0etch1 -> 3.0.4-1)
<pending>
#510902 - Missing security updates - version 2.0.0.20 available from upstream
Bogues de gravité grave sur xserver-xorg (1:7.1.0-19 -> 1:7.3+18) <pending>
#511216 - Xorg crash (i810 )
Bogues de gravité grave sur util-linux (2.12r-19etch1 -> 2.13.1.1-1) <pending>
#510130 - Error calculing volhdr partition boundaries on SGI disklabel
Bogues de gravité grave sur libqt3-mt (3:3.3.7-4etch2 -> 3:3.3.8b-5) <pending>
#490999 - libqt3-mt: QTime::addMSecs(int) is compiled wrongly on sparc
Bogues de gravité grave sur grub (0.97-27etch1 -> 0.97-47lenny1) <pending>
#243835 - grub-install hangs with xfs root/boot
Réuni avec : 239111 246111 309218 425367
Bogues de gravité grave sur cupsys (1.2.7-4etch6 -> 1.3.8-1lenny4) <pending>
#510857 - cupsys: cups print jobs hang since upgrade to Etch
Bogues de gravité serious sur perl (5.8.8-7etch6 -> 5.10.0-18) <pending>
#477694 - FTBFS: ext/threads/t/stress_re.t fails sporadically on sparc
Bogues de gravité serious sur xserver-xorg-video-nv (1:2.0.3-1 -> 1:2.1.10-1)
<pending>
#383465 - Contains obfuscated source code, DFSG violation?
Bogues de gravité serious sur liferea (1.0.27-2 -> 1.4.18-1+b1) <pending>
#510765 - liferea-webkit: Liferea should not provide webkit in a stable
release
Bogues de gravité serious sur portmap (5-26 -> 6.0-9) <pending>
#424957 - portmap includes non-DFSG-compliant code
Bogues de gravité serious sur python (2.4.4-2 -> 2.5.2-3) <pending>
#418462 - mailman: Fails to upgrade from Sarge to Etch
Bogues de gravité serious sur system-tools-backends (1.4.2-3 -> 2.6.0-2)
<pending>
#510744 - system-tools-backends: /etc/dbus-1/system.d file needs alterations
for fd.o #18961
Bogues de gravité serious sur texlive-base (-> 2007.dfsg.1-4) <pending>
#477060 - texlive-base: license of amslatex is unclear
Bogues de gravité serious sur libsnmp-base (5.2.3-7etch4 -> 5.4.1~dfsg-12)
<pending>
#498475 - libsnmp-base ships MIB files licensed under a restrictive license
Résumé :
xserver-xorg(1 bogue), util-linux(1 bogue), procps(1 bogue),
texlive-common(1 bogue), python2.5(1 bogue), perl(1 bogue),
openoffice.org-writer(1 bogue), libqt3-mt(1 bogue), grub(1 bogue),
nautilus(1 bogue), libpam-modules(1 bogue), xserver-xorg-video-nv(1 bogue),
epiphany-browser(1 bogue), liferea(1 bogue), hal(1 bogue),
ghostscript(1 bogue), portmap(1 bogue), libaudiofile0(1 bogue),
python(1 bogue), iceweasel(1 bogue), system-tools-backends(1 bogue),
cupsys(1 bogue), policycoreutils(1 bogue), initramfs-tools(1 bogue),
texlive-base(1 bogue), libsnmp-base(1 bogue), libsemanage1(1 bogue)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ?
[Y/n/?/...]

Mon sources.list sans fichier preferences :
# lenny
deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ testing main contrib non-free
# security
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

Si je lance la mise à jour, il m'affiche tout un tas de warning concernant
perl apparemment, et je me retrouve avec une distro cassée !
J'ai essayé le fichier sources.list et le fichier préférences
Lenny>Etch>Sid>Experimental du forum :
http://forum.debian-fr.org/viewtopic.php?f=8&tV59 mais sans succés.
J'avoue être trés découragé sur ce coup.
C'est ou que ça colle pas ?
Souhaitant être en version testing/Lenny comment je fais ?
Merci de vos réponses suremment pertinentes.





La façon "officiel" pour passer de etch à lenny est :
- Sauvergardes (!!!)
- Modifier le sources.list et au besoin le fichier preferences
- aptitude update
- aptitude install apt aptitude dpkg
- aptitude full-upgrade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Franck Delage
Le #18341681
Salut,

Bernard a écrit :
| Souhaitant être en version testing/Lenny comment je fais ?

Personnellement j'ai fait le saut de etch à lenny/sid il y a quelques jours
en suivant à la lettre cet excellent tuto, conseillé d'ailleurs ici-même
sur cette liste :

http://ubunteros.tuxfamily.org/spip.php?article177

J'ai juste dû faire plusieurs fois aptitude dist-upgrade car les premières fois,
aptitude installait plusieurs paquets, puis s'arrêtait pour "trop d'erreurs".

J'ai donc répété la commande 4 ou 5 fois, et j'ai désormais une
magnifique Lenny/Sid.

--
Franck Delage
Création et hébergements de sites web
www.web82.net

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bernard
Le #18346611
Le Thursday 08 January 2009 22:26:14 Stephane Bortzmeyer, vous avez écrit  :
On Thu, Jan 08, 2009 at 07:56:23PM +0100,

a message of 39 lines which said:
> Je remarque que les Upgrade ne fonctionnent pas toujours et pire,
> ils cassent la version avant upgrade !

Jamais eu de problème similaire mais, de toute façon, lenny n'est pas
sortie encore. C'est une version de test. Donc, mettez à jour si vous
voulez mais soyez prévenu !

> J'aimerai connaître le moyen pour faire un upgrade sans trop de
> déboires.

0) SAUVEGARDES SAUVEGARDES SAUVEGARDES AI-JE DIT QU'IL FALLAIT FAIRE
DES SAUVEGARDES ?
1) Éditer /etc/apt/sources.list
2) aptitude update
3) aptitude install aptitude (car la mise à jour doit se faire avec un
aptitude récent)
4) aptitude dist-upgrade (en quatrième surtout pas en premier)

Et j'en ai mis des machines à jour comme ça.



Avant toutes choses, merci pour vos nombreuses réponses.
Effectivement, il faut d'abord effectuer la mise à jours de aptitude vers ion
testing. La mise à jour Etch>Lenny se passe ensuite sans problemes majeur s.
Il me reste à me documenter pour l'installation de logiciels en version
récentes en adaptant le sources.list avec un fichier preferences.
Merci encore à la liste pour le coup de main.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme