userform + ComboBox

Le
JRC
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LE TROLL
Le #17297551
Bonjour,

Le comboBox renvoie ce qu'il a, soit :

cellule = Combo1.text

Soit (mieux)

cellule = Combo1.list(combo1.listindex)

C'est ta cellule qui semble ne pas bien recevoir la donnée, sans doute
faut-il la mettre en texte ou date...

------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm






------------------------------------------------------------------------------------
"JRC"
| Bonjour bonjour,
|
| En ce si bon lundi matin, je me permets de vous poser une question
| concernant les ComboBox qui se situent dans un userform.
|
| J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
| Mon problème est que lorsque l'utilisateur choisit la date voulut, des
| chiffres apparaissent à sa place.
|
| J'ai essayé ceci
|
| date1.Value = Format(date1.Value, "dd/mm/yyyy")
|
| ça marche pas :)
|
| Merci d'avance pour votre aide et très bonne semaine à tous!
|
| Ju
Fredo P
Le #17297881
Bonjour
il faut rendre les dates au format texte en premier lieu sur un colonne
différente par ex à l'aide de la formule:=TEXTE(A1;"jj/mm/aa") puis faire un
copier-coller>Valeurs à l'endroit de la liste des valeurs liées avec le
combobox.
Il y a sans doute d'autres solutions qui ne me reviennent pas pour
l'instant.
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju


JRC
Le #17298071
Bonjour Le troll,

Merci de prendre du temps pour me répondre.

Je me suis peut être mal expliqué mais mon problème reste sur le
combobox de l'userform. C'est à dire que l'utilisateur ne voit pas la
feuille excel qui récupère les données mais lorsqu'il choisit une date
parmi la liste du combobox date1 et lorsqu'il passe au combobox suivant,
la date qui vient d'être choisit, au lieu de rester au format dd/mm/yyyy
se transforme en chiffre du type 3189745.

merci

LE TROLL a écrit :
Bonjour,

Le comboBox renvoie ce qu'il a, soit :

cellule = Combo1.text

Soit (mieux)

cellule = Combo1.list(combo1.listindex)

C'est ta cellule qui semble ne pas bien recevoir la donnée, sans doute
faut-il la mettre en texte ou date...

------
Romans, logiciels, email, site personnel
http://irolog.free.fr/joe.htm






------------------------------------------------------------------------------------
"JRC"
| Bonjour bonjour,
|
| En ce si bon lundi matin, je me permets de vous poser une question
| concernant les ComboBox qui se situent dans un userform.
|
| J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
| Mon problème est que lorsque l'utilisateur choisit la date voulut, des
| chiffres apparaissent à sa place.
|
| J'ai essayé ceci
|
| date1.Value = Format(date1.Value, "dd/mm/yyyy")
|
| ça marche pas :)
|
| Merci d'avance pour votre aide et très bonne semaine à tous!
|
| Ju




Fredo P
Le #17298061
Voila une autre sur la plage liée au combobox
=TEXTE(DATE(1948;12;15)+LIGNE();"jj/mm/aa") ' Date à adapter
ou la date du jour
=TEXTE(AUJOURDHUI()+LIGNE();"jj/mm/aa")
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju


JRC
Le #17298051
Salut Fredo,

Je reprécise mon problème :

Mon problème ne concerne pas le "transfert" des données entre le
combobox date1 de l'userform et la feuille excel mais seulement la
"valeur" indiquée par le combobox date1 à l'utilisateur qui une fois
saisie se transforme en chiffre et ne reste pas au format date.

Merci ;)

Fredo P a écrit :
Voila une autre sur la plage liée au combobox
=TEXTE(DATE(1948;12;15)+LIGNE();"jj/mm/aa") ' Date à adapter
ou la date du jour
=TEXTE(AUJOURDHUI()+LIGNE();"jj/mm/aa")
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju






Fredo P
Le #17298241
Eh oui j'ai bien compris
Seulement tes données liées au combobox sont réellement des nombres, il faut
les transformer en texte.

Je reprécise mon problème :

Mon problème ne concerne pas le "transfert" des données entre le combobox
date1 de l'userform et la feuille excel mais seulement la "valeur"
indiquée par le combobox date1 à l'utilisateur qui une fois saisie se
transforme en chiffre et ne reste pas au format date.

Merci ;)

Fredo P a écrit :
Voila une autre sur la plage liée au combobox
=TEXTE(DATE(1948;12;15)+LIGNE();"jj/mm/aa") ' Date à adapter
ou la date du jour
=TEXTE(AUJOURDHUI()+LIGNE();"jj/mm/aa")
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju







JRC
Le #17298441
Ok Fredo je voulais juste m'en assurer :)

J'ai donc essayé de mettre ta formule dans le code de la Combobox, j'ai
également essayé plusiseurs facon vace des .Value mais ça ne marche
pas, enfin tout du moins, je n'ai pas réussi à la faire fonctionner ...

Merci;)

Fredo P a écrit :
Eh oui j'ai bien compris
Seulement tes données liées au combobox sont réellement des nombres, il faut
les transformer en texte.
Je reprécise mon problème :

Mon problème ne concerne pas le "transfert" des données entre le combobox
date1 de l'userform et la feuille excel mais seulement la "valeur"
indiquée par le combobox date1 à l'utilisateur qui une fois saisie se
transforme en chiffre et ne reste pas au format date.

Merci ;)

Fredo P a écrit :
Voila une autre sur la plage liée au combobox
=TEXTE(DATE(1948;12;15)+LIGNE();"jj/mm/aa") ' Date à adapter
ou la date du jour
=TEXTE(AUJOURDHUI()+LIGNE();"jj/mm/aa")
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju









JPMonnier
Le #17298641
Bonjour,
J'ai testé :
Dans les propiétés de ta ComboBox
RowSource, tu rentres l'adresse des cellules comportant les dates à choisir
ex A1:A20,
Les dates apparaissent bien en date dans la liste de la ComboBox

--
Cordialement

"JRC" news:
Ok Fredo je voulais juste m'en assurer :)

J'ai donc essayé de mettre ta formule dans le code de la Combobox, j'ai
également essayé plusiseurs facon vace des .Value mais ça ne marche pas,
enfin tout du moins, je n'ai pas réussi à la faire fonctionner ...

Merci;)

Fredo P a écrit :
Eh oui j'ai bien compris
Seulement tes données liées au combobox sont réellement des nombres, il
faut les transformer en texte.
Je reprécise mon problème :

Mon problème ne concerne pas le "transfert" des données entre le
combobox date1 de l'userform et la feuille excel mais seulement la
"valeur" indiquée par le combobox date1 à l'utilisateur qui une fois
saisie se transforme en chiffre et ne reste pas au format date.

Merci ;)

Fredo P a écrit :
Voila une autre sur la plage liée au combobox
=TEXTE(DATE(1948;12;15)+LIGNE();"jj/mm/aa") ' Date à adapter
ou la date du jour
=TEXTE(AUJOURDHUI()+LIGNE();"jj/mm/aa")
"JRC"
Bonjour bonjour,

En ce si bon lundi matin, je me permets de vous poser une question
concernant les ComboBox qui se situent dans un userform.

J'ai donc une ComboBox qui permet à l'utilisateur de choisir une date.
Mon problème est que lorsque l'utilisateur choisit la date voulut, des
chiffres apparaissent à sa place.

J'ai essayé ceci

date1.Value = Format(date1.Value, "dd/mm/yyyy")

ça marche pas :)

Merci d'avance pour votre aide et très bonne semaine à tous!

Ju











JRC
Le #17298851
Bonjour JPMonnier,

Sur RowSource de ma comboBox date1 j'ai déjà entré 'Données!A2:A116' et
les cellules A2 à A116 sont au format date du type dd/mm/aa et
effectivement dans la liste lorsque l'userform est lancé les dates
apparaissent au format date cité.

Mais lorsqu'on passe à une ComboBox différente, ce format change
automatiquement (pas lorsque je transfère les données de l'userforme
vers la "base de donnée")

Merci merci!!

JPMonnier a écrit :
Bonjour,
J'ai testé :
Dans les propiétés de ta ComboBox
RowSource, tu rentres l'adresse des cellules comportant les dates à
choisir ex A1:A20,
Les dates apparaissent bien en date dans la liste de la ComboBox



JPMonnier
Le #17299461
J'ai testé cela aussi
Private Sub ComboBox1_Change()
ComboBox1 = Format(ComboBox1.Text, "dd/mm/yyyy")
End Sub
Il semble que cela fonctionne

--
Cordialement


"JRC" news:
Bonjour JPMonnier,

Sur RowSource de ma comboBox date1 j'ai déjà entré 'Données!A2:A116' et
les cellules A2 à A116 sont au format date du type dd/mm/aa et
effectivement dans la liste lorsque l'userform est lancé les dates
apparaissent au format date cité.

Mais lorsqu'on passe à une ComboBox différente, ce format change
automatiquement (pas lorsque je transfère les données de l'userforme vers
la "base de donnée")

Merci merci!!

JPMonnier a écrit :
Bonjour,
J'ai testé :
Dans les propiétés de ta ComboBox
RowSource, tu rentres l'adresse des cellules comportant les dates à
choisir ex A1:A20,
Les dates apparaissent bien en date dans la liste de la ComboBox





Publicité
Poster une réponse
Anonyme