Utilisation basique de kdenlive

Le
denis.paris
Bonjour,

J'utilise actuellement 3 éléments de la suite logiciel "AVS" pour faire
mes montages videos qui me convient parfaitement, c'est le système qui
ne me convient pas car seul Windows est supporté et je suis le plus
souvent sous xubuntu 12.04. J'ai déjà basculé vers linux pour deux
éléments sur les trois dont j'ai besoin:

- AVS remaker pour le premier traitement des rushs est maintenant
avantageusement remplacé par avidemux

- AVS Convertor: => handbrake fait plus rapidement le travail pour les
conversions de format

Il reste le montage final, que je fais toujours sous AVS Editor, mais
j'ai installé sur mon portable linux "kdenlive" pour tester. A priori il
est plutôt indiqué pour les configuration sous KDE mais il s'est
pourtant installé sans problème sous Xfce.

Contrairement aux modules AVS ou tout est tellement intuitif que l'on
peut faire beaucoup de choses sans doc (culture Windows!) j'ai lu et
tenté de reproduire les opérations basiques suivantes:

http://www.funix.org/fr/linux/index.php?ref=kdenlive pour les fondus
et
http://fr.wikibooks.org/wiki/Kdenlive/D%C3%A9marrage_rapide pour la
création d'une titre

Si je prends par exemple le seul sujet de la création d'un "clip titre"
je n'ai pas réussi à sortir autre chose qu'une séquence vide. Je peux
rentrer du texte, choisir la taille, valider, mais le clip reste
désespérément noir. Est-Il possible que ce problème vienne d'une
mauvaise compatibilité avec l'environnement Xfce, car apparemment le
programme est venu avec un environnement "runtime" de KDE:

Kdenlive
Version 0.8.2.1
Using KDE Development Platform 4.8.5 (4.8.5)

Je suis juste capable pour l'instant de mettre mes clips bout à bout,
sans aucun effet, et puis de générer le fichier DV de sortie. C'est un
peu limité! (et puis je peux faire ça avec avidemux)

Ai-je un problème de configuration sur mon poste, ou bien il y a-t-il un
truc que j'ai loupé?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 5
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LeLapin
Le #25792382
Le Sun, 17 Nov 2013 16:41:45 +0100
"denis.paris"
Bonjour,

J'utilise actuellement 3 éléments de la suite logiciel "AVS" po ur
faire mes montages videos qui me convient parfaitement, c'est le
système qui ne me convient pas car seul Windows est supporté et je
suis le plus souvent sous xubuntu 12.04. J'ai déjà basculé vers linux
pour deux éléments sur les trois dont j'ai besoin:

- AVS remaker pour le premier traitement des rushs est maintenant
avantageusement remplacé par avidemux

- AVS Convertor: => handbrake fait plus rapidement le travail pour
les conversions de format

Il reste le montage final, que je fais toujours sous AVS Editor, mais
j'ai installé sur mon portable linux "kdenlive" pour tester. A priori
il est plutôt indiqué pour les configuration sous KDE mais il s 'est
pourtant installé sans problème sous Xfce.

Contrairement aux modules AVS ou tout est tellement intuitif que l'on
peut faire beaucoup de choses sans doc (culture Windows!) j'ai lu et
tenté de reproduire les opérations basiques suivantes:

http://www.funix.org/fr/linux/index.php?ref=kdenlive pour les fondus
et
http://fr.wikibooks.org/wiki/Kdenlive/D%C3%A9marrage_rapide pour la
création d'une titre

Si je prends par exemple le seul sujet de la création d'un "clip
titre" je n'ai pas réussi à sortir autre chose qu'une séqu ence vide.
Je peux rentrer du texte, choisir la taille, valider, mais le clip
reste désespérément noir. Est-Il possible que ce problà ¨me vienne
d'une mauvaise compatibilité avec l'environnement Xfce, car
apparemment le programme est venu avec un environnement "runtime" de
KDE:

Kdenlive
Version 0.8.2.1
Using KDE Development Platform 4.8.5 (4.8.5)

Je suis juste capable pour l'instant de mettre mes clips bout à bout ,
sans aucun effet, et puis de générer le fichier DV de sortie. C 'est
un peu limité! (et puis je peux faire ça avec avidemux)

Ai-je un problème de configuration sur mon poste, ou bien il y a-t-il
un truc que j'ai loupé?




Si tu as un rendering, ta config est bonne.

J'ai quelques réponses qui pourraient (oupas) t'aider.

Déjà le plus gros défaut de KDEnlive c'est la gestion des pi stes et
des transparences, qu'il ne sait absolument pas faire proprement.
Ensuite les effets sont comme tu le dis assez anti-intuitifs les
premières fois.

Alors j'ai beau tenter de faire quelque chose d'utile de ce soft depuis
plus d'un an, j'ai complètement abandonné pour utiliser openshot
(reportages surtout, jusqu'à plus de 40 minutes jusque-là, je vais
même probablement finir le premier docu à 100% avec) et Cinelerra (si
besoins supérieurs, quoique...)

En passant, j'ai quelques infos en avant-première sur la version
d'openshot à sortir cet hiver pour avoir beaucoup discuté avec le
leader du projet, et ça va remplir 100% de mes besoins.

http://www.openshotvideo.com/

Openshot va déjà te résoudre en deux coups de cuillère à pot tout ce
qui concerne titraille, habillage et transparences
jdanield
Le #25792432
Le 17/11/2013 16:41, denis.paris a écrit :

j'ai installé sur mon portable linux "kdenlive" pour tester. A priori
il est plutôt indiqué pour les configuration sous KDE mais il s'est
pourtant installé sans problème sous Xfce.



c'est ca, linux :-)


Contrairement aux modules AVS ou tout est tellement intuitif que l'on
peut faire beaucoup de choses sans doc (culture Windows!)



kdenlive a sa propre logique (comme chaque logiciel)

j'ai lu et
tenté de reproduire les opérations basiques suivantes:



le problème avec les tutos, c'est que kdenlive évolue vite et que les
tutos sont trop vieux...

Si je prends par exemple le seul sujet de la création d'un "clip
titre"



je n'ai pas fait de titre depuis longtemps sous kdenlive.

déjà, pour le fondu enchainé, ce que j'ai trouvé de mieux et qui ne me
plait pas vraiment c'est de mettre les séquences à enchainer sur deux
pistes l'une en dessous de l'autre avec un chevauchement correspondant
au fondu, ensuite on demande l'effet "dissolve".

si il y a plusieurs clips, on, alterne un en haut et un en bas, on
peut choisir le sens du fondu.

sinon je pratique à peu près comme mon programme windows (magix), je
met toute la piste dans la timeline, puis je coupe les parties que je
ne veux pas

je viens de tester comment mettre un titre, en suivant le premier lien
que vous avez donné.

En fait il faut créer un "clip titre" dans projet et l'ajouter ensuite
à la timeline. kdenlive crée automatiquement un effet "affine" avec la
piste suivante ou vous pouvez mettre votre clip.

pour vérifier, démarrez le titre un peu avant la video (pour vérifier
qu'il s'affiche bien)

jdd
jdanield
Le #25792422
Le 17/11/2013 17:11, LeLapin a écrit :

Openshot va déjà te résoudre en deux coups de cuillère à pot tout ce
qui concerne titraille, habillage et transparences



ça reste à voir, et ca fait plus d'un an qu'on nous la promet...

chaque logiciel a sa propre logique, j'ai mis des années à maitriser
Magix... et sur kdenlive je suis encore débutant

jdd
LeLapin
Le #25792532
Le Sun, 17 Nov 2013 17:19:57 +0100
jdanield
Le 17/11/2013 17:11, LeLapin a écrit :

> Openshot va déjà te résoudre en deux coups de cuillà ¨re à pot tout ce
> qui concerne titraille, habillage et transparences
>
ça reste à voir, et ca fait plus d'un an qu'on nous la promet...



Sur ces points précis (ainsi que les effets et transitions de base ou
un peu plus évolués) c'est déjà dans l'ancienne version . Ça fait deux
ans que je bosse avec et une fois résolu un petit problème de ren dering
(à cause d'un paquet de substitution de ffmpeg problématique dans ma
config) ça a tout de suite marché impec.

chaque logiciel a sa propre logique, j'ai mis des années à mait riser
Magix... et sur kdenlive je suis encore débutant



Moi j'abandonne définitivement KDEnlive. Openshot 1.4.3 remplit tous
mes besoins avec une grande rapidité et efficacité (je peux reven ir
plus longuement sur les défauts des versions 1 d'openshot mais à
quelques semaines de l'upgrade ça me semble un peu futile), et j'ai
récemment revalidé Cinelerra sur ma config, en cas de gros besoin s je
peux toujours basculer dessus.

Un Macintoshien m'a fait essayer récemment je ne sais quel atrocement
coûteux logiciel de montage (si c'était Première, il a vache ment
changé !). Et très sincèrement, même si très intui tivement j'ai
retrouvé mes marques, j'ai été très déçu par l'ergonomie et le manque
de maîtrise de choses pourtant simples. En tous cas je ne regrette pas
un poil mon époque Premiere/Win, je n'y ai que gagné (et je ne pa rle
même pas de fric).
denis.paris
Le #25792522
Le 17/11/2013 17:16, jdanield a écrit :
Le 17/11/2013 16:41, denis.paris a écrit :

j'ai installé sur mon portable linux "kdenlive" pour tester. A priori
il est plutôt indiqué pour les configuration sous KDE mais il s'est
pourtant installé sans problème sous Xfce.



c'est ca, linux :-)


Contrairement aux modules AVS ou tout est tellement intuitif que l'on
peut faire beaucoup de choses sans doc (culture Windows!)



kdenlive a sa propre logique (comme chaque logiciel)

j'ai lu et
tenté de reproduire les opérations basiques suivantes:



le problème avec les tutos, c'est que kdenlive évolue vite et que les
tutos sont trop vieux...

Si je prends par exemple le seul sujet de la création d'un "clip
titre"



je n'ai pas fait de titre depuis longtemps sous kdenlive.

déjà, pour le fondu enchainé, ce que j'ai trouvé de mieux et qui ne me
plait pas vraiment c'est de mettre les séquences à enchainer sur deux
pistes l'une en dessous de l'autre avec un chevauchement correspondant
au fondu, ensuite on demande l'effet "dissolve".

si il y a plusieurs clips, on, alterne un en haut et un en bas, on peut
choisir le sens du fondu.

sinon je pratique à peu près comme mon programme windows (magix), je met
toute la piste dans la timeline, puis je coupe les parties que je ne
veux pas

je viens de tester comment mettre un titre, en suivant le premier lien
que vous avez donné.

En fait il faut créer un "clip titre" dans projet et l'ajouter ensuite à
la timeline. kdenlive crée automatiquement un effet "affine" avec la
piste suivante ou vous pouvez mettre votre clip.

pour vérifier, démarrez le titre un peu avant la video (pour vérifier
qu'il s'affiche bien)

jdd



Je viens de réessayer: rien à faire! De même pour les fondus, je mets
deux clips sur 2 lignes différentes, qui se superposent, je choisis
"dissoudre"... et ça passe de l'un à l'autre d'un coup sec sans
transition (comme dirait Poivre d'Arvor...)

Bref, je laisse tomber, je vais tester Openshot comme suggéré par
LeLapin. En fait j'ai déjà testé mais sur une machine virtuelle pour
faire un premier dégrossissage des softs testés, en ne retenant que ceux
qui ne plantaient pas (une machine virtuelle d'un ESX est assez
spéciale, certains softs ne supportent pas). Je l'avais donc jeté lors
de cette première passe car il avait crashé direct au chargement d'un
clip, je vais l'installer "en vrai" sur ma machine et je vous fais un
retour.

Merci pour vos contributions.
LeLapin
Le #25792572
Le Sun, 17 Nov 2013 17:56:24 +0100
"denis.paris"
Le 17/11/2013 17:16, jdanield a écrit :
> Le 17/11/2013 16:41, denis.paris a écrit :
>
>> j'ai installé sur mon portable linux "kdenlive" pour tester. A
>> priori il est plutôt indiqué pour les configuration sous KDE mais
>> il s'est pourtant installé sans problème sous Xfce.
>
> c'est ca, linux :-)
>
>>
>> Contrairement aux modules AVS ou tout est tellement intuitif que
>> l'on peut faire beaucoup de choses sans doc (culture Windows!)
>
> kdenlive a sa propre logique (comme chaque logiciel)
>
> j'ai lu et
>> tenté de reproduire les opérations basiques suivantes:
>
> le problème avec les tutos, c'est que kdenlive évolue vite et que
> les tutos sont trop vieux...
>
>> Si je prends par exemple le seul sujet de la création d'un "clip
>> titre"
>
> je n'ai pas fait de titre depuis longtemps sous kdenlive.
>
> déjà, pour le fondu enchainé, ce que j'ai trouvé de mieux et qui ne
> me plait pas vraiment c'est de mettre les séquences à enchain er sur
> deux pistes l'une en dessous de l'autre avec un chevauchement
> correspondant au fondu, ensuite on demande l'effet "dissolve".
>
> si il y a plusieurs clips, on, alterne un en haut et un en bas, on
> peut choisir le sens du fondu.
>
> sinon je pratique à peu près comme mon programme windows (mag ix),
> je met toute la piste dans la timeline, puis je coupe les parties
> que je ne veux pas
>
> je viens de tester comment mettre un titre, en suivant le premier
> lien que vous avez donné.
>
> En fait il faut créer un "clip titre" dans projet et l'ajouter
> ensuite à la timeline. kdenlive crée automatiquement un effet
> "affine" avec la piste suivante ou vous pouvez mettre votre clip.
>
> pour vérifier, démarrez le titre un peu avant la video (pour
> vérifier qu'il s'affiche bien)
>
> jdd

Je viens de réessayer: rien à faire! De même pour les fond us, je mets
deux clips sur 2 lignes différentes, qui se superposent, je choisis
"dissoudre"... et ça passe de l'un à l'autre d'un coup sec sans
transition (comme dirait Poivre d'Arvor...)

Bref, je laisse tomber, je vais tester Openshot comme suggéré p ar
LeLapin. En fait j'ai déjà testé mais sur une machine virt uelle pour
faire un premier dégrossissage des softs testés, en ne retenant que
ceux qui ne plantaient pas (une machine virtuelle d'un ESX est assez
spéciale, certains softs ne supportent pas). Je l'avais donc jetà ©
lors de cette première passe car il avait crashé direct au char gement
d'un clip, je vais l'installer "en vrai" sur ma machine et je vous
fais un retour.

Merci pour vos contributions.



Si tu as un pb de config pour openshot, (surtout pour installer la
1.4.3 qui ne convient pas partout), je te ferai passer mes échanges
avec l'équipe de dev, le gars a résolu mon problème trè s vite malgré
des symptômes bizarres.
jdanield
Le #25792622
Le 17/11/2013 17:56, denis.paris a écrit :

Je viens de réessayer: rien à faire! De même pour les fondus, je mets
deux clips sur 2 lignes différentes, qui se superposent, je choisis
"dissoudre"... et ça passe de l'un à l'autre d'un coup sec sans
transition (comme dirait Poivre d'Arvor...)



faut changer le sens (clic sur l'effet)

clip, je vais l'installer "en vrai" sur ma machine et je vous fais un
retour.



la version actuelle est très basique mais marche bien

jdd
Stephane Legras-Decussy
Le #25792762
On 11/17/2013 05:56 PM, LeLapin wrote:

Moi j'abandonne définitivement KDEnlive. Openshot 1.4.3 remplit tous
mes besoins avec une grande rapidité et efficacité



si tu dois changer un peu les couleurs, tu fais
comment ?

tu sais s'il ô miracle il y aura un
brave outils courbe dans la 2.0 ?
LeLapin
Le #25792792
Réponses au fil du texte. N'ayant plus accès à la 1.4.0 mes réponses
con,cernent la 1.4.3, qui a pour autre avantage d'être bien plus stabl e.

Le Sun, 17 Nov 2013 19:05:54 +0100
"denis.paris"
Merci. J'ai testé avec la version par défaut proposé par ma
distribution actuelle 12.04 LTS, comme je ne suis pas adepte des
versions trop récentes je préfère privilégier la stab ilité. Openshot
vient avec la version 1.4.0 pour ce qui me concerne.



Pour des raisons d'historique de projet, c'est celle qui avait été
tentée de stabiliser pour la distrib Ubuntu-Studio bien que pas
stabilisée du tout.

Ayant eu moi-même des problèmes avec Quantal au début, j'à ©tais revenu
sous la LTS (12.04) et c'est bel et sous Precise que j'ai réussi à
installer la 1.4.3 (comme je disais, le seul gros problème sous
U-Studio 12.04 est un paquet de substitution de ffmpeg).

Premières impressions: très simple à prendre en main, corr espond
exactement à ce dont j'ai besoin en terme de fonctionnalités.



La Souris (ma compagne) qui est tout sauf une jeune geekette, l'a
adopté assez spontanément (comme elle a adopté U-STudio en q uelques
minutes d'ailleurs, ce qui élimine le dernier Windows de la maison).

En revanche des points négatifs:

- plutôt lent (la création d'une petit fichier m'a pris deux fo is
plus de temps que sous AVS / Windows, ce qui est un comble). J'ai une
petite config (portable ACER de 5 ans environ)



J'ai une vieille config aussi (même époque) et j'ai pas mal ram é avant
de trouver le bon compromis de rendering. De façon assez surprenante,
j'ai d'excellentes performances en MP4/h264 (1024x576 pour le web, full
HD pour le reste). Difficile de te chiffrer les performances sachant
que ma machine fait toujours plein d'autres choses en même temps que le
rendering, mais à vue de nez je dirais un ration 4/1 au pire (temps de
rendering = 4 fois le temps de lecture de la vidéo finie, avec un
reportage de base genre 6 pistes dont deux d'incrustation/titrage).

La config, et notamment le crucial ffmpeg est un point clé.


- stabilité douteuse, il a crashé deux ou trois fois en cours d e
manipulation. Je suppose que si on a passé de nombreuses heures à  
faire un montage on ne doit pas être ravi! La parade est de
sauvegarder fréquemment son projet, mais il faut espérer qu'il ne
plante pas en cours de création du fichier final qui me prend
typiquement 4 ou 5 heures sur ma config.



Alors preums je te recommande de mettre les deux enregistrements
automatiques en route (quelque part dans les réglages) : un toutes les x
minutes, et un à chaque fois que tu appuies sur le Play du moniteur
(c'est à dire quasiment à chaque manip en gros). C'est totalement
transparent (pas de ralentissement) et on l'oublie bien vite...
jusqu'au crash suivant où en deux clics et 10 secondes on se retrouve
exactement au même endroit de son montage. ;)

Par ailleurs en mode édition il ne plante presque plus, et seulement
sur des trucs un peu baroques (probablement pas prévus mais pas
bloqués, pb de cette version 1.4.0).

Il arrive que le "client" openshot plante en plein milieu du
rendering, mais il faut savoir que ce n'est pas lui qui fait le
rendering mais un script qu'il lance. Donc en allant dans le dossier
cible, tu verras ton fichier gentiment grossir et se finir tout seul.

- Même sans être très exigeant quelques fonctions semblent manquer à
l'appel (ou alors je ne les ai pas trouvées), comme par exemple de
modifier la longueur de la séquence titre (5 secondes par défau t)



Deux techniques selon les besoins :
- L'outil "longueur" (à droite des ciseaux) te permet de redimensionner
à la main (rapide, pratique, vite fait, limité à 5 minutes par plan).
- Click droit sur le plan (sur la piste bien entendu), Propriétés,
Onglet Durée. Là tu mets la valeur directement.

ou
de modifier la taille de la police des caractères.



Je n'utilise pas openshot directement comme titreur, je ne m'en sers
que pour lancer inkscape préchargé avec la bonne taille de page
(1920x1080) le titre à la con que ça génère et je bosse ma titraille et
mon infographie librement. Quand je ferme ça se retrouve direct dans
openshot.

Si tu utilises inkscape en manuel, n'oublie pas de d'exporter en png
avec les transparences si tu veux qu'openshot le traite très
facilement (il n'aime pas les .svg d'inkscape parfois).

Petite variation sur le thème, si ça t'amuse :

Pour mes reportages j'incruste les noms des gens dans une zone colorée
en bas de l'écran, mais je cherchais une "signature" esthétique q ui ne
soit pas trop lourde à gérer donc j'ai commencé à faire ça (et c'est
définitivement adopté).

Tu fais ta légende sous inkscape, comme d'hab (moi je m'en garde des
templates de noms/fonctions pour simplifier), puis tu vas sous openshot
et importes ton incrustation.

Tu la colles 3 fois de suite (non jointifs, c'est plus facile à
retrouver après, tu comprendras pourquoi) dans la piste que tu ré serves
à cet usage (s'il n'y en a qu'une) et tu fais la manip suivante :

- Sur la première occurrence tu click-droit-Propriétés-Dur ée et tu mets
200ms en sortie (0,2), soit 5 images. Puis onglet Agencement, mettre
X à -100% (moins cent). Appliquer.

- Sur la deuxième tu choisis la durée que tu veux, tu n'oublies p as
l'outil aimant pour coller le début contre la fin des 0,2 secondes.

- Sur la 3è tu changes la durée à 0,2 aussi, mais en Agencem ent tu
fais : Image-clé = fin de la séquence, et X= +100%. Tu appl iques, et
colle le bout derrière les deux autres et t'as un exemple tout con de
truc assez joli, et que tu fais en 30 secondes ou moins une fois le
truc en mains. :)

Si ça éveille ton intérêt pour la 1.4, je suis à t a dispo sur
d'autres questions sur l'utilisation (depuis le temps j'ai quand même
été confronté à une belle collection de problèmes à résoudre ou
d'astuces à trouver), et toujours dispo si tu as des pbs à instal ler la
1.4.3.
LeLapin
Le #25792842
Le Sun, 17 Nov 2013 19:55:47 +0100
LeLapin
Par ailleurs en mode édition il ne plante presque plus, et seulement
sur des trucs un peu baroques (probablement pas prévus mais pas
bloqués, pb de cette version 1.4.0).



Erratum : "de cette version 1.4.x"
Publicité
Poster une réponse
Anonyme