UUID et gros volume, bug ou pas bug ?

Le
Pierre Maurette
Bonjour,

Je cherche à monter au démarrage un disque USB composé de trois
partitions NTFS 270Go, NTFS 170Go et FAT32 30Go, et ce avec quelques
contraintes, vu l'usage que je fais de ce disque.
Logiquement, je m'oriente vers de l'UUID. Le souci est avec une
Mandriva 2008 i586.

Extrait du /etc/fstab:

UUID1C55FA1C55E2EC /media/usb-media ntfs-3g
defaults,force,sync,locale=fr_FR.UTF-8 0 0
/dev/sda1 /media/usb-media ntfs-3g
defaults,force,sync,locale=fr_FR.UTF-8 0 0
/dev/sdb1 /media/usb-media ntfs-3g
defaults,force,sync,locale=fr_FR.UTF-8 0 0
/dev/sdc1 /media/usb-media ntfs-3g
defaults,force,sync,locale=fr_FR.UTF-8 0 0
UUIDv802EDD802EA419 /media/usb-data ntfs-3g
defaults,force,sync,locale=fr_FR.UTF-8 0 0
UUID(FB-BFAE /media/usb-fat32 vfat
umask=0,users,iocharset=utf8,sync,exec 0 0

Les UUID furent récupérés par /dev/disk/by-uuid/ et vol_id, et tout est
cohérent. Bien entendu, les lignes 2, 3 et 4 ont été ajoutées après
avoir constaté le problème, et elles ne me couvrent pas AMHA du risque
de me retrouver avec une clé USB ou un APN monté en /media/usb-media.

Avec la première ligne, en faisant par exemple mount -a, j'obtiens:
ntfs-3g: Cannot mount 'UUID1C55FA1C55E2EC': Aucun fichier ou
répertoire de ce type

J'ai vérifié tout ce qu'il fallait vérifier, redémonté mon disque
proprement à partir d'un Windows XP au cas où, rien à faire. Le point
important c'est que:
- Dans les mêmes conditions, la deuxième partition NTFS se monte sans
problème par UUID.
- Avec un boot Ubuntu Hardy x86-64 sur la même machine, et les mêmes
lignes dans le /etc/fstab, les trois partitions se montent sans
problème avec le UUID.

J'ai vu quelques machins de ce genre avec Google. Mais souvent le
/etc/fstab était autogénéré, et les gars considéraient le problème
réglé par le remplacement par /dev/xxxn Il y a peut-être - avec de
grandes réserves, je n'ai pas gardé les liens - un point commun avec
mon cas, ce serait la grande taille de la partition concernée, un seuil
autour de 250Go. Pourrait-on penser à un bug - dans ntfs-3g à priori -
quand compilé en x86-32 qui disparaîtrait quand compilé en x86-64 ? Ce
ne serait pas totalement illogique, si on pense aux tailles d'entiers
et de pointeurs.

Si ça dit quelque chose à quelqu'un, ça m'intéresse. Encore que ce
n'est pas prioritaire, ça marche assez bien comme ça.

Bonne journée à tous

--
Pierre Maurette
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Florac
Le #6573591
Le Wed, 07 May 2008 08:25:55 +0200, Pierre Maurette a écrit :


Si ça dit quelque chose à quelqu'un, ça m'intéresse. Encore que ce
n'est pas prioritaire, ça marche assez bien comme ça.


Vérifie qu'il n'y a pas des caractères bizarres dans /etc/fstab.
Normalement entre les champs il ne doit y avoir que des espaces ou des
tabs, de préférence que l'un ou que l'autre.

--
Le commissaire : Comment vous appelez-vous?
Garance : Moi je ne m'appelle jamais, je suis toujours là. J'ai pas
besoin de m'appeler. Mais les autres m'appellent Garance, si ça peut
vous intéresser.
Prévert,"les enfants du Paradis".

Pierre Maurette
Le #6575071
Le Wed, 07 May 2008 08:25:55 +0200, Pierre Maurette a écrit :


Si ça dit quelque chose à quelqu'un, ça m'intéresse. Encore que ce
n'est pas prioritaire, ça marche assez bien comme ça.


Vérifie qu'il n'y a pas des caractères bizarres dans /etc/fstab.
Normalement entre les champs il ne doit y avoir que des espaces ou des
tabs, de préférence que l'un ou que l'autre.


Merci. Mais j'avais levé ce doute de plusieurs façons, ce n'est pas ça.
D'ailleurs, il semble bien que mount (ou je ne sais trop quoi)
comprenne bien ce qu'il doit faire, et que ce soit ntfs-3g qui
n'obtient pas la bonne valeur.

--
Pierre Maurette


Publicité
Poster une réponse
Anonyme