Valeurs distinctes filtrées

Le
Ellimac
Bonjour,

J'ai récupéré il ya longtemps quelques formules pour compter le nombre de
valeurs distinctes :

=SOMMEPROD(N(FREQUENCE(plage;plage)>0)) pour valeur numériques uniquement
=SOMME(1/NB.SI(plage2;plage2)) matricielle ne fonctionne pas s'il y a des
cellules vides
=SOMME(SI(NB.SI(plage3;plage3)<>0;1/NB.SI(plage3;plage3);"")) matricielle
fonctionne même avec des vides

Mais je ne réussi pas à faire fonctionner sur une plage filtrée.

Une idée ?
Merci
Camille
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #5276891
de AV:
Avec une plage nommée "Noms" (A2:Ax) et une autre nommée "Valeurs" (B2:Bx)
(étiquettes en A1 et B1) utilise cette formule :
=SOMMEPROD((SOUS.TOTAL(3;DECALER(Noms;LIGNE(Noms)-MIN(LIGNE(Noms));;1)))*(Valeurs<50))
http://www.excelabo.net/excel/filtres.php#sommeprodfiltre

--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net
Ellimac
Le #5276851
Super merci beaucoup

Camille


"Misange"
de AV:
Avec une plage nommée "Noms" (A2:Ax) et une autre nommée "Valeurs" (B2:Bx)
(étiquettes en A1 et B1) utilise cette formule :
=SOMMEPROD((SOUS.TOTAL(3;DECALER(Noms;LIGNE(Noms)-MIN(LIGNE(Noms));;1)))*(Valeurs<50))
http://www.excelabo.net/excel/filtres.php#sommeprodfiltre

--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net



Publicité
Poster une réponse
Anonyme