Validation

Le
Michel B
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom, Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #7008701
Bonjour,
Dans ta colonne A, tu peux utiliser données/validation/autoriser pour créer
ta liste
pour le contrôle, je te propose le code suivant dans le module de la feuille
concernée :

Private Sub Worksheet_Change(ByVal Target As Range)
'MPFE le 15/06/2008
If Not Intersect(Target, Range("a2:a654")) Is Nothing Then
r = Target.Row
If Range("d" & r).Value = "" Or Range("e" & r).Value _
= "" Or Range("f" & r).Value = "" Then
Application.EnableEvents = False
Range("a" & r).Value = ""
End If
End If
Application.EnableEvents = True
End Sub
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Michel B" news:4854cc28$0$5046$
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel




JB
Le #7008691
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JB
http://boisgontierjacques.free.fr/


On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains cham ps
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom, Pr énom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel


Michel B
Le #7009131
Bonjour JB,


Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule ligne ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel






"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JB
http://boisgontierjacques.free.fr/


On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel


JB
Le #7009241
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"
Bonjour JB,

Je viens d'essayer  en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une s eule ligne ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"


Bonjours,

je souhaite controller avant de mettre un champ à jour que certains ch amps
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Michel B
Le #7009371
Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non, alors
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel


"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"
Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"


Bonjours,

je souhaite controller avant de mettre un champ à jour que certains
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



JB
Le #7009361
http://cjoint.com/?gpnlGbPuR1

Lors de la création de Données/Validation, il faut que D2,E2,F2 soient
remplis (les effacer après)

JB

On 15 juin, 12:59, "Michel B"
Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non, alors
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel

"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"


Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom ,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




Michel B
Le #7010211
Merci JB,

ça y est j'ai compris,

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)
Change a chaque ligne.
=SI(ET(D3<>"";E3<>"";F3<>"");MaListe)
=SI(ET(D4<>"";E4<>"";F4<>"");MaListe)
=SI(ET(D5<>"";E5<>"";F5<>"");MaListe)
Il s'agit donc d'une mise en place unitaire.

N'existe il pas quelque chose pour travaillé au niveau des colonnes ?

=SI(ET(D<>"";E<>"";F<>"");MaListe) D,E,F, de la ligne!
Il faut que je prévois 3 000 lignes cela risque d'être long ?
Et que lorsque la table a peu d'enregistrements 40 ou 50, elle ne pése pas
le même poid qu'avec 2000 ou 3000 enregistrements

Peut- être existe il une approche différente ?

Merci
Michel


"JB"

http://cjoint.com/?gpnlGbPuR1

Lors de la création de Données/Validation, il faut que D2,E2,F2 soient
remplis (les effacer après)

JB

On 15 juin, 12:59, "Michel B"
Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non, alors
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel

"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"


Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -




Merguez07
Le #7010561
non ce n'est pas un travail unitaire
tu mets la première en A2
puis tu sélectionnes en bas à droite de ta cellule (le curseur de la souris
doit faire une croix)
et tu tires vers le bas (tu lâche pas le clic gauche de la souris)
l'affaire est dans le sac

XavierP

"Michel B" discussion : 48552079$0$5409$
Merci JB,

ça y est j'ai compris,

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)
Change a chaque ligne.
=SI(ET(D3<>"";E3<>"";F3<>"");MaListe)
=SI(ET(D4<>"";E4<>"";F4<>"");MaListe)
=SI(ET(D5<>"";E5<>"";F5<>"");MaListe)
Il s'agit donc d'une mise en place unitaire.

N'existe il pas quelque chose pour travaillé au niveau des colonnes ?

=SI(ET(D<>"";E<>"";F<>"");MaListe) D,E,F, de la ligne!
Il faut que je prévois 3 000 lignes cela risque d'être long ?
Et que lorsque la table a peu d'enregistrements 40 ou 50, elle ne pése pas
le même poid qu'avec 2000 ou 3000 enregistrements

Peut- être existe il une approche différente ?

Merci
Michel


"JB"

http://cjoint.com/?gpnlGbPuR1

Lors de la création de Données/Validation, il faut que D2,E2,F2 soient
remplis (les effacer après)

JB

On 15 juin, 12:59, "Michel B"
Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non,
alors
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel

"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"


Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule
ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -








JB
Le #7010551
Il suffit de:

-Sélectionner les 3000 cellules avant Données/Validation

ou

-Recopier 3000 fois la cellule où Données/Valid a été fait 3000 fois

JB

On 15 juin, 15:55, "Michel B"
Merci JB,

ça y est j'ai compris,

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)
Change a chaque ligne.
=SI(ET(D3<>"";E3<>"";F3<>"");MaListe)
=SI(ET(D4<>"";E4<>"";F4<>"");MaListe)
=SI(ET(D5<>"";E5<>"";F5<>"");MaListe)
Il s'agit donc d'une mise en place unitaire.

N'existe il pas quelque chose pour travaillé au niveau des colonnes ?

=SI(ET(D<>"";E<>"";F<>"");MaListe)   D,E,F, de la ligne!
Il faut que je prévois 3 000 lignes cela risque d'être long ?
Et que lorsque la table a peu d'enregistrements 40 ou 50, elle ne pése p as
le même poid qu'avec 2000 ou 3000 enregistrements

Peut- être existe il une approche différente ?

Merci
Michel

"JB"

http://cjoint.com/?gpnlGbPuR1

Lors de la création de Données/Validation, il faut que D2,E2,F2 soient
remplis (les effacer après)

JB

On 15 juin, 12:59, "Michel B"


Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non, alo rs
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel

"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"
Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à u ne seule ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certain s
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le N om,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte de s
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -





Michel B
Le #7011341
Un grand merci a tous,

ça marche, je n'avais pas remarqué que la recopie incrémentée la formule.

c'est super.
Encore merci
Michel



"JB"
Il suffit de:

-Sélectionner les 3000 cellules avant Données/Validation

ou

-Recopier 3000 fois la cellule où Données/Valid a été fait 3000 fois

JB

On 15 juin, 15:55, "Michel B"
Merci JB,

ça y est j'ai compris,

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)
Change a chaque ligne.
=SI(ET(D3<>"";E3<>"";F3<>"");MaListe)
=SI(ET(D4<>"";E4<>"";F4<>"");MaListe)
=SI(ET(D5<>"";E5<>"";F5<>"");MaListe)
Il s'agit donc d'une mise en place unitaire.

N'existe il pas quelque chose pour travaillé au niveau des colonnes ?

=SI(ET(D<>"";E<>"";F<>"");MaListe) D,E,F, de la ligne!
Il faut que je prévois 3 000 lignes cela risque d'être long ?
Et que lorsque la table a peu d'enregistrements 40 ou 50, elle ne pése pas
le même poid qu'avec 2000 ou 3000 enregistrements

Peut- être existe il une approche différente ?

Merci
Michel

"JB"

http://cjoint.com/?gpnlGbPuR1

Lors de la création de Données/Validation, il faut que D2,E2,F2 soient
remplis (les effacer après)

JB

On 15 juin, 12:59, "Michel B"


Re bonjour JB,

je ne comprend pas sur la tienne cela fonctionne, sur la mienne non,
alors
que je fais un copié/collé ?

Si tu peux y jeter un coup d'oeil

http://cjoint.com/?gpncxi26ZH

d'avance merci
Michel

"JB"
Voir PJ

http://cjoint.com/?gpmJzbK460

JB

On 15 juin, 12:22, "Michel B"
Bonjour JB,

Je viens d'essayer en créant une liste :

"MaListe"
X
N

et dans validation :

=SI(ET(D2<>"";E2<>"";F2<>"");MaListe)

le message d'erreur est :
La liste source doit être délimité, ou faire référence à une seule
ligne
ou
colonne.

Je ne dois pas mettre ce qu'il faut au bonne endroit ?

Merci
Michel

"JB"
Bonjour,

Données/Validation/Liste

=SI(ET(D2<>"";E2<>"";F2<>"");Liste)

JBhttp://boisgontierjacques.free.fr/

On 15 juin, 09:56, "Michel B"
Bonjours,

je souhaite controller avant de mettre un champ à jour que certains
champs
autres soit remplis :

Réinscription doit accepter la valeur "X" ou "N" seulement si le
Nom,
Prénom
et Date de Naissance est renseigné
X ou N étant dans une liste déroulante.

Genre :

valeur accepté en A2
"X"ou "N"
Si D2 Pas Null + E2 Pas Null + F2 Pas Null
Si Non, message et retour

je ne sais comment l'écrire et ou le mettre.

D'avance merci pour le coup de main.

Michel- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -





Publicité
Poster une réponse
Anonyme