vérifier avant de sauvegarder

Le
pellet15
Bonjour à tous

Dans une macros je voudrait que le fichier se sauvegarde
mais seulement si dans la cellule "G3" il n'y a pas la note "pas autoriser"
si non mettre fin a la procedure

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #24617981
bonjour,

Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Boolean)
If Range("G3") = "pas autoriser" Then Cancel = True
End Sub

ou

Sub Macro1()
If Range("G3") = "pas autoriser" Then Exit Sub
ThisWorkbook.Save
End Sub


--
isabelle



Le 2012-07-05 10:38, pellet15 a écrit :
Bonjour à tous

Dans une macros je voudrait que le fichier se sauvegarde
mais seulement si dans la cellule "G3" il n'y a pas la note "pas autoriser"
si non mettre fin a la procedure

Merci
pellet15
Le #24618031
Le jeudi 5 juillet 2012 12:04:02 UTC-4, isabelle a écrit :
bonjour,

Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Bool ean)
If Range("G3") = "pas autoriser" Then Cancel = True
End Sub

ou

Sub Macro1()
If Range("G3") = "pas autoriser" Then Exit Sub
ThisWorkbook.Save
End Sub


--
isabelle



Le 2012-07-05 10:38, pellet15 a écrit :
> Bonjour à tous
>
> Dans une macros je voudrait que le fichier se sauvegarde
> mais seulement si dans la cellule "G3" il n'y a pas la note "pas autori ser"
> si non mettre fin a la procedure
>
> Merci



Très bien cela fonctionne

Merci

Comment fair pour que la formule suivante

=SI(A1="";"";RECHERCHEV(A1;$A$2:$B$20;2;FAUX))

me donne "pas autoriser" a la place de "#N/A"
lorsquel ne trouve pas dans la liste de RECHERCHE

Merci encore
isabelle
Le #24618041
=SI(A1="";"";SI(ESTERREUR(RECHERCHEV(A1;$A$2:$B$20;2;FAUX));"pas autoriser";RECHERCHEV(A1;$A$2:$B$20;2;FAUX)))

--
isabelle



Le 2012-07-05 12:45, pellet15 a écrit :

Très bien cela fonctionne

Merci

Comment fair pour que la formule suivante

=SI(A1="";"";RECHERCHEV(A1;$A$2:$B$20;2;FAUX))

me donne "pas autoriser" a la place de "#N/A"
lorsquel ne trouve pas dans la liste de RECHERCHE

Merci encore
pellet15
Le #24618271
Le jeudi 5 juillet 2012 13:12:51 UTC-4, isabelle a écrit :
=SI(A1="";"";SI(ESTERREUR(RECHERCHEV(A1;$A$2:$B$20;2;FAUX));"pas auto riser";RECHERCHEV(A1;$A$2:$B$20;2;FAUX)))

--
isabelle



Le 2012-07-05 12:45, pellet15 a écrit :

> Très bien cela fonctionne
>
> Merci
>
> Comment fair pour que la formule suivante
>
> =SI(A1="";"";RECHERCHEV(A1;$A$2:$B$20;2;FAUX))
>
> me donne "pas autoriser" a la place de "#N/A"
> lorsquel ne trouve pas dans la liste de RECHERCHE
>
> Merci encore




Gros merci isabelle

Cela m'aide beaucoup
isabelle
Le #24618701
merci du retour pellet15, au plaisir!

--
isabelle



Le 2012-07-05 15:51, pellet15 a écrit :

Gros merci isabelle

Cela m'aide beaucoup
Publicité
Poster une réponse
Anonyme