Version de python et installation de modules

Le
Michel Depiesse
Bonjour,
Je suis nouveau en Python et je ne comprends pas comment le système chois=
it la version de python pour laquelle on installe un package (apt-get, pip,=
easy_install)

J'ai kivy qui marche avec la 2.7. On voit les fichiers dans /usr/lib
Mais je n'y arrive pas avec la 3.4.

Merci,
Mchl
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Laurent Pointal
Le #26094022
Michel Depiesse wrote:

Bonjour,
Je suis nouveau en Python et je ne comprends pas comment le système
choisit la version de python pour laquelle on installe un package
(apt-get, pip, easy_install)

J'ai kivy qui marche avec la 2.7. On voit les fichiers dans /usr/lib...
Mais je n'y arrive pas avec la 3.4.



Normalement il y a un pip par version de Python.

:~$ pip<tab>
pip pip2 pip3

Tu as peut-être un package python3-pip a installer.

Voir
https://stackoverflow.com/questions/10919569/how-to-pip-install-to-specific-version-of-python


A+
Laurent.


Merci,
Mchl


--
Laurent POINTAL -
Michel Depiesse
Le #26094362
Merci Laurent, j'ai suivi ton conseil mais il ne veut pas installer cython
et quand je recommence sudo apt-get install python3.4, ça ne marche plus non plus.

Comment se fait-il qu'il y a tant de manières différentes d'installer u n package python ?

Merci et bon week-end de Paques
Laurent Pointal
Le #26096312
Michel Depiesse wrote:

Merci Laurent, j'ai suivi ton conseil mais il ne veut pas installer cython
et quand je recommence sudo apt-get install python3.4, ça ne marche plus
non plus.

Comment se fait-il qu'il y a tant de manières différentes d'installer un
package python ?



Ça dépend s'il est packagé, ou non, et s'il l'est pour la version de Python
que tu veux utiliser.

:~$ apt-cache search cython
cython - Extensions C pour Python
cython-dbg - Extensions C pour Python - débogage
cython-doc - Extensions C pour Python - documentation
cython3 - Extensions C pour Python 3
cython3-dbg - Extensions C pour Python 3 - Débogage
python-jswebkit - WebKit/JavaScriptCore Python bindings
python-kivy - Kivy - Multimedia / Multitouch framework in Python
python-falcon - supersonic micro-framework for building cloud APIs - Python
2.x
python-misaka - binding for Sundown, a markdown parsing library - python 2.x
python-mpikmeans - Liaisons Python pour MPIKmeans
python3-falcon - supersonic micro-framework for building cloud APIs - Python
3.x
python3-misaka - binding for Sundown, a markdown parsing library - python
3.x

(sous une Kubuntu 14.04)

Il est probable que cython3 soit fourni pour la version "courante" de
Python3. Sous mon kubuntu, c'est Python 3.4, mais tu peux trouver du
python3.2 ou 3.3.


Pour le apt-get install python3.4, il faut que celui-ci soit dans les dépots
de ta distribution… pas toujours le cas.

Tu seras peut-être obligé d'utiliser des dépots "backports", ou encore de
recompiler python3.4 (tu peux installer les build-dep de python3 afin de
construire un python 3.4 dans ton répertoire perso).

Ensuite, pour pip, il faudra suivre le lien donné dans la discussion sur
stackoverflow.
==> http://www.pip-installer.org/en/latest/installing.html

A+


--
Laurent POINTAL -
Michel Depiesse
Le #26096362
Merci pour ces explications
Très sympa
Je vais regarder tout ça à l'aise
Bonne semaine à toi


Le lundi 21 avril 2014 15:56:55 UTC+1, Laurent Pointal a écrit :
Michel Depiesse wrote:



> Merci Laurent, j'ai suivi ton conseil mais il ne veut pas installer cyt hon

> et quand je recommence sudo apt-get install python3.4, ça ne marche p lus

> non plus.

>

> Comment se fait-il qu'il y a tant de manières différentes d'install er un

> package python ?



Ça dépend s'il est packagé, ou non, et s'il l'est pour la version d e Python

que tu veux utiliser.



:~$ apt-cache search cython

cython - Extensions C pour Python

cython-dbg - Extensions C pour Python - débogage

cython-doc - Extensions C pour Python - documentation

cython3 - Extensions C pour Python 3

cython3-dbg - Extensions C pour Python 3 - Débogage

python-jswebkit - WebKit/JavaScriptCore Python bindings

python-kivy - Kivy - Multimedia / Multitouch framework in Python

python-falcon - supersonic micro-framework for building cloud APIs - Pyth on

2.x

python-misaka - binding for Sundown, a markdown parsing library - python 2.x

python-mpikmeans - Liaisons Python pour MPIKmeans

python3-falcon - supersonic micro-framework for building cloud APIs - Pyt hon

3.x

python3-misaka - binding for Sundown, a markdown parsing library - python

3.x



(sous une Kubuntu 14.04)



Il est probable que cython3 soit fourni pour la version "courante" de

Python3. Sous mon kubuntu, c'est Python 3.4, mais tu peux trouver du

python3.2 ou 3.3.





Pour le apt-get install python3.4, il faut que celui-ci soit dans les d épots

de ta distribution... pas toujours le cas.



Tu seras peut-être obligé d'utiliser des dépots "backports", ou enc ore de

recompiler python3.4 (tu peux installer les build-dep de python3 afin de

construire un python 3.4 dans ton répertoire perso).



Ensuite, pour pip, il faudra suivre le lien donné dans la discussion su r

stackoverflow.

==> http://www.pip-installer.org/en/latest/installing.html



A+





--

Laurent POINTAL -
Publicité
Poster une réponse
Anonyme