Virtualbox ne fonctionne plus depuis une mise à jour récente

Le
David Hautbois
Salut
Depuis un semaine, virtualbox ne fonctionne plus suite à un dist-upgrade
sur ma Lenny.
Le message d'erreur :

The version of the VirtualBox kernel modules and the version of
VirtualBox application are not matching. You can correct this by either
installing the correct virtualbox-ose-modules package (if available)
through apt-get or by building it manually with: module-assistant
auto-install virtualbox-ose.
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).
Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

J'ai réinstallé virtualbox-ose-modules-2.6.26-1, puis
virtualbox-ose-modules, puis tout virtualbox.
J'ai fini par "module-assistant auto-install virtualbox-ose" qui s'est
bien passé.

Rien n'y fait, toujours la même erreur.
Le module vboxdrv se charge bien.

Pas grand chose du côté de Google, à part des bugzillas par récents.

Une idée ?

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michael HEYMANN
Le #17591211
David Hautbois a écrit :
Salut
Depuis un semaine, virtualbox ne fonctionne plus suite à un
dist-upgrade sur ma Lenny.



/etc/init.d/vboxdrv setup

(en sudo ou root)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David BERCOT
Le #17591191
Bonjour,

Le Mon, 20 Oct 2008 19:51:39 +0200,
David Hautbois
Salut
Depuis un semaine, virtualbox ne fonctionne plus suite à un
dist-upgrade sur ma Lenny.
Le message d'erreur :

The version of the VirtualBox kernel modules and the version of
VirtualBox application are not matching. You can correct this by
either installing the correct virtualbox-ose-modules package (if
available) through apt-get or by building it manually with:
module-assistant auto-install virtualbox-ose.
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).
Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

J'ai réinstallé virtualbox-ose-modules-2.6.26-1, puis
virtualbox-ose-modules, puis tout virtualbox.
J'ai fini par "module-assistant auto-install virtualbox-ose" qui
s'est bien passé.

Rien n'y fait, toujours la même erreur....
Le module vboxdrv se charge bien.



J'ai eu exactement le même problème...
Comment charges-tu le module vboxdrv ? Personnellement, je le mets
dans /etc/modules. Sauf que, apparemment, ça fonctionne moyen.
J'ai refait l'installation cet après-midi, j'ai chargé le module et
j'avais la même erreur.
J'ai alors utilisé module-assistant et ça ne fonctionnait pas mie ux.
J'ai fait un depmod -r vboxdrv, puis je l'ai rechargé. Et là, tout
roule... Est-ce que le problème restait l'ancien module ?

Si ça peut t'aider un peu...

Bon courage.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #17591881
saturne:/home/david# depmod -r vboxdrv
WARNING: Can't read module vboxdrv: No such file or directory

et
/etc/init.d/vboxdrv n'existe pas

Arrghh !!
Suis pas couché....

David BERCOT wrote:
Bonjour,

Le Mon, 20 Oct 2008 19:51:39 +0200,
David Hautbois
Salut
Depuis un semaine, virtualbox ne fonctionne plus suite à un
dist-upgrade sur ma Lenny.
Le message d'erreur :

The version of the VirtualBox kernel modules and the version of
VirtualBox application are not matching. You can correct this by
either installing the correct virtualbox-ose-modules package (if
available) through apt-get or by building it manually with:
module-assistant auto-install virtualbox-ose.
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).
Result Code:
0x80004005
Component:
Console
Interface:
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

J'ai réinstallé virtualbox-ose-modules-2.6.26-1, puis
virtualbox-ose-modules, puis tout virtualbox.
J'ai fini par "module-assistant auto-install virtualbox-ose" qui
s'est bien passé.

Rien n'y fait, toujours la même erreur....
Le module vboxdrv se charge bien.




J'ai eu exactement le même problème...
Comment charges-tu le module vboxdrv ? Personnellement, je le mets
dans /etc/modules. Sauf que, apparemment, ça fonctionne moyen.
J'ai refait l'installation cet après-midi, j'ai chargé le module et
j'avais la même erreur.
J'ai alors utilisé module-assistant et ça ne fonctionnait pas mieux.
J'ai fait un depmod -r vboxdrv, puis je l'ai rechargé. Et là, tout
roule... Est-ce que le problème restait l'ancien module ?

Si ça peut t'aider un peu...

Bon courage.

David.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Michael HEYMANN
Le #17592031
David Hautbois a écrit :
/etc/init.d/vboxdrv n'existe pas



Huh ? V'là aut' chose.

Juste pour info, pourrais-tu donner la sortie des 2 commandes suivantes:
uname -r
ls -l /etc/init.d/vbox*

Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #17592021
il y avait juste /etc/init.d/virtualbox
et setup n'était pas un argument de ce script.

et j'ai vérifié avec apt-file, aucun paquet ne fournit le fichier vboxdrv

Suis en train d'essayer virtualbox2

Michael HEYMANN wrote:
David Hautbois a écrit :
/etc/init.d/vboxdrv n'existe pas



Huh ? V'là aut' chose.

Juste pour info, pourrais-tu donner la sortie des 2 commandes suivantes:
uname -r
ls -l /etc/init.d/vbox*

Merci.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #17592551
C'est exactement ce que j'ai fait.
Je suis en train d'essayer ubuntu dans virtualbox2.

Vais pouvoir abandonner Vmware....

Michael HEYMANN wrote:
David Hautbois a écrit :
il y avait juste /etc/init.d/virtualbox
et setup n'était pas un argument de ce script.

et j'ai vérifié avec apt-file, aucun paquet ne fournit le fichier
vboxdrv

Suis en train d'essayer virtualbox2



Pour info, si tu n'es pas allergique aux "non-free", moi j'ai purgé la
version "ose" et ai ajouté dans mon "/etc/apt/sources.list"
deb http://download.virtualbox.org/virtualbox/debian lenny non-free

aptitude update
aptitude install virtualbox

Et roule ma poule !
(avec un "/etc/init.d/vboxdrv setup" pour chaque nouveau kernel)




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Michael HEYMANN
Le #17592541
David Hautbois a écrit :
il y avait juste /etc/init.d/virtualbox
et setup n'était pas un argument de ce script.

et j'ai vérifié avec apt-file, aucun paquet ne fournit le fichier vboxdrv

Suis en train d'essayer virtualbox2



Pour info, si tu n'es pas allergique aux "non-free", moi j'ai purgé la
version "ose" et ai ajouté dans mon "/etc/apt/sources.list"
deb http://download.virtualbox.org/virtualbox/debian lenny non-free

aptitude update
aptitude install virtualbox

Et roule ma poule !
(avec un "/etc/init.d/vboxdrv setup" pour chaque nouveau kernel)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Prévot
Le #17600681
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

David Hautbois a écrit :
il y avait juste /etc/init.d/virtualbox
et setup n'était pas un argument de ce script.

et j'ai vérifié avec apt-file, aucun paquet ne fournit le fichier vboxdrv



Normal : c'est à toi de construire ce module avec le paquet
virtualbox-ose-source et module-assistant (il y a parfois les modules
précompilés dans les paquets, mais ce n'est pas le cas en ce moment).

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkj95UoACgkQ18/WetbTC/qccwCfY9FLejKbvb6haBHfvEP2Abxy
UDkAoJWzL052B/X9GBcw7E2edGUXbhfw
=8XI/
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme