VirtualBox : interface Ethernet en mode "bridge" ne fonctionne pas sous Linux ?

Le
Eric Belhomme
Bonjour,

Soit une station de travail tournant sous Debian Jessie, avec 3
interfaces réseau (toutes Intel). Voici le fichier de conf de mes
interfaces :

auto eth0
iface eth0 inet dhcp

auto br2
iface br2 inet static
bridge_ports eth2
address 192.168.88.254
netmask 255.255.255.0


eth0 est utilisé en DHCP pour accéder à mon réseau local, eth1 est
inutilisée, et eth2 est un bridge ethernet pour un réseau de test

Soit maintenant une VM VirtualBox faisant tourner une Debian Wheezy,
dotée de 2 interfaces virtuelles :
- la 1ere interface est natée afin d'avoir un accès à Internet mon réseau
local,
- la 2eme interface est en mode bridge, connecté au bridge bridge br2 du
host.

Cette configuration ne fonctionne pas ! Lors du lancement de la VM,
l'interface eth0 permet bien de faire les mises à jour via Internet, en
revanche, il n'y a rien qui passe sur eth1 : impossible de joinbdre le
host (192.168.88.254) via cette interface.
D'ailleurs, sur le host, un "brctl show" permet de constater qu'il n'y a
pas d'interface créée et connectée au bridge br2

Le seul workaround que j'ai trouvé, est de créer une interface de type
"host only" dans VBox, de désactiver le serveur DHCP associé et de
rajouter manuellement coté host l'interface vboxnet0 ainsi créée à mon
bridge à coup de "brctl addif" Ca marche mais ce n'est pas propre !

Ma question est donc la suivante : comment fonctionne le mode bridge de
VBox ??? Je pensais que c'était construit autour de bridge-utils, mais
soit ce n'est pas le cas, soit il y a une subtilité qui m'a échapé dans
le paramétrage de biniou !

D'avance, merci !

--
Rico
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois Lafont
Le #26299988
Bonjour,

Pas vraiment d'idée par rapport à ton problème (désolé),
juste quelques remarques.

Le 04/08/2014 13:17, Eric Belhomme a écrit :

Soit une station de travail tournant sous Debian Jessie, avec 3
interfaces réseau (toutes Intel). Voici le fichier de conf de mes
interfaces :

auto eth0
iface eth0 inet dhcp

auto br2
iface br2 inet static
bridge_ports eth2
address 192.168.88.254
netmask 255.255.255.0



Quel est l'intérêt de faire un bridge si au final
une seule carte réseau y est attachée ? Pour ton
ton hôte physique, ça change quoi par rapport à un
simple :

iface eth2 inet static
address 192.168.88.254
netmask 255.255.255.0

?

Sachant que dans ce cas, tu peux bridger l'interface de ta VM
Virtualbox sur eth2 et ça devrait marcher directement.

eth0 est utilisé en DHCP pour accéder à mon réseau local, eth1 est
inutilisée, et eth2 est un bridge ethernet pour un réseau de test

Soit maintenant une VM VirtualBox faisant tourner une Debian Wheezy,
dotée de 2 interfaces virtuelles :
- la 1ere interface est natée afin d'avoir un accès à Internet mon réseau
local,
- la 2eme interface est en mode bridge, connecté au bridge bridge br2 du
host.

Cette configuration ne fonctionne pas ! Lors du lancement de la VM,
l'interface eth0 permet bien de faire les mises à jour via Internet, en
revanche, il n'y a rien qui passe sur eth1 : impossible de joinbdre le
host (192.168.88.254) via cette interface.
D'ailleurs, sur le host, un "brctl show" permet de constater qu'il n'y a
pas d'interface créée et connectée au bridge br2...



Ça, ce n'est pas un élément qu'il faut prendre en compte
je pense. Sur ma Debian Wheezy, j'utilise très souvent
Virtualbox et le paquet bridge-utils n'est même pas installé
sur mon hôte physique (et donc la commande brctl n'existe
pas).

Le seul workaround que j'ai trouvé, est de créer une interface de type
"host only" dans VBox, de désactiver le serveur DHCP associé et de
rajouter manuellement coté host l'interface vboxnet0 ainsi créée à mon
bridge à coup de "brctl addif"... Ca marche mais ce n'est pas propre !

Ma question est donc la suivante : comment fonctionne le mode bridge de
VBox ??? Je pensais que c'était construit autour de bridge-utils, mais
soit ce n'est pas le cas, soit il y a une subtilité qui m'a échapé dans
le paramétrage de biniou !



Je pense qu'il ne se base effectivement pas sur bridge-utils
mais je suis incapable de t'en dire plus sinon que, sur ma
Debian Wheezy, je peux voir ceci :

$ ip link

[...]

5: vboxnet0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT qlen 1000
link/ether 0a:00:27:00:00:00 brd ff:ff:ff:ff:ff:ff

Il y a une interface qui est créée et a priori utilisée
par Virtualbox (elle n'est pas visible via un ifconfig).

Mes 2 centimes...

--
François Lafont
Publicité
Poster une réponse
Anonyme