VLC - Debian

Le
essomba84
Bonjour à tous,

j'ai un problème depuis quelques temps que je n'arrive pas à régler. Je
suis incapable d'avoir un VLC fonctionnel sur ma debian sid. J'entends
par opérationnel qui lit entres autres les MP4.

Je ne comprends pas car n'importe quel Ubuntu lit ces fichiers sans
problèmes.

J'ai essayé avec les dépôts debian-multimedia, videolan et debian
classiques mais rien.

Y a t'il un endroit ou je peux télécharger un VLC qui marche ???

Merci,

--
Laurent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #24031671
essomba84 , dans le message écrit :
J'ai essayé avec les dépôts debian-multimedia, videolan et debian
classiques mais rien.

Y a t'il un endroit ou je peux télécharger un VLC qui marche ???



Ce n'est pas normal qu'un programme dans les dépôts officiels ne marche pas,
donc plutôt que chercher partout un nouveau paquet, il vaudrait mieux
comprendre pourquoi celui-là ne marche pas.

D'ailleurs, si trois versions, de trois origines différentes, ne marchent
pas, il y a de grosses chances que le problème soit sur ton système et pas
dans VLC, donc tu n'en trouveras aucun qui marche.
essomba84
Le #24031781
On 04/12/2011 19:07, Nicolas George wrote:
essomba84 , dans le message écrit :
J'ai essayé avec les dépôts debian-multimedia, videolan et debian
classiques mais rien.

Y a t'il un endroit ou je peux télécharger un VLC qui marche ???



Ce n'est pas normal qu'un programme dans les dépôts officiels ne marche pas,
donc plutôt que chercher partout un nouveau paquet, il vaudrait mieux
comprendre pourquoi celui-là ne marche pas.

D'ailleurs, si trois versions, de trois origines différentes, ne marchent
pas, il y a de grosses chances que le problème soit sur ton système et pas
dans VLC, donc tu n'en trouveras aucun qui marche.



le VLC marche. Simplement il ne lit pas les fichiers mp4v. Et le message
d'erreur retourné est: "Pas de décodeur approprié pour le format: VLC ne
supporte probablement pas le format audio ou video "mp4v".
Malheureusement, il n'y a rien à faire".

Bon moi je suis d'accord qu'il n'y a rien à faire, mais comment les gens
de Ubuntu ont fait alors ?

--
Laurent
Eric Jacoboni
Le #24031851
Le 04/12/2011 19:36, essomba84 a écrit :

Bon moi je suis d'accord qu'il n'y a rien à faire, mais comment les gens
de Ubuntu ont fait alors ?




Ben, une des grosses différences entre Ubuntu et Debian est que la
première installe tout un tas de trucs systématiquement, au risque que
tu n'en aies jamais besoin.
La seconde n'installe que ce que tu lui demandes (et encore, ça a un peu
changé depuis les débuts).

Donc, si tu n'as pas installé le codec qui va bien sous Debian, ben il
ne te l'installeras pas tout seul surtout si c'est un truc considéré
comme non-free et que tu n'as pas activé ce dépôt.
essomba84
Le #24031921
On 04/12/2011 19:50, Eric Jacoboni wrote:
Le 04/12/2011 19:36, essomba84 a écrit :

Bon moi je suis d'accord qu'il n'y a rien à faire, mais comment les gens
de Ubuntu ont fait alors ?




Ben, une des grosses différences entre Ubuntu et Debian est que la
première installe tout un tas de trucs systématiquement, au risque que
tu n'en aies jamais besoin.
La seconde n'installe que ce que tu lui demandes (et encore, ça a un peu
changé depuis les débuts).

Donc, si tu n'as pas installé le codec qui va bien sous Debian, ben il
ne te l'installeras pas tout seul surtout si c'est un truc considéré
comme non-free et que tu n'as pas activé ce dépôt.



en fait tout est installé. Il y a un problème dans une librairie,
libavformat.so.53, qui apparemment devrait exporter le symbole
lame_set_VBR_quality et qui ne l'exporte pas. Je ne comprends pas car
apparemment tout est à jour.

--
Laurent
lifeishard
Le #24066701
On Sun, 04 Dec 2011 20:05:50 +0100, essomba84 wrote:

en fait tout est installé. Il y a un problème dans une librairie,
libavformat.so.53, qui apparemment devrait exporter le symbole
lame_set_VBR_quality et qui ne l'exporte pas. Je ne comprends pas car
apparemment tout est à jour.



+1, VLC ne lit pas le mp4 et en plus Firefox et Totem ne s'entendent
pas avec lui pour la lecture du flash: freeze image et coupure du son.

Essaye DragonPlayer, multithread à l'infini même avec Firefox qui
s'accapare l'exclusivité du process flash, ABUSE.

Mais Dragon ne fait QUE la lecture de fichiers.

J'ai aucune solution pour VLC sauf que moi aussi j'ai trop cherché, et
la prochaine fois je ne me donnerai pas cette peine: ça fonctionne ou
ça ne fonctionne pas, si ça ne marche pas alors que ça devrait ..
c'est la benne.

Tu peux certainement te passer de VLC, il faut pas rester sur des
idées fixes. T'as bien réussi à te passer de Windows ...

C'est comme NVidia sous Ubuntu c'est un merdier _ou_(quand ça
fonctionne) c'est pas aboutis c'est tout pourris c'est bridé OU c'est
buggé, la solution c'est Debian et encore mieux, SID, parce que benner
une Nvidia .. ça, ça .. ça ça ne se fait pas.

VLC on s'en foot ...
Tonton Th
Le #24066771
On 12/13/2011 11:53 PM, lifeishard wrote:

la solution c'est Debian et encore mieux, SID,



Fait gaffe, ya des upgrades de 500Mo !

--

Nous vivons dans un monde étrange/
http://foo.bar.quux.over-blog.com/
Eric Jacoboni
Le #24066971
Le 13/12/2011 23:53, lifeishard a écrit :

+1, VLC ne lit pas le mp4



Sur Debian SID... parce qu'il les lit très bien avec d'autres
distributions...
lifeishard
Le #24069571
On Wed, 14 Dec 2011 01:24:40 +0100, Eric Jacoboni

Le 13/12/2011 23:53, lifeishard a écrit :

+1, VLC ne lit pas le mp4



Sur Debian SID... parce qu'il les lit très bien avec d'autres
distributions...



ah ok, j'ai vite remplacé la squeeze par la sid alors
je-ne-sais-plus-trop.
Le plus surprenant c'est ce process flash(flv) qui se fait manger le
canal son ou freeze et ça c'est du à vlc vs firefox - c'est là qu'on
benne l'un ou l'autre.
lifeishard
Le #24069721
On Wed, 14 Dec 2011 00:10:00 +0100, Tonton Th wrote:

On 12/13/2011 11:53 PM, lifeishard wrote:

la solution c'est Debian et encore mieux, SID,



Fait gaffe, ya des upgrades de 500Mo !



je l'avais sur le bout des doigts, ne l'ais-je pas déjà dit ...
c'est une folie, vivons heureux vivons dangereux(sement).

là j'ai 900 mégas de patch en attente .. donc il veut encore une fois
TOUT remplacer, GAG?

le pire c'est d'installer FROM SCRATCH, une seule fois dans ma vie
suffit merci./+/!

650 paquets touchés,
900 mégas à pomper, 30 à consacrer,
35 paquets passent à la trappe, amusant.
un autre jour ...

mais la seule chose qui m'inquiette encore c'est le hacking des
serveurs et l'espionnite aigüe, des plantages ou des ratages d'upgrade
j'en ai jamais eu.


cups-driver-gutenprint sera désinstallé
libepc-1.0-2 sera désinstallé
libepc-ui-1.0-2 sera désinstallé
libgail-3-common sera désinstallé
libgcr-3-0 sera désinstallé
libgnome-desktop-3-0 sera désinstallé
lzma sera désinstallé
accountsservice (version 0.6.15-1) sera mis à niveau vers la version
0.6.15-2
acl (version 2.2.51-4) sera mis à niveau vers la version 2.2.51-5
acpi-support-base (version 0.138-9) sera mis à niveau vers la version
0.138-10
aisleriot (version 1:3.0.2-2) sera mis à niveau vers la version
1:3.2.2-1
apache2.2-bin (version 2.2.21-2) sera mis à niveau vers la version
2.2.21-3
aptdaemon (version 0.31+bzr413-1.1) sera mis à niveau vers la version
0.43+bzr707-1
aqualung (version 0.9~beta11-1.1) sera mis à niveau vers la version
0.9~beta11-1.2
baobab (version 3.0.1-5) sera mis à niveau vers la version 3.2.1-2
base-passwd (version 3.5.23) sera mis à niveau vers la version 3.5.24
bash (version 4.1-3) sera mis à niveau vers la version 4.2-1
bind9-host (version 1:9.8.1.dfsg-1) sera mis à niveau vers la version
1:9.8.1.dfsg-1.1
binutils (version 2.21.90.20111025-1) sera mis à niveau vers la
version 2.22-2
brasero (version 3.0.0-4) sera mis à niveau vers la version 3.2.0-3
brasero-common (version 3.0.0-4) sera mis à niveau vers la version
3.2.0-3
bsd-mailx (version 8.1.2-0.20100314cvs-1) sera mis à niveau vers la
version 8.1.2-0.20111106cvs-1
bsdutils (version 1:2.19.1-5) sera mis à niveau vers la version
1:2.20.1-1
busybox (version 1:1.19.3-1) sera mis à niveau vers la version
1:1.19.3-4

[ ............. ]
jp willm
Le #24111331
Hello,

Le 04/12/2011 20:05, essomba84 a écrit :

Il y a un problème dans une librairie,
libavformat.so.53, qui apparemment devrait exporter le symbole
lame_set_VBR_quality et qui ne l'exporte pas. Je ne comprends pas car
apparemment tout est à jour.




En attendant que tu trouves la solution pour vlc, tu peux toujours
utiliser smplayer. c'est ce que j'ai fait il y a deux ans et je n'ai pas
été déçu.

--
jp willm
http://perso.orange.fr/willms/index.html
Publicité
Poster une réponse
Anonyme