Volume group "vg00" not found

Le
yann
Bonsoir,

C'est le message au boot que je vois après mdadm: no devices found
for /dev/md0

Ceci sur une sid fraîchement mise à jour (2.6.26-2) (sans que j'a=
i bien
vérifié le résultat).

Boot sur une clé rescuecd sans pb et je "vois" le miroir et le LVM sans
Pb.

Je viens aussi de découvrir qu'il y a une mini busybox au bout d'un
certain temps d'attente dans l'état décrit.
ALERT! /dev/mapper/vg00-root doesn't exist

Cette dernière donne comme indication un éventuel Pb de module da=
ns
initfs Bizarre

sous (initramfs)
mdadm --detail /dev/md0 ne donne rien (pas de md0)
lvscan non plus

Comment me sortir de là avant de vérifier si ma dernière sau=
vegarde est
opérationnelle ?

Le nom de rootfs aurait-il changé ?

Merci de vos pistes

Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
WakS
Le #19156121
yann a écrit :

Bonsoir,



Bonsoir,
C'est le message au boot que je vois après mdadm: no devices found
for /dev/md0



Ca ressemble à un module non-chargé
Ceci sur une sid fraîchement mise à jour (2.6.26-2) (sans que j'ai bien
vérifié le résultat).

Boot sur une clé rescuecd sans pb et je "vois" le miroir et le LVM sans
Pb.

Je viens aussi de découvrir qu'il y a une mini busybox au bout d'u n
certain temps d'attente dans l'état décrit.
ALERT! /dev/mapper/vg00-root doesn't exist



Ca semble normal puisque ton RAID n'est pas chargé, il est impossibl e de
monté tes LVM
Cette dernière donne comme indication un éventuel Pb de modul e dans
initfs... Bizarre

sous (initramfs)
mdadm --detail /dev/md0 ne donne rien (pas de md0)
lvscan non plus...

Comment me sortir de là avant de vérifier si ma dernière sauvegarde est
opérationnelle ?

Le nom de rootfs aurait-il changé ?
Merci de vos pistes...

Yann.






Soumis à validation des experts
Je te conseillerais de faire un update de ton initramfs,
1- boot sur ton rescuecd,
2- monte tes LVM
#mount /dev/mapper/vgX-volX /mnt/xxx, et ainsi de suite (ou un p'tit
mount -a pour les fénéant :D )
3- chroot toi à la racine de ton système
#chroot /mnt/xx
4- update ton /boot/initrd.img
#update-initramfs -u -k `uname -r`


WakS


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
yann
Le #19177851
Ben c'est pas fini !

J'ai une entrée sur le noyau précédent : 2.6.26-1. Je l'ai u tilisé et
la machine à booter sans Xorg, mais bon j'ai une sessiosn
Je lance un apt-get install --reinstall sur le paquet
linux-image-2.6.26-2-amd64 pas mieux avec la trace suivante

Dépaquetage de la mise à jour de linux-image-2.6.26-2-amd64 ...
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-2.6.26-2-amd64 Found
kernel: /vmlinuz-2.6.26-1-amd64 Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools
Paramétrage de linux-image-2.6.26-2-amd64 (2.6.26-15) ...
Running depmod.
Running mkinitramfs-kpkg.
Deprecation WARNING: use update-initramfs(8)
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
Not updating initrd symbolic links since we are being
updated/reinstalled (2.6.26-15 was configured last, according to dpkg)
Not updating image symbolic links since we are being
updated/reinstalled (2.6.26-15 was configured last, according to dpkg)
Running postinst hook script update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ...
found: /boot/grub/menu.lst Searching for splash image ... none found,
skipping ... Found kernel: /vmlinuz-2.6.26-2-amd64
Found kernel: /vmlinuz-2.6.26-1-amd64
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-toolsd'ouverte


Alors je suis passé brutal :

yan:~# update-initramfs -u -k 2.6.26-2-amd64
update-initramfs: Generating /boot/initrd.img-2.6.26-2-amd64
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.

Pas mieux au boot pas possible de démarrer => toujours pas
de /dev/md0...

Une nouvelle idée avant la réinstall de ce WE ?

Bonsoir
Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Alain Baeckeroot
Le #19178701
Le 23/04/2009 à 22:34, yann a écrit :
/etc/mdadm/mdadm.conf



quel est le contenu de /etc/mdadm/mdadm.conf ?

quels sont les odules chargés quand tu boot depuis
le rescuecd, et avec ton noyau ?

Alain

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
yann
Le #19181031
Le Fri, 24 Apr 2009 01:01:23 +0200,
Alain Baeckeroot
Le 23/04/2009 à 22:34, yann a écrit :
> /etc/mdadm/mdadm.conf

quel est le contenu de /etc/mdadm/mdadm.conf


Vide. Et cela fonctionnait "avant".
Il semble qu'avec le noyau 2.6.26-1 (et prédécesseurs), lors de l eur
installation disposait du "bon" module dans le initramfs et ensuite
effectuait une recherche sur les disques pour retrouver les "array".

Maintenant, s'il faut un mdadm.conf, comment le faire depuis une conf
qui tourne ?...
[..]
Alain



Yann.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Thierry B
Le #19183241
yann a écrit :
Le Fri, 24 Apr 2009 01:01:23 +0200,
Alain Baeckeroot
Le 23/04/2009 à 22:34, yann a écrit :
/etc/mdadm/mdadm.conf


quel est le contenu de /etc/mdadm/mdadm.conf


Vide. Et cela fonctionnait "avant".
Il semble qu'avec le noyau 2.6.26-1 (et prédécesseurs), lors de leur
installation disposait du "bon" module dans le initramfs et ensuite
effectuait une recherche sur les disques pour retrouver les "array".

Maintenant, s'il faut un mdadm.conf, comment le faire depuis une conf
qui tourne ?...
[..]
Alain



Yann.




Hello,

Essaie avec ce tuto là :
http://www.noisette.ch/wiki/index.php/Mdadm#.28R.C3.A9.29Assemblage

Si vous démarrez d'un live CD, il faut charger le module (raid1 par
exemple) :

Citations du tuto :

modprobe raid1
(cd dev && MAKEDEV md) (ce qu'il y a entre parenthèse c'est seulement si
les devices /dev/mdx n'existent pas.

(Ré)Assemblage

Une fois le RAID créé et des données dessus, on ne veut plus
nécessairement le reformater et le recréer quand on l'a démonté. La
solution sera donc de le réassemblé avec mdadm.

La première étape conciste à examiner une partition pour contrôler si
elle fait bien partie d'un RAID (pour ceux qui on une mauvaise mémoire à
très court terme) :

mdadm --examine /dev/sda1

La sortie nous dit si oui ou non la partition fait partie d'un RAID, et
si oui quels autres disques en font aussi partie. Une fois en possession
de ces informations, il nous reste à assembler l'ARRAY :

mdadm --assemble /dev/md1 /dev/sda1 /dev/sdb1
mdadm --assemble /dev/md3 /dev/sda3 /dev/sdb3
mdadm --assemble /dev/md4 /dev/sda4 /dev/sdb4

--------------------------------------------------------------------------

Si tu arrives à réassembler ton raid, tu pourras écrire la config dans
le mdadm.conf souhaité :

mdadm --detail --scan >> /etc/mdadm.conf

Après, une fois le raid construit, tu pourras essayer de refaire marcher
LVM sur ton PV qui est un volume raid, si j'ai bien compris.

Bon courage.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme