[W11] Utilisation de compile

Le
Arno
Bonjour,

J'ai créé une fonction locale sous Windev, cette fonction retourne un
booléen et prend en entrée une source de données comme paramètre.

Je souhaite externaliser cette fonction en la positionnant dans un fichier
texte de façon à faire de la compilation dynamique avec Compile.

J'ai essayé comme la doc, sans résultat probant.

Quelqu'un a-t-il déjà réussi ce genre de compile ?

Merci pour vos informations.

Arno
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #14573031
Dans son message précédent, Arno a écrit :
Bonjour,



Bonsoir,

J'ai créé une fonction locale sous Windev, cette fonction retourne un
booléen et prend en entrée une source de données comme paramètre.
Je souhaite externaliser cette fonction en la positionnant dans un fichier
texte de façon à faire de la compilation dynamique avec Compile.
J'ai essayé comme la doc, sans résultat probant.
Quelqu'un a-t-il déjà réussi ce genre de compile ?



Essaye de voir ce que donne éventuellement une exception (voir le code en 7.5 ci dessous)

sCompil est une chaîne
sRes, sResCompil est une chaîne
bResCompil est un booléen = Faux
//on recharge à chaque traitement...
sCompil = fChargeTexte("C:Monfichier.txt")
SI sCompil~="" ALORS sCompil="RENVOYER 0"//A traiter

sCompil = "QUAND EXCEPTION"+RC+...
" RENVOYER exceptioninfo(errMessage)+RC+exceptionInfo(errcode) "+RC+...
"FIN"+RC+...
sCompil
sRes=Compile("fl_compildyn",sCompil)
SI sRes<>"" ALORS
SI sRes="ERR" ALORS
Erreur("Erreur code compilation :" + ErreurInfo(errMessage))
SINON
Erreur("Erreur code compilation :" + sRes)
FIN
SINON
bResCompil = Vrai
FIN

SI bResCompil ALORS
sResCompil=ExécuteTraitement("fl_compildyn",trtProcédure)
SI Val(sResCompil)= 0 ET sResCompil<>"0" ALORS
Erreur("Erreur compilation dynamique, résultat="+sResCompil)
SINON
//traiter le retour de la fonction dyn
SELON sResCompil
//blabla
FIN
FIN
FIN

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Romain PETIT
Le #14573021
Dans son message précédent, Arno a écrit :
Bonjour,



Bonsoir,

J'ai créé une fonction locale sous Windev, cette fonction retourne un
booléen et prend en entrée une source de données comme paramètre.
Je souhaite externaliser cette fonction en la positionnant dans un fichier
texte de façon à faire de la compilation dynamique avec Compile.
J'ai essayé comme la doc, sans résultat probant.
Quelqu'un a-t-il déjà réussi ce genre de compile ?



Essaye de voir ce que donne éventuellement une exception (voir le code
en 7.5 ci dessous)

sCompil est une chaîne
sRes, sResCompil est une chaîne
bResCompil est un booléen = Faux
//on recharge à chaque traitement...
sCompil = fChargeTexte("C:Monfichier.txt")
SI sCompil~="" ALORS sCompil="RENVOYER 0"//A traiter

sCompil = "QUAND EXCEPTION"+RC+...
" RENVOYER exceptioninfo(errMessage)+RC+exceptionInfo(errcode) "+RC+...
"FIN"+RC+...
sCompil
sRes=Compile("fl_compildyn",sCompil)
SI sRes<>"" ALORS
SI sRes="ERR" ALORS
Erreur("Erreur code compilation :" + ErreurInfo(errMessage))
SINON
Erreur("Erreur code compilation :" + sRes)
FIN
SINON
bResCompil = Vrai
FIN

SI bResCompil ALORS
sResCompil=ExécuteTraitement("fl_compildyn",trtProcédure)
//traiter le retour de la fonction dyn
SELON sResCompil
//blabla
FIN
FIN

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Publicité
Poster une réponse
Anonyme