[WD10]Pb EmailEnvoieMessage

Le
Serein
Bonjour,

Suite à un plantage, j'ai dû réinstaller une appli qui fonctionnait
bien; depuis, je ne peux plus envoyer de mails

En effet, j'obtiens l'erreur suivante :
"Session SMTP: la transaction est refusée. Vérifiez le contenu des
variables Email.Expéditeur et Email.Destinataire[]"

Quelques précisions :
- tout marchait bien avant le plantage, et marche encore bien chez moi,
- les PC sont sous XP,
- les mails partent et arrivent bien avec Outlook (le gros, pas l'express),
- et bien sur les deux adresses évoquées dans le message sont correctes.

Merci par avance de vos idées ou de vos expériences en la matière

Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tjfromparis
Le #19122291
On 5 avr, 10:08, Serein
Bonjour,

Suite à un plantage, j'ai dû réinstaller une appli qui fonctionnait
bien; depuis, je ne peux plus envoyer de mails...


il faut pas autoriser quelque chose sur le serveur exchange ?
(blocage suite à un windows update auto sur le serveur exchange, un
service pack , un correctif)

t'as essayé de faire la meme chose directement depuis visual studio
pour verifier que tu as le meme pb avec une autre techno (si ca marche
pas avec MS ...)

j'ai eu un pb similaire :
j'ai fais un composant qui manipule l'assembly mail (si y'a une
erreur .NET (le truc qui fait 3 pages) ca pete tranquille dans le
composant sans gener l'appli principale)
d'ailleurs si vous savez comment on intercepte l'equivalent de
ex.message en windev je suis preneur




En effet, j'obtiens l'erreur suivante :
"Session SMTP: la transaction est refusée. Vérifiez le contenu des
variables Email.Expéditeur et Email.Destinataire[]"

Quelques précisions :
- tout marchait bien avant le plantage, et marche encore bien chez moi,
- les PC sont sous XP,
- les mails partent et arrivent bien avec Outlook (le gros, pas l'express ),
- et bien sur les deux adresses évoquées dans le message sont correct es.

Merci par avance de vos idées ou de vos expériences en la matière.. .

Philippe


Serein
Le #19140771
Merci de ta réponse,

Non, je n'ai pas essayé avec autre chose que Windev... parce qu'avant ça
marchait, donc je me suis un peu entêté.

Je vais essayer pour voir.

Mais ton idée de blocage me parait judicieuse, le serveur Exchange a été
réinstallé récemment et finalement c'est peut-être depuis ce moment là
que cette appli ne fonctionne plus...

Merci encore

Philippe

a écrit :
On 5 avr, 10:08, Serein
Bonjour,

Suite à un plantage, j'ai dû réinstaller une appli qui fonctionnait
bien; depuis, je ne peux plus envoyer de mails...


il faut pas autoriser quelque chose sur le serveur exchange ?
(blocage suite à un windows update auto sur le serveur exchange, un
service pack , un correctif)

t'as essayé de faire la meme chose directement depuis visual studio
pour verifier que tu as le meme pb avec une autre techno (si ca marche
pas avec MS ...)

j'ai eu un pb similaire :
j'ai fais un composant qui manipule l'assembly mail (si y'a une
erreur .NET (le truc qui fait 3 pages) ca pete tranquille dans le
composant sans gener l'appli principale)
d'ailleurs si vous savez comment on intercepte l'equivalent de
ex.message en windev je suis preneur



En effet, j'obtiens l'erreur suivante :
"Session SMTP: la transaction est refusée. Vérifiez le contenu des
variables Email.Expéditeur et Email.Destinataire[]"

Quelques précisions :
- tout marchait bien avant le plantage, et marche encore bien chez moi,
- les PC sont sous XP,
- les mails partent et arrivent bien avec Outlook (le gros, pas l'express),
- et bien sur les deux adresses évoquées dans le message sont correctes.

Merci par avance de vos idées ou de vos expériences en la matière...

Philippe





Publicité
Poster une réponse
Anonyme