WD12 55n - erreur 73001

Le
I.G.LOG
Bonjour,

J'utilise l'accès natif MySQL sur une base 4.1. Hier j'ai effectué un
traitement qui a parfaitement fonctionné. Aujourd'hui je veux relancer ce
traitement, IDENTIQUE puisque je n'ai fait aucune modif dans le code, et
j'ai une erreur 73001 sur un HAjoute().

Voici le code:
lCond = "select IDCONDITV,MESSAGE from conditv where IDTRADUC = 0"
SI SQLExec(lCond,"Req") ALORS
TANTQUE SQLFetch("Req") = 0
Traduc.ABRLANGUE = "FR" // char(2)
Traduc.MESSAGE = SQLLitCol("Req",2) // longtext
SI HAjoute(Traduc) ALORS // Ne fonctionne plus ?!
lCond = "update conditv set IDTRADUC = " + Traduc.IDTRADUC + " where
IDCONDITV = " + SQLLitCol("Req",1)
SQLExec(lCond,"Req2")
SQLFerme("Req2")
SINON
Erreur("conditv : " + HErreur()) // Erreur 73001 ????
FIN
FIN
FIN
SQLFerme("Req")

Merci de me donner vos idées je dois rendre ma copie demain sans faute
Bon dev
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
I.G.LOG
Le #16380531
J'ai trouvé: après une restauration, la structure de la base avait changé
(ai mis en évidence ce pb avec HErreurInfo() plutot que HErreur()). Après
mise à niveau de la structure, plus de probleme.
Merci à tous
Publicité
Poster une réponse
Anonyme