[WD16] Affichage icone aprés génération du .exe

Le
Lemele kévin
Bonjour,

Aprés la création de l'exécutable sur Windev16, j'ai remarqué que
l'image d'icône que j'avais préalablement défini n'apparait pas sur
l'exe. J'ai essayé avec 3 icones (au format .ico) de différents formats
16*16; 32*32 et 48*48 les trois avec une profondeur de oculeur de 32.
Pourtant lorsque j'essaye avec l'ancienne icone (32*32 et profondeur
32) du programme, aucun problème n'est rencontré, l'image du .exe est
bien celle de l'icône.

Je ne vois pas d'ou pourrais venir le problème.
Si vous avez une solution à me proposer, je suis preneur.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
André STASZEWSKI
Le #24016791
Bonjour,

Aprés la création de l'exécutable sur Windev16, j'ai remarqué que l'image
d'icône que j'avais préalablement défini n'apparait pas sur l'exe. J'ai
essayé avec 3 icones (au format .ico) de différents formats 16*16; 32*32 et
48*48 les trois avec une profondeur de oculeur de 32.
Pourtant lorsque j'essaye avec l'ancienne icone (32*32 et profondeur 32) du
programme, aucun problème n'est rencontré, l'image du .exe est bien celle de
l'icône.

Je ne vois pas d'ou pourrais venir le problème.
Si vous avez une solution à me proposer, je suis preneur.



bonsoir,

L'icone défini se trouve bien dans le répertoire du projet ?
En renommant le nouvel icone avec le même nom que celui qui
fonctionnait auparavant ça donne quoi ?
Le nouvel icone a été créé par quel outil ?
La case "recompiler le projet avant de créer l'exe" est bien cochée
dans l'assistant de création de l'exe ?

--
Cordialement,
André STASZEWSKI
http://www.SoftSolution.fr
Pour me contacter, cliquez ici :
http://cerbermail.com/?Z8IP9sIahR
Stef BEAUSUROY
Le #24017371
Bonjour.

J'ai eu un problème similaire sous Windows7 à cause des versions
précédentes. Windows7 garde en mémoire les anciennes versions avec le s
anciennes icônes, et on a beaucoup de mal à supprimer ces anciennes
versions pour avoir les nouvelles icônes ...
Lemele kévin
Le #24017751
Le 29/11/2011, André STASZEWSKI a supposé :
Bonjour,

Aprés la création de l'exécutable sur Windev16, j'ai remarqué que l'image
d'icône que j'avais préalablement défini n'apparait pas sur l'exe. J'ai
essayé avec 3 icones (au format .ico) de différents formats 16*16; 32*32 et
48*48 les trois avec une profondeur de oculeur de 32.
Pourtant lorsque j'essaye avec l'ancienne icone (32*32 et profondeur 32) du
programme, aucun problème n'est rencontré, l'image du .exe est bien celle
de l'icône.

Je ne vois pas d'ou pourrais venir le problème.
Si vous avez une solution à me proposer, je suis preneur.



bonsoir,

L'icone défini se trouve bien dans le répertoire du projet ?
En renommant le nouvel icone avec le même nom que celui qui fonctionnait
auparavant ça donne quoi ?
Le nouvel icone a été créé par quel outil ?
La case "recompiler le projet avant de créer l'exe" est bien cochée dans
l'assistant de création de l'exe ?



Bonjour,

Oui l'icône se trouve bien dans le répertoire du projet, je n'ai pas
essayé de renommer l'icône avec le même nom qu'auparavant par contre en
renommant le ".exe" avec un nom différent l'icône souhaité apparaît.
J'ai crée l'icône avec ToYcon
Oui la case recompiler est bien coché pendant la génération du ".exe".

J'ai effectué une nouvelle génération du ".exe", en renommant le
fichier ".wdl" lors de la "Mise en bibliothèque" (étape 3.2) et
maintenant en générant l'exe, en gardant le même nom pour le ".exe", et
avec ma nouvelle image d'icone, je vois apparaître (sous Windows 7) :
-l'image de l'ancienne icone sur l'exe en affichage des icônes moyennes
-sinon je vois la bonne icône sous les autres affichages.

Et lorsque je "Crée la prodécure d'installation de l'éxécutable"
et que j'installe (sur ce poste ou un autre), je vois la bonne icône
sur le ".exe".

Peut être que le renommage du ".wdl" a résolu mon problème ou cela est
du à un bug windows 7 comme le cite M.Beausuroy.
André STASZEWSKI
Le #24019311
Le 29/11/2011, André STASZEWSKI a supposé :
Bonjour,

Aprés la création de l'exécutable sur Windev16, j'ai remarqué que l'image
d'icône que j'avais préalablement défini n'apparait pas sur l'exe. J'ai
essayé avec 3 icones (au format .ico) de différents formats 16*16; 32*32
et 48*48 les trois avec une profondeur de oculeur de 32.
Pourtant lorsque j'essaye avec l'ancienne icone (32*32 et profondeur 32)
du programme, aucun problème n'est rencontré, l'image du .exe est bien
celle de l'icône.

Je ne vois pas d'ou pourrais venir le problème.
Si vous avez une solution à me proposer, je suis preneur.



bonsoir,

L'icone défini se trouve bien dans le répertoire du projet ?
En renommant le nouvel icone avec le même nom que celui qui fonctionnait
auparavant ça donne quoi ?
Le nouvel icone a été créé par quel outil ?
La case "recompiler le projet avant de créer l'exe" est bien cochée dans
l'assistant de création de l'exe ?



Bonjour,

Oui l'icône se trouve bien dans le répertoire du projet, je n'ai pas essayé
de renommer l'icône avec le même nom qu'auparavant par contre en renommant le
".exe" avec un nom différent l'icône souhaité apparaît.
J'ai crée l'icône avec ToYcon
Oui la case recompiler est bien coché pendant la génération du ".exe".

J'ai effectué une nouvelle génération du ".exe", en renommant le fichier
".wdl" lors de la "Mise en bibliothèque" (étape 3.2) et maintenant en
générant l'exe, en gardant le même nom pour le ".exe", et avec ma nouvelle
image d'icone, je vois apparaître (sous Windows 7) :
-l'image de l'ancienne icone sur l'exe en affichage des icônes moyennes
-sinon je vois la bonne icône sous les autres affichages.

Et lorsque je "Crée la prodécure d'installation de l'éxécutable"
et que j'installe (sur ce poste ou un autre), je vois la bonne icône sur le
".exe".

Peut être que le renommage du ".wdl" a résolu mon problème ou cela est du à
un bug windows 7 comme le cite M.Beausuroy.



Bizarre...
Bon l'important c'est que ça marche ! n'est ce pas ?

--
Cordialement,
André STASZEWSKI
http://www.SoftSolution.fr
Pour me contacter, cliquez ici :
http://cerbermail.com/?Z8IP9sIahR
Publicité
Poster une réponse
Anonyme