[WD8] Messages mutilangues

Le
Real Phil
Bonjour,

Après avoir entré un nouveau message mutilangue (CTRL+T) il arrive parfois
qu'en exécution le message (en fait le message dans chaque langue) apparaît
totalement vide. On revient dans le code et il est bien visible. On
recompile, on va re-créer un exécutable mais rien ne règle le problème.

Un truc qui fonctionne quelques fois, est d'exécuter « Code, Messages
multilangues, Rechercher les messages inutilisés » mais c'est rare.

La plupart du temps, à force de faire des tentatives diverses le message
finit par disparaître dans le code. Alors on entre à nouveau le message

Quelqu'un connaît un truc pour régler cette situation ?

Merci à l'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #14515571
Real Phil a émis l'idée suivante :
Bonjour,



Bonjour,

Quelqu'un connaît un truc pour régler cette situation ?



J'ai eu de gros problèmes en 7.5 avec des mélanges de messages issus
collections de procédures avec ceux du projet ou d'autres
collections...
(ils ont le même identifiants !)
Vérifie que tes messages ne sont pas dispersés à divers endroits.
J'ai résolu le problème en faisant en sorte que les ID des messtraduits
ne se chevauchent pas pour ce type d'éléments (pour les fenetres ca
marche)...
La synthaxe <Résultat> = MessTraduit(<Élément>, <Numéro de message>)
est bugguée en 7.5 pour les collections de procédures.


Ce serait à refaire, je crois que je gérerais moi-même les messages en
externe.

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Bruno Wrk
Le #14515561
Le 25/04/2008, Romain PETIT a supposé :
Real Phil a émis l'idée suivante :
Bonjour,



Bonjour,

Quelqu'un connaît un truc pour régler cette situation ?



J'ai eu de gros problèmes en 7.5 avec des mélanges de messages issus
collections de procédures avec ceux du projet ou d'autres collections...
(ils ont le même identifiants !)
Vérifie que tes messages ne sont pas dispersés à divers endroits.
J'ai résolu le problème en faisant en sorte que les ID des messtraduits ne se
chevauchent pas pour ce type d'éléments (pour les fenetres ca marche)...
La synthaxe <Résultat> = MessTraduit(<Élément>, <Numéro de message>) est
bugguée en 7.5 pour les collections de procédures.


Ce serait à refaire, je crois que je gérerais moi-même les messages en
externe.

A+



Quand on a le temps pour une grosse application, je crois que c'est de
toute façon toujours l'idéal, souplesse, efficacité.
Romain PETIT
Le #14515551
Bruno Wrk avait énoncé :
Quand on a le temps pour une grosse application, je crois que c'est de toute
façon toujours l'idéal, souplesse, efficacité.



Remarque, même si on commence avec les MessTraduit, on peut toujours
rattraper le coup en surchargeant la fonction et en gérant
soit-même....

A+

--
Romain PETIT
http://cerbermail.com/?O16kfXOFcq
(cliquez sur le lien ci-dessus pour me contacter en privé)
Publicité
Poster une réponse
Anonyme