webcam marche sur un pc, pas sur l'autre

Le
Vincent Gay
Bonjour,

je suis sous lenny, noyau 2.6.21 compilé maison et dispose d'une webcam=

à 3 sous dont je n'ai pas l'usage : elle fonctionne avec le module gspc=
a
compilé avec module-assistant. Quand je la branche elle est
automatiquement détectée (hal je suppose) et le module est monté=


gspca 643856 0
videodev 26304 1 gspca
usbcore 123400 9
snd_usb_audio,snd_usb_lib,gspca,usblp,usbhid,usb_storage,ehci_hcd,uhci_hc=
d

un devide /dev/video0 est ajouté

flanker@flanker:~$ ls -al /dev/video0
crw-rw- 1 root video 81, 0 2007-09-27 13:02 /dev/video0

bref tout baigne

je souhaite donner cette webcam à ma fille qui estsous etch noyau
2.6.18-5. J'ai installé le module comme précédemment avec
module-assistant, mais quand je branche la webcam le module ne monte pas =

et pas de /dev/video0

/var/log/messages me dit

Sep 27 12:53:23 Antonio kernel: ohci_hcd 0000:00:03.1: wakeup
Sep 27 12:53:23 Antonio kernel: usb 2-3: new full speed USB device using =

ohci_hcd and address 2
Sep 27 12:53:23 Antonio kernel: usb 2-3: configuration #1 chosen from 1
choice
Sep 27 12:53:23 Antonio kernel: usbcore: registered new driver snd-usb-au=
dio

si je fait un modprobe gspa le module s'installe sans problème

gspca 599280 0
videodev 21120 1 gspca
usbcore 112644 6
gspca,snd_usb_audio,snd_usb_lib,ehci_hcd,ohci_hcd

mais toujours pas de /dev/video

/var/log/messages me dit

Sep 27 12:57:27 Antonio kernel: Linux video capture interface: v2.00
Sep 27 12:57:27 Antonio kernel: usbcore: registered new driver gspca
Sep 27 12:57:27 Antonio kernel: /usr/src/modules/gspca/gspca_core.c:
gspca driver 01.00.04 registered

Ma gosse part pour 1 an en Angleterre le 30 septembre, il me reste donc
2 jours pour résoudre le truc. Autant dire que toute aide serait
grandement appréciée

Merci d'avance

--
Vincent Gay - mailto:vgay@salug-fr.org
"Ouvrir une école, c'est fermer une prison" (Victor Hugo)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
julien
Le #9607521
Vincent Gay a écrit :
Bonjour,

je suis sous lenny, noyau 2.6.21 compilé maison et dispose d'une webcam
à 3 sous dont je n'ai pas l'usage : elle fonctionne avec le module gspca
compilé avec module-assistant. Quand je la branche elle est
automatiquement détectée (hal je suppose...) et le module est monté

gspca 643856 0
videodev 26304 1 gspca
usbcore 123400 9
snd_usb_audio,snd_usb_lib,gspca,usblp,usbhid,usb_storage,ehci_hcd,uhci_hcd

un devide /dev/video0 est ajouté

:~$ ls -al /dev/video0
crw-rw---- 1 root video 81, 0 2007-09-27 13:02 /dev/video0

bref tout baigne

je souhaite donner cette webcam à ma fille qui estsous etch noyau
2.6.18-5. J'ai installé le module comme précédemment avec
module-assistant, mais quand je branche la webcam le module ne monte pas
et pas de /dev/video0

/var/log/messages me dit

Sep 27 12:53:23 Antonio kernel: ohci_hcd 0000:00:03.1: wakeup
Sep 27 12:53:23 Antonio kernel: usb 2-3: new full speed USB device using
ohci_hcd and address 2
Sep 27 12:53:23 Antonio kernel: usb 2-3: configuration #1 chosen from 1
choice
Sep 27 12:53:23 Antonio kernel: usbcore: registered new driver
snd-usb-audio

si je fait un modprobe gspa le module s'installe sans problème

gspca 599280 0
videodev 21120 1 gspca
usbcore 112644 6
gspca,snd_usb_audio,snd_usb_lib,ehci_hcd,ohci_hcd

mais toujours pas de /dev/video

/var/log/messages me dit

Sep 27 12:57:27 Antonio kernel: Linux video capture interface: v2.00
Sep 27 12:57:27 Antonio kernel: usbcore: registered new driver gspca
Sep 27 12:57:27 Antonio kernel: /usr/src/modules/gspca/gspca_core.c:
gspca driver 01.00.04 registered

Ma gosse part pour 1 an en Angleterre le 30 septembre, il me reste donc
2 jours pour résoudre le truc. Autant dire que toute aide serait
grandement appréciée


C'est un peu brutal mais pouquoi ne pas passer l'ordinateur de ta fille
sous Lenny (sans recompilation particulière de noyau) ?
L'avantage, c'est qu'elle aurait un noyau 2.6.21.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Gay
Le #9607511
julien a écrit :
C'est un peu brutal mais pouquoi ne pas passer l'ordinateur de ta
fille sous Lenny (sans recompilation particulière de noyau) ?
L'avantage, c'est qu'elle aurait un noyau 2.6.21.


Si j'étais sûr que c'est la solution je n'hésiterai pas. Je peux au ssi
lui compiler un 2.6.21 mais est-là le problème ?

Meci

Vincent
Vincent Gay
Le #9607451
julien a écrit :
C'est un peu brutal mais pouquoi ne pas passer l'ordinateur de ta
fille sous Lenny (sans recompilation particulière de noyau) ?
L'avantage, c'est qu'elle aurait un noyau 2.6.21.




J'ai installé un 2.6.22 de backports, sans effet
Jean-Michel OLTRA
Le #9607191
Bonjour,


Le jeudi 27 septembre 2007, Vincent Gay a écrit...


je suis sous lenny, noyau 2.6.21 compilé maison et dispose d'une webcam
à 3 sous dont je n'ai pas l'usage : elle fonctionne avec le module gspca
compilé avec module-assistant. Quand je la branche elle est
automatiquement détectée (hal je suppose...) et le module est monté



Tu as utilisé les même sources que pour ton 2.6.21 ? Tu peux utiliser
des sources « inférieures » ? (Problème d'api ?)

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.affaires-en-ligne.com



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
julien
Le #9607181
Vincent Gay a écrit :
julien a écrit :
C'est un peu brutal mais pouquoi ne pas passer l'ordinateur de ta
fille sous Lenny (sans recompilation particulière de noyau) ?
L'avantage, c'est qu'elle aurait un noyau 2.6.21.


Si j'étais sûr que c'est la solution je n'hésiterai pas. Je peux aussi
lui compiler un 2.6.21 mais est-là le problème ?



L'avantage de Lenny, c'est que tu as non seulement un noyau plus à jour
mais aussi une version de udev, hal et du modules gspca plus à jour.

Concernant une compilation customisée du noyau, était ce nécessaire pour
ton pc ou c'est juste à des fins d'optimisation ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Vincent Gay
Le #9607161
Jean-Michel OLTRA a écrit :
Bonjour,


Le jeudi 27 septembre 2007, Vincent Gay a écrit...



je suis sous lenny, noyau 2.6.21 compilé maison et dispose d'une webcam
à 3 sous dont je n'ai pas l'usage : elle fonctionne avec le modul e gspca
compilé avec module-assistant. Quand je la branche elle est
automatiquement détectée (hal je suppose...) et le module es t monté




Tu as utilisé les même sources que pour ton 2.6.21 ? Tu peux utiliser
des sources « inférieures » ? (Problème d'api ?)




non, j'ai utilisé le deb gspca-source donc l'un de lenny l'autre de
etch. Je n'ai pas vérifié les versions.

Ceci-dit vu le peu de délai j'ai arrêté de me prendre la t ête et j'ai
récupéré une vieille quickcam messenger au pilote un peu t ordu mais qui
marche (sauf pour le son). Et à ma grande surprise l'image est nette ment
meilleure. Renseignements pris sur le web il "paraît" que qspca c'es t un
peu de la m....

Merci en tous cas pour vos réponses
--
Vincent Gay - mailto:
"Ouvrir une école, c'est fermer une prison" (Victor Hugo)


P.S. désolé pour la réponse privée à Jean-Michel , je n'ai pas encore
pris le pli de cliquer sur "répondre à la liste"
Publicité
Poster une réponse
Anonyme