Wheezy Freeze sur Dedibox SC

Le
Jean Baptiste FAVRE
Hello,
J'ai un gros soucis avec Wheezy & les Dedibox SC depuis quelques semaines.

Tout fonctionnait parfaitement en Squeeze.
Il y a 3 semaines, je réalise l'upgrade d'une Dedibox vers Wheezy. À
partir de ce moment là, le serveur devient instable. Il freeze à
intervalles irréguliers. Pas moyen de reprendre la main dessus: plus
d'accès réeau, plus de ping, plus aucun services (mail) accessible.
Seule possibilité: reboot via la console Online.

J'ai demandé et obtenu un KVM. Lorsque le serveur est inaccessible,
pas moyen de réveiller la console.

Bien entendu, rien dans les logs.

J'ai installé le noyau de Jessie (3.10) en lieu et place du 3.2 de
Wheezy. Pas mieux

De guerre lasse, j'ai commandé un nouveau serveur en me disant que mon
install Squeeze était foireuse et que l'upgrade en Wheezy avait
introduit un comportement bizarre.
Ce dernier a fonctionné parfaitement pendant 3 semaines. Ce soir je
réalise la migration du serveur de mail après forces synchro des boites.

Et là, le drame: le nouveau serveur est lui aussi devenu instable.
Je ne comprends plus rien et ne vois pas comment m'en sortir.

Les Services actifs sur le serveur:
- Postfix
- Dspam avec le stockage fichiers
- Dovecot en configuration utilisateurs virtuels
- policy-spf
- opendkim
- policyd-weight
- milter-greylist
- clamav daemon

- prosody

- Nginx
- Munin (serveur)
- Smokeping

Je n'ai pas l'impression d'avoir trop chargé le serveur, d'autant que
tous ces services tournaient aupravant sous Squeeze sans soucis aucun

Je suis preneur de toutes les bonnes idées.

Cordialement,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/52363E67.2030003@jbfavre.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilles Mocellin
Le #25662752
Le 16/09/2013 01:10, Jean Baptiste FAVRE a écrit :
Hello,
J'ai un gros soucis avec Wheezy & les Dedibox SC depuis quelques semaines.

Tout fonctionnait parfaitement en Squeeze.
Il y a 3 semaines, je réalise l'upgrade d'une Dedibox vers Wheezy. À
partir de ce moment là, le serveur devient instable. Il freeze à
intervalles irréguliers. Pas moyen de reprendre la main dessus: plus
d'accès réeau, plus de ping, plus aucun services (mail) accessible.
Seule possibilité: reboot via la console Online.
[...]
Je suis preneur de toutes les bonnes idées.

Cordialement,
JB



Désolé, mais j'ai eu le même problème, insoluble.
On est pas les seuls :
http://forum.online.net/index.php?/topic/2344-dedibox-via-nano-et-debian/?hl=instable

De mon coté, j'étais sous Proxmox, et c'est apparu lors de ma migration
à la version 3.0, basée sur Wheezy.
*Mais*, avec un noyau Proxmox qui est basé sur RedHat !
Je pense donc que le problème n'est pas noyau, mais plutôt libc.
En tout cas, pour moi ça se déclenche sous forte charge réseau.

Ma solution, prendre un Kimsufi chez le concurrent, avec un proc Atom,
plus "standard". Pas de soucis avec.

J'ai gardé la dedibox, en mettant un seul container dessus pour tests,
et j'ai à nouveau eu un problème il n'y a pas longtemps...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean Baptiste Favre
Le #25663222
On 16/09/2013 01:38, Gilles Mocellin wrote:
Le 16/09/2013 01:10, Jean Baptiste FAVRE a écrit :
Hello,
J'ai un gros soucis avec Wheezy & les Dedibox SC depuis quelques
semaines.

Tout fonctionnait parfaitement en Squeeze.
Il y a 3 semaines, je réalise l'upgrade d'une Dedibox vers Wheezy. À
partir de ce moment là, le serveur devient instable. Il freeze à
intervalles irréguliers. Pas moyen de reprendre la main dessus: plus
d'accès réeau, plus de ping, plus aucun services (mail) accessible.
Seule possibilité: reboot via la console Online.
[...]
Je suis preneur de toutes les bonnes idées.

Cordialement,
JB



Désolé, mais j'ai eu le même problème, insoluble.
On est pas les seuls :
http://forum.online.net/index.php?/topic/2344-dedibox-via-nano-et-debian/?hl=instable


De mon coté, j'étais sous Proxmox, et c'est apparu lors de ma migration
à la version 3.0, basée sur Wheezy.
*Mais*, avec un noyau Proxmox qui est basé sur RedHat !
Je pense donc que le problème n'est pas noyau, mais plutôt libc.
En tout cas, pour moi ça se déclenche sous forte charge réseau.

Ma solution, prendre un Kimsufi chez le concurrent, avec un proc Atom,
plus "standard". Pas de soucis avec.

J'ai gardé la dedibox, en mettant un seul container dessus pour tests,
et j'ai à nouveau eu un problème il n'y a pas longtemps...




Hello,
Voilà qui n'est pas fait pour me rassurer :-/

Voici quelques liens qui pourraient expliquer le problème.
En résumé, tout serait lié au "CPU frequency scaling".
http://www.coreboot.org/Coreboot_Options
http://www.coreboot.org/pipermail/coreboot/2012-July/071078.html
http://permalink.gmane.org/gmane.linux.kernel.cpufreq/8088

J'ai vérifié, cpufreqd et cpufrequtils n'étaient pas installés chez moi,
mais la fréquence CPU était fixée à 800MHz pour un max à 1.6GHz

J'ai donc installé ces 2 paquets. Depuis, le CPU a "le choix" entre
1.6GHz et... 1.6GHz (parce que fonctionne sur secteur) :)

Je vais voir si ça tient. Pour le moment, les serveurs touchés n'ont
jamais tenu plus de 36h. On va donc voir s'ils en tiennent 72...

Sinon, une autre solution semble être de blacklister le module acpi_cpufreq.
Je testerai cette solution le cas échéant.

Cordialement,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gilles Mocellin
Le #25664202
Le 16/09/2013 11:43, Jean Baptiste Favre a écrit :
[...]

J'ai vérifié, cpufreqd et cpufrequtils n'étaient pas installés chez moi,
mais la fréquence CPU était fixée à 800MHz pour un max à 1.6GHz

J'ai donc installé ces 2 paquets. Depuis, le CPU a "le choix" entre
1.6GHz et... 1.6GHz (parce que fonctionne sur secteur) :)

Je vais voir si ça tient. Pour le moment, les serveurs touchés n'ont
jamais tenu plus de 36h. On va donc voir s'ils en tiennent 72...

Sinon, une autre solution semble être de blacklister le module acpi_cpufreq.
Je testerai cette solution le cas échéant.

Cordialement,
JB



Bizarre, je n'ai pas de module acpi_cpufreq de chargé, ni rien d'autre
concernant les fréquences.
Je vais essayer aussi avec cpufrequtils...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean Baptiste FAVRE
Le #25664692
Le 16/09/2013 20:00, Gilles Mocellin a écrit :
Le 16/09/2013 11:43, Jean Baptiste Favre a écrit :
[...]

J'ai vérifié, cpufreqd et cpufrequtils n'étaient pas installés
chez moi, mais la fréquence CPU était fixée à 800MHz pour un max
à 1.6GHz

J'ai donc installé ces 2 paquets. Depuis, le CPU a "le choix"
entre 1.6GHz et... 1.6GHz (parce que fonctionne sur secteur) :)

Je vais voir si ça tient. Pour le moment, les serveurs touchés
n'ont jamais tenu plus de 36h. On va donc voir s'ils en tiennent
72...

Sinon, une autre solution semble être de blacklister le module
acpi_cpufreq. Je testerai cette solution le cas échéant.

Cordialement, JB



Bizarre, je n'ai pas de module acpi_cpufreq de chargé, ni rien
d'autre concernant les fréquences. Je vais essayer aussi avec
cpufrequtils...



Bon, en fait, ça ne fonctionne pas mieux.
J'ai eu un petit espoir, mais ils ont été déçu en un peu plus de 12h

J'en arrive donc à essayer de blacklister le module acpi-cpufreq qui
semble être à l'origine de mes déboires, cf. les liens ci-dessus.

J'ai donc désinstallé les paquets cpufreqd et cpufrequtils, et ajouté
"blacklist acpi-cpufreq" dans /etc/modprobe.d/acpi-cpufreq.conf (j'ai
aussi essayé avec acpi_cpufreq).

Idem avec mperf qui utilise acpi-cpufreq (Source [1])

Sauf que, même après un depmod -ae -F /boot/System.map-3.2.0-4-amd64
suivi d'un update-initramfs -u et d'un reboot, le module est quand
même chargé.

J'ai essayé avec le fichier /etc/modprobe.d/blacklist.conf, même topo.

Un examen des logs de démarrage (dmesg) semble indiquer que le module
est chargé par udev.
Bon, là, sur un serveur remote, je ne suis pas chaud du tout pour me
lancer dans l'aventure. Donc, si quelqu'un connaît mieux (pas dur)
udev que moi, je suis preneur de ses conseils.

Je me donne jusqu'à la fin de la semaine pour trouver une solution.
Sinon, je prends un serveur avec un vrai CPU qui fonctionne et je
virtualise.

Cordialement,
JB

[1] https://wiki.debian.org/KernelModuleBlacklisting

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean Baptiste Favre
Le #25666092
On 16/09/2013 01:10, Jean Baptiste FAVRE wrote:
Hello,
J'ai un gros soucis avec Wheezy & les Dedibox SC depuis quelques semaines.

Tout fonctionnait parfaitement en Squeeze.
Il y a 3 semaines, je réalise l'upgrade d'une Dedibox vers Wheezy. À
partir de ce moment là, le serveur devient instable. Il freeze à
intervalles irréguliers. Pas moyen de reprendre la main dessus: plus
d'accès réeau, plus de ping, plus aucun services (mail) accessible.
Seule possibilité: reboot via la console Online.

J'ai demandé et obtenu un KVM. Lorsque le serveur est inaccessible,
pas moyen de réveiller la console.

Bien entendu, rien dans les logs.

J'ai installé le noyau de Jessie (3.10) en lieu et place du 3.2 de
Wheezy. Pas mieux

De guerre lasse, j'ai commandé un nouveau serveur en me disant que mon
install Squeeze était foireuse et que l'upgrade en Wheezy avait
introduit un comportement bizarre.
Ce dernier a fonctionné parfaitement pendant 3 semaines. Ce soir je
réalise la migration du serveur de mail après forces synchro des boites.

Et là, le drame: le nouveau serveur est lui aussi devenu instable.
Je ne comprends plus rien et ne vois pas comment m'en sortir.

Les Services actifs sur le serveur:
- Postfix
- Dspam avec le stockage fichiers
- Dovecot en configuration utilisateurs virtuels
- policy-spf
- opendkim
- policyd-weight
- milter-greylist
- clamav daemon

- prosody

- Nginx
- Munin (serveur)
- Smokeping

Je n'ai pas l'impression d'avoir trop chargé le serveur, d'autant que
tous ces services tournaient aupravant sous Squeeze sans soucis aucun

Je suis preneur de toutes les bonnes idées.

Cordialement,
JB




Hello,

Un problème de compatibilité entre les Dedibox SC & SC Gen2 et Debian
Wheezy a été confirmé par Online:

Le module acpi-cpufreq pose effectivement problème sur les Dedibox SC &
SC Gen2, sous Debian Wheezy en architecture 64 bits.

La solution est de blacklister le module acpi-cpufreq comme indiqué ici:
http://forum.online.net/index.php?/topic/3542-important-probl%C3%A8me-de-stabilit%C3%A9-sur-les-sc/

Je viens de mettre en place la solution sur un des deux serveurs impactés.
Wait & see,

Bonne journée,
JB

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme