wifi ipw2200

Le
fabrice régnier
salut la liste,

J'ai installé une wheezy sur un "vieux" PC Tablette Motion Computing
(2005). Tout fonctionne sauf le wifi.

lspci donne ça:
06:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG
[Calexico2] Network Connection (rev 05)
Subsystem: Intel Corporation Device 1001
Physical Slot: 1-1
Flags: bus master, medium devsel, latency 32, IRQ 23
Memory at b8001000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2
Kernel driver in use: ipw2200

Au niveau des modules, ça semble ok.
root@libre:~# lsmod | grep ipw
ipw2200 114618 0
libipw 26170 1 ipw2200
lib80211 12950 2 libipw,ipw2200
cfg80211 260313 2 libipw,ipw2200

root@libre:~# dmesg | grep ipw
[ 585.466997] libipw: 802.11 data/management/control stack, git-1.1.13
[ 585.467009] libipw: Copyright (C) 2004-2005 Intel Corporation
<jketreno@linux.intel.com>
[ 585.474484] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver,
1.2.2kmprq
[ 585.474496] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 585.475052] ipw2200: Detected Intel PRO/Wireless 2915ABG Network
Connection
[ 585.475555] ipw2200 0000:06:02.0: firmware: agent loaded
ipw2200-bss.fw into memory
[ 585.701724] ipw2200: Detected geography ZZE (13 802.11bg channels, 19
802.11a channels)

Donc à priori, le firmware est bien chargé. Mais quand je regarde
ifconfig, je ne vois pas d'interface wifi qui s'est créée.

root@libre:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:02:3f:fd:3e:b6
inet adr:172.25.56.34 Bcast:172.25.56.255 Masque:255.255.255.0
adr inet6: fe80::202:3fff:fefd:3eb6/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3980 errors:0 dropped:0 overruns:0 frame:0
TX packets:1507 errors:0 dropped:0 overruns:0 carrier:0
collisions:77 lg file transmission:1000
RX bytes:373897 (365.1 KiB) TX bytes:313011 (305.6 KiB)

lo Link encap:Boucle locale
etc.


J'ai donc raté quelque chose. Mais je ne vois pas quoi. Je ne vois rien
non plus dans les logs qui pourrait m'aiguiller. Vous avez des idées ?

Merki ;)

a+

f.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/52825af4$0$2272$426a74cc@news.free.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
nb
Le #25781922
Salut,

Essaye d'abord un ifconfig -a pour voir la liste des interfaces qui
existent.
Sans le "-a" tu ne verras pas celles qui ne sont pas "up"


Le 12-11-2013 17:49, fabrice régnier a écrit :
salut la liste,

J'ai installé une wheezy sur un "vieux" PC Tablette Motion Computing
(2005). Tout fonctionne sauf le wifi.

lspci donne ça:
06:02.0 Network controller: Intel Corporation PRO/Wireless 2915ABG
[Calexico2] Network Connection (rev 05)
Subsystem: Intel Corporation Device 1001
Physical Slot: 1-1
Flags: bus master, medium devsel, latency 32, IRQ 23
Memory at b8001000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2
Kernel driver in use: ipw2200

Au niveau des modules, ça semble ok.
:~# lsmod | grep ipw
ipw2200 114618 0
libipw 26170 1 ipw2200
lib80211 12950 2 libipw,ipw2200
cfg80211 260313 2 libipw,ipw2200

:~# dmesg | grep ipw
[ 585.466997] libipw: 802.11 data/management/control stack, git-1.1.13
[ 585.467009] libipw: Copyright (C) 2004-2005 Intel Corporation
[ 585.474484] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network
Driver, 1.2.2kmprq
[ 585.474496] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 585.475052] ipw2200: Detected Intel PRO/Wireless 2915ABG Network
Connection
[ 585.475555] ipw2200 0000:06:02.0: firmware: agent loaded
ipw2200-bss.fw into memory
[ 585.701724] ipw2200: Detected geography ZZE (13 802.11bg channels,
19 802.11a channels)

Donc à priori, le firmware est bien chargé. Mais quand je regarde
ifconfig, je ne vois pas d'interface wifi qui s'est créée.

:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:02:3f:fd:3e:b6
inet adr:172.25.56.34 Bcast:172.25.56.255
Masque:255.255.255.0
adr inet6: fe80::202:3fff:fefd:3eb6/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3980 errors:0 dropped:0 overruns:0 frame:0
TX packets:1507 errors:0 dropped:0 overruns:0 carrier:0
collisions:77 lg file transmission:1000
RX bytes:373897 (365.1 KiB) TX bytes:313011 (305.6 KiB)

lo Link encap:Boucle locale
etc....


J'ai donc raté quelque chose. Mais je ne vois pas quoi. Je ne vois
rien non plus dans les logs qui pourrait m'aiguiller. Vous avez des
idées ?

Merki ;)

a+

f.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #25782722
'soir,

Essaye d'abord un ifconfig -a pour voir la liste des interfaces qui
existent.


:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:02:3f:fd:3e:b6
inet adr:172.25.56.34 Bcast:172.25.56.255 Masque:255.255.255.0
adr inet6: fe80::202:3fff:fefd:3eb6/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22383 errors:0 dropped:0 overruns:0 frame:0
TX packets:1799 errors:0 dropped:0 overruns:0 carrier:0
collisions:77 lg file transmission:1000
RX bytes:2287004 (2.1 MiB) TX bytes:356429 (348.0 KiB)

eth1 Link encap:Ethernet HWaddr 00:13:ce:e0:43:cf
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Boucle locale

eth1 est un second port ethernet (que je ne parviens pas à faire
fonctionner d'ailleurs) fourni par le socle de la tablette.

donc, pas de trace de wlan ou autre wireless interface :(

peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?


f.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/5282c2c4$0$2390$
steve
Le #25782792
Le 13-11-2013, à 01:12:14 +0100, fabrice régnier a écrit :

'soir,

>Essaye d'abord un ifconfig -a pour voir la liste des interfaces qui
>existent.
:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:02:3f:fd:3e:b6
inet adr:172.25.56.34 Bcast:172.25.56.255 Masque:255.255.255.0
adr inet6: fe80::202:3fff:fefd:3eb6/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22383 errors:0 dropped:0 overruns:0 frame:0
TX packets:1799 errors:0 dropped:0 overruns:0 carrier:0
collisions:77 lg file transmission:1000
RX bytes:2287004 (2.1 MiB) TX bytes:356429 (348.0 KiB)

eth1 Link encap:Ethernet HWaddr 00:13:ce:e0:43:cf
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Boucle locale

eth1 est un second port ethernet (que je ne parviens pas à faire
fonctionner d'ailleurs) fourni par le socle de la tablette.

donc, pas de trace de wlan ou autre wireless interface :(

peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?




Que dit iwconfig ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #25782972
'jour,


peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?




Que dit iwconfig ?


Ah yes, on avance!

:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


merki!

f.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/52833479$0$2307$
nb
Le #25783192
Bonjour,

ipw2200 utilise des interfaces ethx, pas des wlanx.
J'ai pour ma part utilisé udev pour ce genre de choses.
Qu'as-tu dans le fichier /etc/udev/rules.d/70-persistent-net.rules ?
Est-ce que tu y trouves une ligne avec l'adresse mac de ton interface
wifi ?

Une bonne méthode consiste à y placer une ligne :
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="xx:xx:xx:xx:xx:xx", ATTR{dev_id}=="0x0",
ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"

xx:xx:xx:xx:xx:xx étant l'adresse mac de l'interface wifi
eth2 étant l'interface qui y sera affectée (puisque eth0 et eth1 sont
déjà pris)

Pour le reste, il faudra prévoir l'entrée eth2 dans
/etc/network/interfaces selon tes besoins.

nb


Le 13-11-2013 09:17, fabrice régnier a écrit :
'jour,


peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?




Que dit iwconfig ?


Ah yes, on avance!

:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


merki!

f.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
steve
Le #25783612
Le 13-11-2013, à 09:17:23 +0100, fabrice régnier a écrit :

>>peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?
>
>
> Que dit iwconfig ?
Ah yes, on avance!

:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Ton interface est prête à s'associer à un point d'accès et ensuite
obtenir une adresse IP. Essaie de le faire manuellement :

iwconfig eth1 essid ton_pa

etc... puis, lui donner une IP, par exemple :

ifconfig eth1 192.168.1.10 (ip qui dépend de la plage qu'offre ta box)

À ce stade, tu devrais pouvoir pinguer ta box.

Le reste est laissé comme exercice :)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #25786442
salut la liste,

Merci à François, Nb et Steve pour m'avoir mis sur la voix. Okokok, ils
m'ont tout fait ;)

J'ai modifié /etc/udev/rules.d/70-persistent-net.rules pour y insérer
les 2 interfaces ethernet et l'interface wifi.

Enfin, j'ai utiliser iwconfig pour faire l'association avec l'AP.

A bientôt,

f.


Le 13/11/2013 13:10, steve a écrit :
Le 13-11-2013, à 09:17:23 +0100, fabrice régnier a écrit :

peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?




Que dit iwconfig ?


Ah yes, on avance!

:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Ton interface est prête à s'associer à un point d'accès et ensuite
obtenir une adresse IP. Essaie de le faire manuellement :

iwconfig eth1 essid ton_pa

etc... puis, lui donner une IP, par exemple :

ifconfig eth1 192.168.1.10 (ip qui dépend de la plage qu'offre ta box)

À ce stade, tu devrais pouvoir pinguer ta box.

Le reste est laissé comme exercice :)




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/5284b1f7$0$2123$
nb
Le #25786832
Content que ça fonctionne.
Ceci dit, tu n'as pas besoin d'utiliser nomément iwconfig.
Je pense que Steve t'a demandé de l'utiliser pour vérifier quelles
interfaces wifi étaient présentes.
Sous Debian, il te faut ajouter des lignes du genre:

wireless-mode managed
wireless-essid le_ssid_qui_va_bien

et aussi pour les clés
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Dans wpa_supplicant.conf, il faut mettre les bonnes options que tu dois
connaître.

Dans /etc/network/interfaces au niveau des interfaces concernées. Ca
exécute les commendes iwconfig automatiquement.



Le 14-11-2013 12:25, fabrice régnier a écrit :
salut la liste,

Merci à François, Nb et Steve pour m'avoir mis sur la voix. Okokok,
ils m'ont tout fait ;)

J'ai modifié /etc/udev/rules.d/70-persistent-net.rules pour y insérer
les 2 interfaces ethernet et l'interface wifi.

Enfin, j'ai utiliser iwconfig pour faire l'association avec l'AP.

A bientôt,

f.


Le 13/11/2013 13:10, steve a écrit :
Le 13-11-2013, à 09:17:23 +0100, fabrice régnier a écrit :

peut-être s'agit d'un mélangeage de pinceau entre eth1 et wlan ?




Que dit iwconfig ?


Ah yes, on avance!

:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



Ton interface est prête à s'associer à un point d'accès et ensuite
obtenir une adresse IP. Essaie de le faire manuellement :

iwconfig eth1 essid ton_pa

etc... puis, lui donner une IP, par exemple :

ifconfig eth1 192.168.1.10 (ip qui dépend de la plage qu'offre ta
box)

À ce stade, tu devrais pouvoir pinguer ta box.

Le reste est laissé comme exercice :)






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
fabrice régnier
Le #25787012
'lut,

Je pense que Steve t'a demandé de l'utiliser pour vérifier quelles
interfaces wifi étaient présentes.


yes, j'avais bien entendu comme ça aussi.

Sous Debian, il te faut ajouter des lignes du genre:


[zap]
exécute les commendes iwconfig automatiquement.


En fait j'utilise network-manager donc /etc/network/interfaces...

Mon problème a été réglé par l'ajout des rêgles dans
70-persistent-net.rules. Ce qui a permis de fixer les noms des
interfaces aux

encore merci et a+

f.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/5284e950$0$2055$
Publicité
Poster une réponse
Anonyme