Windows Mail : mauvais codage

Le
Faelan
Bonjour !

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5 environ
(c'est aléatoire), les mails qui me parviennent de lui sont mal codés. Il y
a des caractères de contrôle comme é ou , etc, dans le texte du
message. Et dans ce cas, s'il y a une pièce jointe, elle est illisible. les
messages suivants sont corrects, jusqu'à ce que le problème se reproduise,
pour une raison inconnue.
Inutile de préciser qu'il ne change rien à la configuration : mais une fois
de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit.

Où chercher ?

J'utilise personnellement WM et je n'ai jamais eu ce problème.

Merci

--

F.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Luc
Le #1551356
Faelan a écrit...

Bonjour !


Bonjour,

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5
environ (c'est aléatoire), les mails qui me parviennent de lui sont
mal codés. Il y a des caractères de contrôle comme é ou ,
etc..., dans le texte du message. Et dans ce cas, s'il y a une pièce
jointe, elle est illisible. les messages suivants sont corrects,
jusqu'à ce que le problème se reproduise, pour une raison inconnue....
Inutile de préciser qu'il ne change rien à la configuration : mais
une fois de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit....

Où chercher ?


Vérifie dans 'Outils' --> 'Options' --> onglet 'Lecture' --> 'Paramètres
internationaux' --> que la case 'Utiliser le codage par défaut pour tous les
messages entrants' ne soit *PAS* cochée.

Si cette case est déjà décochée, il faudrait voir un de ces messages
problématique pour avoir des chances d'être plus précis sur les causes et
l'origine du problème.

J'utilise personnellement WM et je n'ai jamais eu ce problème.

Merci


Padkoi

--
Cordialement,

Luc Burnouf [MVP]
http://www.faqoe.com/

adresse de réponse invalide
pour me joindre --> http://www.mailfusible.com/?ag7Yk2DXNg

Faelan
Le #1551353
"Luc" news:
Faelan a écrit...

Bonjour !


Bonjour,

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5
environ (c'est aléatoire), les mails qui me parviennent de lui sont
mal codés. Il y a des caractères de contrôle comme é ou ,
etc..., dans le texte du message. Et dans ce cas, s'il y a une pièce
jointe, elle est illisible. les messages suivants sont corrects,
jusqu'à ce que le problème se reproduise, pour une raison inconnue....
Inutile de préciser qu'il ne change rien à la configuration : mais
une fois de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit....

Où chercher ?


Vérifie dans 'Outils' --> 'Options' --> onglet 'Lecture' --> 'Paramètres
internationaux' --> que la case 'Utiliser le codage par défaut pour tous
les messages entrants' ne soit *PAS* cochée.


Chez moi ?
Parce que chez lui, le problème se produit pour certains messages
sortants...
Ici, c'est effectivement décoché.

Si cette case est déjà décochée, il faudrait voir un de ces messages
problématique pour avoir des chances d'être plus précis sur les causes et
l'origine du problème.


Que faut-il de ces messages ? L'entête ?

Voici celle d'un message avec attache qui est correct (je n'ai repris que
les lignes ne contenant pas d'adresses...)

MIME-version: 1.0
Content-type: multipart/mixed;
boundary="Boundary_(ID_YfZU/Z0IZ/w0BKSEj+3xKA)"
X-Priority: 3
X-MSMail-priority: Normal
X-Mailer: Microsoft Windows Mail 6.0.6000.16480
X-MIMEOLE: Produced By Microsoft MimeOLE V6.0.6000.16545
X-UIDL: 000000000016bd0d.0000a738
X-MSP-STORE: Tue, 11 Mar 2008 15:44:45 +0100

Voici celle d'un message avec attache qui ne l'est pas.

MIME-version: 1.0
Content-type: TEXT/PLAIN; CHARSET=ISO-8859-1
X-Priority: 3
X-MSMail-priority: Normal
X-Mailer: Microsoft Windows Mail 6.0.6000.16480
X-RFC2646: Format=Flowed; Original
X-MIMEOLE: Produced By Microsoft MimeOLE V6.0.6000.16545
Content-Transfer-Encoding: quoted-printable
X-UIDL: 000000000016bd0d.0000a74f
X-MSP-STORE: Tue, 11 Mar 2008 21:57:01 +0100

Il y a effectivement des différences de codage. Mais mon correspondant me
dit qu'il ne change rien. Pourquoi WM utilise-t-il alors des paramètres
différents ?

Cordialement

--

F.


Pierre TORRIS
Le #1551352
Faelan
Bonjour !

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5 environ
(c'est aléatoire), les mails qui me parviennent de lui sont mal codés. Il y a
des caractères de contrôle comme é ou , etc..., dans le texte du
message. Et dans ce cas, s'il y a une pièce jointe, elle est illisible. les
messages suivants sont corrects, jusqu'à ce que le problème se reproduise,
pour une raison inconnue....
Inutile de préciser qu'il ne change rien à la configuration : mais une fois
de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit....

Où chercher ?


Bonjour,

En complément de la réponse de Luc, les messages que vous recevez
utilisent le codage QP (Quoted Printable) US-ASCII 7 bits, utilisé pour
coder un texte utilisant un jeu de caractères 8 bits (caractères
accentués). Si la messagerie n'est pas réglée en ce sens, il est
possible que cela soit effectué par certains serveurs lors du
transfert.

Dans ce codage, les caractères 8 bits sont remplacés par le caractère =
suivi d'un code hexadécimal. Ainsi le caractère "é" est codé é

Un mot comme "été" le sera donc comme ceci : été

En dépannage, je signale à cet effet un outil nommé "MelQuote",
compatible Vista, susceptible de remettre en forme vos messages
dénaturés et de décoder (entre autres) le codage QP :
http://www.ptorris.com/windows.php#melquote

Dans votre messagerie, il suffit de copier votre texte qui apparaîtra
automatiquement dans le logiciel. Un clic sur l'option souhaité (E9 ->
é) vous affichera le texte décodé. Le logiciel peut être automatisé
avec les options de son choix. Cela fait, un simple Copier/Coller
depuis n'importe quel éditeur transforme le texte à sa guise. ;-)

--
Bien à vous. Pierre TORRIS
www.ptorris.com

Faelan
Le #1551348
"Pierre TORRIS" news:
Faelan
Bonjour !

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5
environ (c'est aléatoire), les mails qui me parviennent de lui sont mal
codés. Il y a des caractères de contrôle comme é ou , etc..., dans
le texte du message. Et dans ce cas, s'il y a une pièce jointe, elle est
illisible. les messages suivants sont corrects, jusqu'à ce que le
problème se reproduise, pour une raison inconnue....
Inutile de préciser qu'il ne change rien à la configuration : mais une
fois de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit....

Où chercher ?


Bonjour,

En complément de la réponse de Luc, les messages que vous recevez
utilisent le codage QP (Quoted Printable) US-ASCII 7 bits, utilisé pour
coder un texte utilisant un jeu de caractères 8 bits (caractères
accentués). Si la messagerie n'est pas réglée en ce sens, il est possible
que cela soit effectué par certains serveurs lors du transfert.

Dans ce codage, les caractères 8 bits sont remplacés par le caractère =
suivi d'un code hexadécimal. Ainsi le caractère "é" est codé é

Un mot comme "été" le sera donc comme ceci : été

En dépannage, je signale à cet effet un outil nommé "MelQuote", compatible
Vista, susceptible de remettre en forme vos messages dénaturés et de
décoder (entre autres) le codage QP :
http://www.ptorris.com/windows.php#melquote

Dans votre messagerie, il suffit de copier votre texte qui apparaîtra
automatiquement dans le logiciel. Un clic sur l'option souhaité (E9 -> é)
vous affichera le texte décodé. Le logiciel peut être automatisé avec les
options de son choix. Cela fait, un simple Copier/Coller depuis n'importe
quel éditeur transforme le texte à sa guise. ;-)

--
Bien à vous. Pierre TORRIS
www.ptorris.com


Bonjour

Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages sont
"normaux" et qu'il dit ne rien changer dans la configuration.

--

F.


Pierre TORRIS
Le #1551346
Faelan
"Pierre TORRIS" news:
Faelan
Bonjour !

J'ai un ami au Canada avec qui je corresponds qui a des problèmes avec
Windows Mail. La plupart du temps, tout va bien. Mais une fois sur 5
environ (c'est aléatoire), les mails qui me parviennent de lui sont mal
codés. Il y a des caractères de contrôle comme é ou , etc..., dans le
texte du message. Et dans ce cas, s'il y a une pièce jointe, elle est
illisible. les messages suivants sont corrects, jusqu'à ce que le problème
se reproduise, pour une raison inconnue....
Inutile de préciser qu'il ne change rien à la configuration : mais une
fois de temps en temps, c'est mal codé.
Il a réinstallé récemment son Vista, et le problème se reproduit....

Où chercher ?


Bonjour,

En complément de la réponse de Luc, les messages que vous recevez utilisent
le codage QP (Quoted Printable) US-ASCII 7 bits, utilisé pour coder un
texte utilisant un jeu de caractères 8 bits (caractères accentués). Si la
messagerie n'est pas réglée en ce sens, il est possible que cela soit
effectué par certains serveurs lors du transfert.

Dans ce codage, les caractères 8 bits sont remplacés par le caractère =
suivi d'un code hexadécimal. Ainsi le caractère "é" est codé é

Un mot comme "été" le sera donc comme ceci : été

En dépannage, je signale à cet effet un outil nommé "MelQuote", compatible
Vista, susceptible de remettre en forme vos messages dénaturés et de
décoder (entre autres) le codage QP :
http://www.ptorris.com/windows.php#melquote

Dans votre messagerie, il suffit de copier votre texte qui apparaîtra
automatiquement dans le logiciel. Un clic sur l'option souhaité (E9 -> é)
vous affichera le texte décodé. Le logiciel peut être automatisé avec les
options de son choix. Cela fait, un simple Copier/Coller depuis n'importe
quel éditeur transforme le texte à sa guise. ;-)

-- Bien à vous. Pierre TORRIS
www.ptorris.com


Bonjour

Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages sont
"normaux" et qu'il dit ne rien changer dans la configuration.


Bonjour,

Dans l'ensemble des messages, il faut distinguer les nouveaux messages
des messages en réponse. Sinon, vérifier s'il s'agit de messages HTML
ou texte brut, car il semblerait que ce soit ces derniers qui vous
causent soucis.

Vérifier les réglages définis dans le format des messages :
Format d'envoi du courrier
Paramètres de texte brut
Format du message [MIME]
Coder le texte en utilisant : Aucun

--
Bien à vous. Pierre TORRIS
www.ptorris.com



Exelmans
Le #1551345
bonjour "Faelan"


En complément de la réponse de Luc, les messages que vous
recevez utilisent le codage QP (Quoted Printable) US-ASCII 7
bits, utilisé pour coder un texte utilisant un jeu de
caractères 8 bits (caractères accentués). Si la messagerie
n'est pas réglée en ce sens, il est possible que cela soit
effectué par certains serveurs lors du transfert.




Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami
envoie de temps à autre un message de ce type alors que tous ses
autres messages sont "normaux" et qu'il dit ne rien changer dans
la configuration.


Voyez ci-dessus la partie de la réponse de Pierre TORRIS qui vous
a échappée !
les serveurs et relais intermédiaires peuvent *parfois*
transcoder seuls !!

--
Ex.


Faelan
Le #1551339
"Exelmans" news:

bonjour "Faelan"


En complément de la réponse de Luc, les messages que vous recevez
utilisent le codage QP (Quoted Printable) US-ASCII 7 bits, utilisé pour
coder un texte utilisant un jeu de caractères 8 bits (caractères
accentués). Si la messagerie n'est pas réglée en ce sens, il est
possible que cela soit effectué par certains serveurs lors du transfert.




Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages
sont "normaux" et qu'il dit ne rien changer dans la configuration.


Voyez ci-dessus la partie de la réponse de Pierre TORRIS qui vous a
échappée !
les serveurs et relais intermédiaires peuvent *parfois* transcoder seuls
!!


Cela ne m'a pas échappé.
Les messages (corrects ou non) sont envoyés *exactement* dans les mêmes
conditions, strictement de la même façon (les deux entêtes que j'ai fournies
viennent en fait de deux messages qui ont le même contenu en pratique : un
texte et une photo jpg attachée).
Pourquoi des serveurs en transcoderaient certains et pas d'autres ?
Cela ne se passe qu'avec WM. Si mon ami utilise thunderbird, le problème ne
se pose pas : tous les messages sont corrects.

--

F.



Faelan
Le #1551338
"Pierre TORRIS" news:
Bonjour

Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages
sont "normaux" et qu'il dit ne rien changer dans la configuration.


Bonjour,

Dans l'ensemble des messages, il faut distinguer les nouveaux messages des
messages en réponse. Sinon, vérifier s'il s'agit de messages HTML ou texte
brut, car il semblerait que ce soit ces derniers qui vous causent soucis.

Vérifier les réglages définis dans le format des messages :
Format d'envoi du courrier
Paramètres de texte brut
Format du message [MIME]
Coder le texte en utilisant : Aucun

--
Bien à vous. Pierre TORRIS
www.ptorris.com


A la place de "aucun", il a indiqué "base64". Je vais lui faire changer et
refaire des essais.
Merci.

--

F.


Faelan
Le #1581446
"Faelan"

Bonjour

Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages
sont "normaux" et qu'il dit ne rien changer dans la configuration.


Bonjour,

Dans l'ensemble des messages, il faut distinguer les nouveaux messages
des messages en réponse. Sinon, vérifier s'il s'agit de messages HTML ou
texte brut, car il semblerait que ce soit ces derniers qui vous causent
soucis.

Vérifier les réglages définis dans le format des messages :
Format d'envoi du courrier
Paramètres de texte brut
Format du message [MIME]
Coder le texte en utilisant : Aucun

--
Bien à vous. Pierre TORRIS
www.ptorris.com


A la place de "aucun", il a indiqué "base64". Je vais lui faire changer et
refaire des essais.
Merci.

--

F.


Ca semble fonctionner. Merci.

--
F.



Faelan
Le #1581445
"Faelan"
"Exelmans" news:

bonjour "Faelan"


En complément de la réponse de Luc, les messages que vous recevez
utilisent le codage QP (Quoted Printable) US-ASCII 7 bits, utilisé pour
coder un texte utilisant un jeu de caractères 8 bits (caractères
accentués). Si la messagerie n'est pas réglée en ce sens, il est
possible que cela soit effectué par certains serveurs lors du
transfert.




Merci pour votre réponse.

Ce que je voudrais comprendre, c'est pourquoi le WM de mon ami envoie de
temps à autre un message de ce type alors que tous ses autres messages
sont "normaux" et qu'il dit ne rien changer dans la configuration.


Voyez ci-dessus la partie de la réponse de Pierre TORRIS qui vous a
échappée !
les serveurs et relais intermédiaires peuvent *parfois* transcoder seuls
!!


Cela ne m'a pas échappé.
Les messages (corrects ou non) sont envoyés *exactement* dans les mêmes
conditions, strictement de la même façon (les deux entêtes que j'ai
fournies viennent en fait de deux messages qui ont le même contenu en
pratique : un texte et une photo jpg attachée).
Pourquoi des serveurs en transcoderaient certains et pas d'autres ?
Cela ne se passe qu'avec WM. Si mon ami utilise thunderbird, le problème
ne se pose pas : tous les messages sont corrects.

--

F.


Effectivement, d'après ce que je constate, des messages identiques peuvent
être traités différemment par les serveurs si le format n'est pas bien
choisi à l'expédition. Etrange....

--
F.




Publicité
Poster une réponse
Anonyme