Xinerama pb forme du curseur sur 2iem écran

Le
Bulot Grégory
--Boundary-00=_DsB1HEpt8eaUPP3
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour,

j'ai un ptit soucis avec le xinerama, lorsque mon curseur de souris se trou=
ve
sur le 2iem écran, celui deviens un gros carré a la place d'une flèch=
e

j'ai une ati, j'utilise le pilote ati (xorg utilise automatiquement le pilo=
te
radeon)

je n'ai s pas ce problème si je ne dépasse pas la résolution de 1024x=
768 sur
les 2 écrans

actuellement le 1er ecran est en 1280x1024, le 2iem écran est en 1024x768=

(j'ai donc le carré en guise de curseur sur le 2ieme écran)

Sinon le reste fonctionne bien, mais il n'est pas facile de sélectionner=

quelquechose sur le 2ieme écran


J'ai voulu essayer quelques appli, impossible de lancer gl117 ni mplayer (e=
n
ligne de commande : erreur de segmentation)

je joints mon xorg.conf

Note en regardant mon Xorg.0.log, j'ai des trucs de ce genre :
(WW) RADEON(0): Direct Rendering Disabled -- Dual-head configuration is not=

working with DRI at present.
(WW) RADEON(0): Invalid Monitor type specified for 2nd port
(II) RADEON(1): No video input capabilities detected and no information is=

provided - disabling multimedia i2c

--Boundary-00=_DsB1HEpt8eaUPP3
Content-Type: text/plain;
charset="iso-8859-1";
name="xorg.conf"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename="xorg.conf"


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Jan 11 15:05:59 PST 2008
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
Screen "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
Option "Xinerama" "true"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
#Load "glx"
Load "int10"
Load "vbe"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"

EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
#Driver "fglrx"
Driver "ati"
BusID "PCI:1:0:0"
Option "DesktopSetup" "horizontal" #Enable Big Desktop
#Option "Mode2" "1280x1024" #Resolution for second monitor
#Option "MonitorLayout" "CRT,CRT" #the types of monitors that is connected LVDS = LCD, CRT, AUTO
#Option "MonitorLayout" "tmds,crt" #if you have DVI and crt.
Option "MonitorLayout" "crt,crt" .

EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "ati"
BusID "PCI:1:0:0"
Screen 1
Option "MergedFB" "True" # si actif, desactiver xinerama sinon retour en mode clone
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection


--Boundary-00=_DsB1HEpt8eaUPP3--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
giggz
Le #9701941
Bulot Grégory a écrit :
Bonjour,




slt,


j'ai un ptit soucis avec le xinerama, lorsque mon curseur de souris se trouve
sur le 2iem écran, celui deviens un gros carré a la place d'une flèche

j'ai une ati, j'utilise le pilote ati (xorg utilise automatiquement le pilote
radeon)

je n'ai s pas ce problème si je ne dépasse pas la résolution de 1024x768 sur
les 2 écrans

actuellement le 1er ecran est en 1280x1024, le 2iem écran est en 1024x768
(j'ai donc le carré en guise de curseur sur le 2ieme écran)

Sinon le reste fonctionne bien, mais il n'est pas facile de sélectionner
quelquechose sur le 2ieme écran


J'ai voulu essayer quelques appli, impossible de lancer gl117 ni mplayer (en
ligne de commande : erreur de segmentation)

je joints mon xorg.conf

Note en regardant mon Xorg.0.log, j'ai des trucs de ce genre :
(WW) RADEON(0): Direct Rendering Disabled -- Dual-head configuration is not
working with DRI at present.
(WW) RADEON(0): Invalid Monitor type specified for 2nd port
(II) RADEON(1): No video input capabilities detected and no information is
provided - disabling multimedia i2c




Bon je vais répondre à côté mais pourquoi tu n'utilises pas xrandr ? es
tu en SID ? si oui alors ne fais pas du xinerama mais utilises xrandr.
Tu vas trouver pleins de tutos sur le net. Tu prends un xorg "normal"
single head (si tu veux je t'envoie le mien) et puis qd tu veux un
bureau étendu tu fais un petit coup de xrandr dans un terminal. Par
exemple :
xrandr --output VGA-0 --left-of LVDS avec si tu veux des options --auto
qui vont bien.

puis pour revenir à la normal :
xrandr --output VGA-0 --same-as LVDS
ou
xrandr --output VGA-0 --off

Tu auras l'accélération graphique sur tes 2 bureaux (pour les
résolutions que tu donnes) et puis ça marchera...

à noter qu'en clone mode tu devras choisir un écran pour le pilote xv.
En bureau étendu pas de problème tu pourras utiliser mplayer sur les 2.

Bonne fin de journée
GiGGz






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9701931
Le dimanche 9 mars 2008 18:21, giggz a écrit :

Bon je vais répondre à côté mais pourquoi tu n'utilises pas xrand r ? es
tu en SID ? si oui alors ne fais pas du xinerama mais utilises xrandr.



je suis en etch, mais
# grep -i randr /var/log/Xorg.0.log
(==) RandR enabled
(==) RandR enabled
(II) Initializing built-in extension RANDR

et bizarrement :
$ xrandr
Xlib: extension "RANDR" missing on display ":0.0".
giggz
Le #9701921
Bulot Grégory a écrit :
Le dimanche 9 mars 2008 18:21, giggz a écrit :

Bon je vais répondre à côté mais pourquoi tu n'utilises pas xrandr ? es
tu en SID ? si oui alors ne fais pas du xinerama mais utilises xrandr.



je suis en etch, mais
# grep -i randr /var/log/Xorg.0.log
(==) RandR enabled
(==) RandR enabled
(II) Initializing built-in extension RANDR

et bizarrement :
$ xrandr
Xlib: extension "RANDR" missing on display ":0.0".




je ne pense pas que ça marche en etch. c'est arrivé assez recemment sous
SID avec le driver libre ati...par contre en etch utilise le mode
mergedFB. ça marchait mieux pour moi que le xinerama

Ciao

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
atlantis
Le #9701881
Bonjour,
J'ai eu le même problème sur une ubuntu avec le driver proprio (fglrx).
La solution est dans le nouveau driver ATI.


Bulot Grégory a écrit :
Bonjour,

j'ai un ptit soucis avec le xinerama, lorsque mon curseur de souris se trouve
sur le 2iem écran, celui deviens un gros carré a la place d'une flèche

j'ai une ati, j'utilise le pilote ati (xorg utilise automatiquement le pilote
radeon)

je n'ai s pas ce problème si je ne dépasse pas la résolution de 1024x768 sur
les 2 écrans

actuellement le 1er ecran est en 1280x1024, le 2iem écran est en 1024x768
(j'ai donc le carré en guise de curseur sur le 2ieme écran)

Sinon le reste fonctionne bien, mais il n'est pas facile de sélectionner
quelquechose sur le 2ieme écran


J'ai voulu essayer quelques appli, impossible de lancer gl117 ni mplayer (en
ligne de commande : erreur de segmentation)

je joints mon xorg.conf

Note en regardant mon Xorg.0.log, j'ai des trucs de ce genre :
(WW) RADEON(0): Direct Rendering Disabled -- Dual-head configuration is not
working with DRI at present.
(WW) RADEON(0): Invalid Monitor type specified for 2nd port
(II) RADEON(1): No video input capabilities detected and no information is
provided - disabling multimedia i2c




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bernard Siaud alias Troumad
Le #9701841
giggz a écrit :
xrandr --output VGA-0 --same-as LVDS


Tu l'as trouvé où l'option --same-as ?
Ou cmment faire pour avoir le man anglais quand on a le man français ?
--
Amicalement vOOotre, Troumad Alias Bernard SIAUD, http://troumad.org
N'envoyez que des documents avec des formats ouverts, comme
http://fr.openoffice.org
Adresse electronique speciale liste

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #9701831
Bernard Siaud alias Troumad a écrit :
giggz a écrit :
xrandr --output VGA-0 --same-as LVDS


Tu l'as trouvé où l'option --same-as ?
Ou cmment faire pour avoir le man anglais quand on a le man français ?



ben j'ai fait "xrandr --help"

:)
pour l'uatre question je sais po trop...as tu essayer en faisant un
export des variables qui touchent la localisation ? du style LC_ALL ou
un truc comme ça...

BOnne journée

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9701751
GiGGz, lundi 10 mars 2008, 14:55:22 CET
[…]
pour l'uatre question je sais po trop...as tu essayer en faisant un
export des variables qui touchent la localisation ? du style LC_ALL ou
un truc comme ça...



Pas besoin d’export.
Il suffit de modifier la variable sur la même ligne que la
commande :
$ LANG=C man xrandr

La modification n’est alors valable que pour la commande (à
répéter en cas d’enchaînement : toto | LAN G=C tata | LANG=C titi
pour | || && et ; ). N’est évidemment pas exportée pour l es
sous-shells : LANG=C echo `date` affiche la date dans la locale
usuelle.

--
Sylvain Sauvage
Bulot Grégory
Le #9701671
Le dimanche 9 mars 2008 19:51, giggz a écrit :
Bulot Grégory a écrit :
> Le dimanche 9 mars 2008 18:21, giggz a écrit :
>> Bon je vais répondre à côté mais pourquoi tu n'utilises pas xr andr ? es
>> tu en SID ? si oui alors ne fais pas du xinerama mais utilises xrandr.
>
> je suis en etch, mais
> # grep -i randr /var/log/Xorg.0.log
> (==) RandR enabled
> (==) RandR enabled
> (II) Initializing built-in extension RANDR
>
> et bizarrement :
> $ xrandr
> Xlib: extension "RANDR" missing on display ":0.0".

je ne pense pas que ça marche en etch. c'est arrivé assez recemment s ous
SID avec le driver libre ati...par contre en etch utilise le mode
mergedFB. ça marchait mieux pour moi que le xinerama



je vais réésayer en MergeFB (me rappel plus de l'erreur)

j'ai un autre truc auquel je n'avais pas fais gaffe, je n'ais plus accès aux
consoles texte (F1...F6), je boot via grub en vgaw3
GiGGz
Le #9701621
Bulot Grégory a écrit :
Le dimanche 9 mars 2008 19:51, giggz a écrit :
Bulot Grégory a écrit :
Le dimanche 9 mars 2008 18:21, giggz a écrit :
Bon je vais répondre à côté mais pourquoi tu n'utilises pas xrandr ? es
tu en SID ? si oui alors ne fais pas du xinerama mais utilises xrandr.


je suis en etch, mais
# grep -i randr /var/log/Xorg.0.log
(==) RandR enabled
(==) RandR enabled
(II) Initializing built-in extension RANDR

et bizarrement :
$ xrandr
Xlib: extension "RANDR" missing on display ":0.0".


je ne pense pas que ça marche en etch. c'est arrivé assez recemment sous
SID avec le driver libre ati...par contre en etch utilise le mode
mergedFB. ça marchait mieux pour moi que le xinerama



je vais réésayer en MergeFB (me rappel plus de l'erreur)

j'ai un autre truc auquel je n'avais pas fais gaffe, je n'ais plus accès aux
consoles texte (F1...F6), je boot via grub en vgaw3




ça veut dire quoi "je n'ais plus accès aux consoles textes" ? J'ai
compris que tu parles des virtual consoles...mais pourquoi tu n'y as
plus accès ? Essaye sans le framebuffer vesafb...(sans l'option vga=)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9701561
Le mardi 11 mars 2008 11:22, GiGGz a écrit :


ça veut dire quoi "je n'ais plus accès aux consoles textes" ? J'ai
compris que tu parles des virtual consoles...mais pourquoi tu n'y as
plus accès ?




oops, effectivement, manque de précision:
bah en fait y'a pas 'login' qui apparait sur tty1...tty6

Essaye sans le framebuffer vesafb...(sans l'option vga=)



je tenterais ce soir en rentrant du taf
Publicité
Poster une réponse
Anonyme