XProtect

Le
g4fleurot
Selon cet article, Xprotect a été mis à jour le 5 février.
<http://www.macg.co/os-x/2014/02/xprotect-mis-jour-pour-bloquer-les-anciennes-versions-de-flash-79718>
Outre la procédure décrite, on peut aussi lire le contenu du fichier
/System/Bibliothèque/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist
et chez moi, je lis :
<dict>
<key>MinimumPlugInBundleVersion</key>
<string>11.8.800.94</string>
<key>PlugInUpdateAvailable</key>
<true/>
</dict>
Le fichier est daté du 08/10/2013, modifié le 02/2/2013.
J'en déduis qu'il ne s'est pas mis à jour chez moi.

Quelqu'un saurait-il comment se met à jour ce fichier ?

Sous MAC OS 10.8, il y avait un daemon ou un system agent
xprotectupdater, mais je ne le trouve plus sous Mavericks.

--
Gérard FLEUROT <g4fleurot@free.fr> plus un
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Matt
Le #25983832
On Lun 10 février 2014 (14:19),
Fleuger
Quelqu'un saurait-il comment se met à jour ce fichier ?



Avant 10.9, par le biais d'un démon launchd(8). A partir de 10.9, cela
se fait différemment à ce que j'ai lu (probablement lors de la recherche
de mise à jour via le Mac App Store).

#v+
% sudo launchctl list | grep -i xprotect
Mot de passe :
- 0 com.apple.xprotectupdater-init
- 252 com.apple.xprotectupdater
#v-

Regarde dans /var/log/system.log.* (avec bzgrep(1) ou via Console.app).

--
“One bad programmer can easily create two new jobs a year.” – David Parnas
g4fleurot
Le #25984172
Matt
Avant 10.9, par le biais d'un démon launchd(8). A partir de 10.9, cela
se fait différemment à ce que j'ai lu (probablement lors de la recherche
de mise à jour via le Mac App Store).

#v+
% sudo launchctl list | grep -i xprotect
Mot de passe :
- 0 com.apple.xprotectupdater-init
- 252 com.apple.xprotectupdater
#v-

Regarde dans /var/log/system.log.* (avec bzgrep(1) ou via Console.app).



Merci Matt pour la réponse rapide.

Nada, que dalle, nil, rien :
pas de réponse à la ligne
sudo launchctl list | grep -i xprotect
(retour direct au prompt)

Dans Console system.log, en filtrant xprotect, j'ai :
Feb 10 16:32:47 gefleurot.local sudo[7194]: fleuger : TTY=ttys001 ;
PWD=/Users/fleuger ; USER=root ; COMMAND=/bin/launchctl list | grep -i
xprotect
(c'est ce que je viens de faire)
Dans system.log.6.gz, (les archives de système.log) j'ai :
Feb 6 16:08:02 gefleurot.local sudo[2939]: fleuger : TTY=ttys001 ;
PWD=/Users/fleuger ; USER=root ; COMMAND=/bin/launchctl start
com.apple.xprotectupdater
Une commande que j'avais lancé le 6, mais restée sans réponse.

J'ai recherché dans le DVD d'install OSX 10.9 "xprotect" avec Pacifist :
il n'y a que :
/System/Bibliothèque/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist
/System/Bibliothèque/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.plist
Pas de démon xprotectupdater et j'ai bien ces deux fichiers à leur place
dans le système.

Il est vrai que j'avais mis Flash à jour la veille de la mise à jour
xprotect.
Ceci pourrait-il expliquer celà ?

--
Gérard FLEUROT
michel.vauquois
Le #25984302
Fleuger
Selon cet article, Xprotect a été mis à jour le 5 février.
<http://www.macg.co/os-x/2014/02/xprotect-mis-jour-pour-bloquer-les-ancien
nes-versions-de-flash-79718> Outre la procédure décrite, on peut aussi
lire le contenu du fichier
/System/Bibliothèque/CoreServices/CoreTypes.bundle/Contents/Resources/XPro
tect.meta.plist
et chez moi, je lis :
<dict>
<key>MinimumPlugInBundleVersion</key>
<key>PlugInUpdateAvailable</key>
<true/>
</dict>
Le fichier est daté du 08/10/2013, modifié le 02/2/2013.
J'en déduis qu'il ne s'est pas mis à jour chez moi.



Ma config correspond bien à ce que dit l'article en question et mes 2
fichiers XProtect.meta.plist et XProtect.plist sont effectivement datés
du 5 février 2014.

Quelqu'un saurait-il comment se met à jour ce fichier ?



Normalement, c'est mis à jour en même temps que la mise à jour de
Flash Player en version 12.0.0.44, non ?
--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
http://photos.michelvauquois.free-h.fr/
http://art-doise.michelvauquois.free-h.fr
Matt
Le #25984382
On Lun 10 février 2014 (16:59),
Fleuger
Il est vrai que j'avais mis Flash à jour la veille de la mise à jour
xprotect.
Ceci pourrait-il expliquer celà ?



Il serait logique que ce soit le cas; XProtect détectant que le numéro
de version du plugin Flash est supérieur à celui qui doit être bloqué,
ne voit pas l'utilité de télécharger le dernier manifest.

Ça peut se vérifier en changeant le numéro de version du plugin Flash
dans :

/Library/Internet Plug-Ins/Flash Player.plugin/Contents/version.plist

--
“Software developers like to solve problems. If there are no problems handily
available, they will create their own problems.” – Anonymous
g4fleurot
Le #25984452
MV
Normalement, c'est mis à jour en même temps que la mise à jour de
Flash Player en version 12.0.0.44, non ?



Oui, mais comme je l'ai dit par ailleurs, j'ai fait la mise à jour de
Flash la veille de Xprotect, avant même que le panneau de préférences
Flash m'ait annoncé qu'il y avait une nouvelle version, (J'avais
découvert cette nouvelle version dans les fils RSS de MacUpdate).

--
Gérard FLEUROT
michel.vauquois
Le #25984492
Fleuger
Oui, mais comme je l'ai dit par ailleurs, j'ai fait la mise à jour de
Flash la veille de Xprotect, avant même que le panneau de préférences
Flash m'ait annoncé qu'il y avait une nouvelle version, (J'avais
découvert cette nouvelle version dans les fils RSS de MacUpdate).



J'ai fait comme toi... et je n'ai pourtant pas cette bizarrerie !
--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
http://photos.michelvauquois.free-h.fr/
http://art-doise.michelvauquois.free-h.fr
g4fleurot
Le #25984952
Matt
Ça peut se vérifier en changeant le numéro de version du plugin Flash



J'ai mis 11.0.0.0 d'abord dans version.plist et voyant que la préférence
système ne changeait pas, j'ai changé aussi dans info.plist et cette
fois-ci, préférence système m'a indiqué 11.0.0.0 en version installée.
J'ai relancé la session, ouvert mise à jour de logiciels, réinstallé
Flash 12.0.0.44, vérifié Xprotect après chaque intervention et le
fichier XProtect.meta.plist ne change pas.

Mystère...
--
Gérard FLEUROT
derfnam
Le #25984942
Fleuger
Selon cet article, Xprotect a été mis à jour le 5 février.
<http://www.macg.co/os-x/2014/02/xprotect-mis-jour-pour-bloquer-les-ancien
nes-versions-de-flash-79718> Outre la procédure décrite, on peut aussi
lire le contenu du fichier
/System/Bibliothèque/CoreServices/CoreTypes.bundle/Contents/Resources/XPro
tect.meta.plist et chez moi, je lis : <dict>
<key>PlugInUpdateAvailable</key> <true/> </dict> Le fichier est daté du
08/10/2013, modifié le 02/2/2013. J'en déduis qu'il ne s'est pas mis à
jour chez moi.

Quelqu'un saurait-il comment se met à jour ce fichier ?

Sous MAC OS 10.8, il y avait un daemon ou un system agent xprotectupdater,
mais je ne le trouve plus sous Mavericks.



Effectivement, sous ML ici, XProtect.plist et XProtect.meta.plist sont
bien datés du 05/02. En revanche, pour chacun des 2 fichiers, j'ai la
même date et la même heure sur la ligne "Création" que sur la ligne
"Modifié". Est-ce normal?
--
Manfred
42° 42' 0" N, 9° 26' 59" E.
iMac Intel Core 2 Duo, OS X 10.8.5.
"I would trade all my technology for an afternoon with Socrates."(S.J.)
Matt
Le #25985192
On Lun 10 février 2014 (20:17),
Fleuger
J'ai mis 11.0.0.0 d'abord dans version.plist et voyant que la préférence
système ne changeait pas, j'ai changé aussi dans info.plist et cette
fois-ci, préférence système m'a indiqué 11.0.0.0 en version installée.
J'ai relancé la session, ouvert mise à jour de logiciels, réinstallé
Flash 12.0.0.44, vérifié Xprotect après chaque intervention et le
fichier XProtect.meta.plist ne change pas.

Mystère...



N'ayant pas 10.9 je ne peux malheureusement pas t'aider davantage.

--
“There are two types of people in this world: those who understand recursion
and those who don’t understand that there are two types of people in this
world.” – Anonymous
g4fleurot
Le #25985832
Matt
N'ayant pas 10.9 je ne peux malheureusement pas t'aider davantage.



C'est déjà sympa de m'avoir donné toutes ces indications. :-)

Et il n'y a pas péril en la demeure.
Alors... Qui vivra verra.

--
Gérard FLEUROT
Publicité
Poster une réponse
Anonyme