Le projet Tor ambitionne un fork de Firefox

Le par  |  12 commentaire(s) Source : Blog du projet Tor
Tor

Le projet Tor envisage de maintenir sa propre version de Firefox baptisée Tor Browser.

TorTor est présenté comme un logiciel libre et un réseau décentralisé afin de préserver l'anonymat de ses utilisateurs. Tout ordinateur peut prendre part à The Onion Router où le trafic est chiffré et chemine aléatoirement parmi les nœuds Tor. Chaque nœud ne connaît que celui qui lui a transmis les données et celui auquel il va les transmettre.

Les utilisateurs qui souhaitent avoir recours à Tor pour surfer sur la Toile et échapper à une forme de surveillance sont dirigés vers l'installation d'une extension Firefox du nom de Torbutton et d'un logiciel Tor. Un bouton que le projet Tor devrait retirer des modules Mozilla proposés.

Le projet Tor envisage en effet de se consacrer au développement d'un fork de Firefox pour une utilisation plus aisée de Tor. Un navigateur baptisé Tor Browser. Plusieurs raisons sont invoquées dont une certaine confusion pour l'utilisateur avec Torbutton et le fait de savoir s'il est effectivement protégé ou pas, la difficulté de maintenir l'extension fonctionnelle en étant tributaire des corrections de bugs apportées dans Firefox.

Complément d'information

Vos commentaires Page 1 / 2

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patheticcockroach Hors ligne VIP 7663 points
Le #776291
"difficulté de maintenir l'extension fonctionnelle en étant tributaire des corrections de bugs apportées dans Firefox"
=>je pense plutôt qu'ils en ont eu marre, comme bon nombre de dévelopeurs d'extension Fx, de devoir reprogrammer leur extension à chaque release de Fx (Mozilla ayant un malin plaisir à casser la compatibilité des extensions aussi souvent que possible...)
Le #776301
@patheticcockroach
Je ne suis pas convaincu de ce que tu affirmes.
Bien souvent il suffit de modifier la borne supérieure des versions supportées par l'extension (faut ouvrir le zip pour ça) pour que l'extension fonctionne de nouveau.
Alors, est-ce la faute à Mozilla ou est-ce plutôt un comportement conservateur des développeurs ?
Lesquels limitent volontairement leur version à la version courante de firefox peut-être par crainte ou, plutôt, par souci de faire monter le nombre de téléchargements ?
db

Le #776311
ils auraient plutôt du faire un fork de chromium...parce que firefox et les bugs/failles ça va leur faire un sacré boulot de maintenance
Le #776331
@InsTeR

Arrête de fumer la moquette.
Firefox 4 fonctionne très bien et a tel point qu'après avoir quitté FF pour Chromium je suis revenu et resté avec Firefox 4.

patheticcockroach Hors ligne VIP 7663 points
Le #776361
@Gourmet: pour les extensions un peu simples ou interagissant au final peu avec le navigataur ok, mais dès que l'extension fait des trucs un peu compliqués en interaction avec Fx (genre TabBrowserPreference) la compatibilité est régulièrement cassée. Personnellement j'en ai eu marre et j'ai arrêté de réparer mon extension, et je suis pas le seul (TabBrowserPreference, Add'n'Edit Cookies...).
Le #776401
@InsTeR les bugs /faille sont en général liés aux extensions que tu rajoutes....les éventuelles failles de FF sont rapidement comblé par les màj automatiques
Le #776411
@patheticcockroach : ou alors tu restes sur ta version de ff. Bon sang, on gueule quand ça bouge pas, on gueule quand ça bouge. Quand est-ce qu'on arrête de gueuler et qu'on fait avancer les choses ?
(Paradoxe de mon coup de gueule).
Le #776431
InsTeR :

C'est du troll de compétition la

Sinon je ne peux qu'adhérer, j'en ai plus que marre d'être tracer sur le net, ne serait-ce que lorsque je cherche un produit, et que je me le bouffe en pub sur les sites sur lesquels je surfe par la suite (je sais, j'ai déjà activé l'option sur firefox pour ne plus être tracé).

Donc ceci risque de m'intéresser fortement.

En attendant, j'utilise ceci :

Adresse Web :
http://www.toutes-les-solutions.fr/phpbb/topic1448.html
patheticcockroach Hors ligne VIP 7663 points
Le #776481
edit: oops, double post à cause d'un bug dans la fonction éditer...
patheticcockroach Hors ligne VIP 7663 points
Le #776491
@Tranber: 2 mots: compatibilité ascendante. On peut très bien moderniser le navigateur sans casser l'API à chaque nouvelle version! C'est ce que fait Chrome, par exemple... Et puis rester sur ma version de Fx (c'est Fx bordel, pas ff) ça fait pas bp avancer le Shmilblik du problème "mon extension n'est plus compatible avec la dernière version", car ce que veulent les utilisateurs c'est la dernière version (et ils n'ont pas vraiment tord car c'est en général la seule, avec son ancêtre directe, à recevoir les MAJ de sécurité ).

@FRANCKYIV: pour les traces tu as aussi Ghostery. Parce que bon, l'option dans Firefox il me semble que ça sert juste à dire aux sites qui le supportent "svp ne me tracez pas". Rien ne garantit que 1 ils comprennent l'instruction et que 2 ils la respectent. Avec Ghostery tu bloques automatiquement les trackers, c'est plus radical je trouve
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]