Android Oreo sur 5,7% des appareils mais Project Treble tape à la porte

Le par  |  14 commentaire(s)
Android-Oreo

Le taux d'adoption d'Android Oreo n'affole toujours pas les compteurs. Du mieux est attendu avec Android P grâce à Project Treble depuis Oreo.

Juste avant le début de la conférence Google I/O qui a eu lieu cette semaine, les chiffres sur le taux d'adoption des différentes versions d'Android ont été mis à jour.

Ces données se destinent d'abord aux développeurs afin de leur permettre d'optimiser leurs applications en fonction des profils de périphériques qui se détachent le plus. Cela étant, il est toujours intéressant de juger de l'adoption rapide ou non d'une nouvelle mouture d'Android.

Disponible depuis août 2017, Android Oreo affiche un taux d'adoption de 5,7 %. En l'occurrence, la présence d'Android 8.0 et 8.1 a été détectée sur des appareils s'étant connectés au Google Play Store sur une période de sept jours jusqu'au 7 mai.

Android 7.x Nougat affiche le taux d'adoption le plus élevé à 31,1 %, devant Android 6.0 Marshmallow (25,5 %) et Android 5.x Lollipop (22,4 %).

Android-taux-adoption-versions-mai-2018

Le coup d'envoi de la bêta d'Android P a été donné. La question sera encore une fois de savoir si par rapport à la situation actuelle, davantage d'utilisateurs pourront bénéficier plus rapidement des nouveautés de la nouvelle mouture après sa finalisation.

Les regards se tournent du côté des apports de Project Treble dans Android Oreo, avec une architecture de bas niveau modifiée dans le but de séparer le code spécifique des fournisseurs de puces et composants du framework Android.

Qualcomm a annoncé avoir collaboré avec Google. Ainsi, des appareils équipés de SoC Snapdragon 845, 660 et 636 sont susceptibles de bénéficier plus vite de la mise à jour vers Android P. Déjà avec la bêta d'Android P, des modèles compatibles avec Project Treble de plusieurs fabricants y ont accès.

Complément d'information

Vos commentaires Page 1 / 2

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #2013089
Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.
lepingouinenfoliedestroyer Connecté Vénéré 3727 points
Le #2013091
skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, j'aurais dit au minimum la version 6 !


Le #2013092
Project Treble n'est malheureusement pas fourni aux smartphones qui font la mise à jour de Nougat à Oreo, du coup Android P sera un succès pour le déploiement des smartphones de base en Oreo car Treble obligatoire, mais pour le reste c'est mort dans l'œuf...

À dans 2-3 ans pour voir les effets de Treble lorsque tout le monde (ou presque) aura changer de smartphone
Le #2013094
lepingouinenfoliedestroyer a écrit :

skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, j'aurais dit au minimum la version 6 !


Société de consommation : pourquoi changer tous les 6 Mois?

Il faudrait surtout que les fabricants mettent leur smartphone à jour, ce qui serait plus intelligent.
Je ne vois pas pourquoi je changerai mon téléphone qui n'a même pas 2 ans et qui été livré qu'avec Android 5.
le galaxy III de mon épouse fonctionne toujours correctement, pour ce qu'elle en fait, pourquoi changer? il a été fourni avec ANdroid 4.00, et il n'a jamais reçu de màj.
Google ne pourrais -t-il pas fournir un Android 6 ou 7 "allégé" pour ces smartphones ?
Le #2013095
Marsou a écrit :

lepingouinenfoliedestroyer a écrit :

skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, j'aurais dit au minimum la version 6 !


Société de consommation : pourquoi changer tous les 6 Mois?

Il faudrait surtout que les fabricants mettent leur smartphone à jour, ce qui serait plus intelligent.
Je ne vois pas pourquoi je changerai mon téléphone qui n'a même pas 2 ans et qui été livré qu'avec Android 5.
le galaxy III de mon épouse fonctionne toujours correctement, pour ce qu'elle en fait, pourquoi changer? il a été fourni avec ANdroid 4.00, et il n'a jamais reçu de màj.
Google ne pourrais -t-il pas fournir un Android 6 ou 7 "allégé" pour ces smartphones ?


Le problème n'est pas tant technique - je ne crois pas que la configuration requise pour Android ait beaucoup changé depuis 2-3 versions - que stratégique : les constructeurs ont-ils des budgets à allouer pour adapter chaque nouvelle version à un parc en augmentation ? Le choix rationnel de ne proposer que 2 ou 3 mises à niveau n'est-il pas simplement cohérent avec la logique économique (ingénierie, imposer un changement de matériel...)?

Espérons que Treble améliore les update, mais on peut craindre que les patchs sécurité arrivent seulement plus rapidement et que l'obsolescence logicielle persiste... J'espère me tromper évidemment
Le #2013096
skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, ce serait de l'obsolescence programmé...
Le #2013097
Je fais parti des 1% ...
Le #2013099
iFlo59 a écrit :

skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, ce serait de l'obsolescence programmé...


Oui mais ça cause tous les problèmes que l'on sait.
On en est à la version 9 !
Quand je parle de garder la version 4.4, ce sont déjà des années en arrière ...

Faut-il se trimbaler encore la version 2, comme on voit dans le graphe ??
Le #2013100
lepingouinenfoliedestroyer a écrit :

skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, j'aurais dit au minimum la version 6 !


J'essayais de trouver un compromis pour éviter aussi l'obsolescence programmée..
Le #2013111
skynet a écrit :

iFlo59 a écrit :

skynet a écrit :

Il faudrait que Google n'autorise sur son store que des versions de softs compatibles avec au minimum la version 4.4 ou 5.0
La segmentation se réduirait drastiquement.


Non, ce serait de l'obsolescence programmé...


Oui mais ça cause tous les problèmes que l'on sait.
On en est à la version 9 !
Quand je parle de garder la version 4.4, ce sont déjà des années en arrière ...

Faut-il se trimbaler encore la version 2, comme on voit dans le graphe ??


Ces appareils (les plus anciens bien entendu) ne sont plus éligible voire compatible à la nouvelle version d'Android.

Si on procède ainsi, on accélérera la fin de support de certains smartphones, ou alors le flashage des devices qui ne sont pas à la porté de tous.
Les constructeurs devraient alors, fournir un logiciel qui permettrait de flasher la rom très facilement (lorsqu'ils ne veulent plus suivre le matériel en question).

APPLE le fait bien, c'est bien le seul à ma connaissance qui propose la sauvegarde/restauration et/ou la mise à jour logiciel par l'iTune. (Bon... ma connaissance date de 2010, je ne pense pas qu'il y ait eu du changement depuis)
Suivre les commentaires
Poster un commentaire
Anonyme