Firefox se débarrasse des plugins sauf Flash

Le par  |  62 commentaire(s)
Firefox-10-ans

Les plugins NPAPI ne seront plus pris en charge avec la prochaine version majeure de Firefox. Une échappatoire avec Firefox ESR, tandis que le plugin Flash Player fera de la résistance.

La version 51 actuelle de Firefox sera la dernière à prendre en charge les plugins s'appuyant sur l'architecture NPAPI (Netscape Plugin API). Cette technologie n'est plus du tout moderne avec des risques inhérents de sécurité et de stabilité. L'heure est aux API Web natives.

Firefox-nouveau-logoLe 7 mars prochain, Firefox 52 sera ainsi la première version du navigateur de Mozilla à laisser de côté les plugins NPAPI. Ce rappel a récemment été fait par Mike Kaply, un consultant spécialisé dans la personnalisation de Firefox pour les entreprises.

Pour les professionnels qui pourraient encore avoir besoin des plugins avec Firefox, il souligne qu'un tel support sera par contre toujours d'actualité avec Firefox ESR (Extended Support Release) au-delà du 7 mars. Il se poursuivra jusqu'à début 2018.

La fin des plugins avec Firefox grand public souffre par ailleurs d'une seule exception incarnée par… Flash Player. Néanmoins, le plan de Mozilla est de réduire l'utilisation de Flash dans Firefox. C'est cette année que l'activation du plugin Flash par un site Web - et ce pour n'importe quel contenu - nécessitera l'aval de l'utilisateur avec un " cliquer pour activer " dans Firefox.

Complément d'information

Vos commentaires Page 1 / 7

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #1951505
C'est vraiment dommage pour flash ... C'était une technologie intéressante que j'avais appris à la faculté.

Maintenant, ce n'est plus qu'un plugin mis à jour uniquement pour des problèmes de sécurité ...
Le #1951507
Ils pourraient pas aussi enlever leur plugin nommé " Codec vidéo OpenH264 fourni par Cisco Systeme, Inc " ?

Pour alléger Firefox.
Le #1951508
Barbak a écrit :

Ils pourraient pas aussi enlever leur plugin nommé " Codec vidéo OpenH264 fourni par Cisco Systeme, Inc " ?

Pour alléger Firefox.


Très utile car sans lui, je pense que les vidéos que j'héberge sur mes serveurs ne fonctionneraient plus ...
Le #1951510
C'est pas vrai, il vont faire ça quand?
Le #1951511
FRANCKYIV a écrit :

C'est vraiment dommage pour flash ... C'était une technologie intéressante que j'avais appris à la faculté.

Maintenant, ce n'est plus qu'un plugin mis à jour uniquement pour des problèmes de sécurité ...


Pareil, quand la version 1 est sortie c'était une révolution pour les webmasters
Le #1951512
Adarion29 a écrit :

C'est pas vrai, il vont faire ça quand?


"Le 7 mars prochain, Firefox 52 sera ainsi la première version du navigateur de Mozilla à laisser de côté les plugins NPAPI."

Ça concerne "juste" les plug-ins, pas les extensions.
Le #1951513
Ouais mais bon, faut savoir évoluer aujourd'hui tout ce qui est fait en flash peut être refait en mieux avec WebGL ou du simple HTML5 donc bon.
Le #1951519
Subutox a écrit :

Adarion29 a écrit :

C'est pas vrai, il vont faire ça quand?


"Le 7 mars prochain, Firefox 52 sera ainsi la première version du navigateur de Mozilla à laisser de côté les plugins NPAPI."

Ça concerne "juste" les plug-ins, pas les extensions.


Ouep la disparition des extensions est prévu pour Firefox 57... faut se préparer moralement
Le #1951521
1for-matik a écrit :

Subutox a écrit :

Adarion29 a écrit :

C'est pas vrai, il vont faire ça quand?


"Le 7 mars prochain, Firefox 52 sera ainsi la première version du navigateur de Mozilla à laisser de côté les plugins NPAPI."

Ça concerne "juste" les plug-ins, pas les extensions.


Ouep la disparition des extensions est prévu pour Firefox 57... faut se préparer moralement


La disparition des extensions avec la technologie d'aujourd'hui ... mais y aura encore des extensions hein ... dis moi qu'il y aura encore des extensions !!!
Le #1951526
FRANCKYIV a écrit :

C'est vraiment dommage pour flash ... C'était une technologie intéressante que j'avais appris à la faculté.

Maintenant, ce n'est plus qu'un plugin mis à jour uniquement pour des problèmes de sécurité ...


A l'époque oui. Mais les bandes passantes ne sont plus les mêmes.

Sinon les éditeurs tiers suivent pas... Prenons java. Toujours pas possible d'exécuter du contenu en ligne depuis 3 versions de FF. Ou alors j'ai raté quelque chose...
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]